Das längste Thema

  • Hat wer vielleicht Tipps für PDF Viewer unter Windows die auch zb. Seiten zuschneiden können?

    Die Post erstellt leider immer Paketmarken in A4 (viel weise leere Fläche), ich muss die immer zuschneiden damit sie auf A5 passen.

    Oder gibts da ne andere Lösung?


    Sorry das ich letztens auf die Rückfragen vergessen habe zu antworten xD

  • Nach dem Upgrade auf Ubuntu 19.10 musste ich leider feststellen, dass sudo -s als ~-Pfad nicht mehr den des ursprünglichen Benutzers hat (also /home/...), sondern /root, ich musste sogar die .bashrc/.zshrc nach /root kopieren.Hat jemand ein Idee, wie ich das alte "Verhalten" (~ = /home/...) wiederherstellen kann?

  • oder hat das bei Anmeldung mittels Key-File keine Wirkung?

    IMHO wird bei SSH Keys nicht in die richtige Stelle im PAM gesprungen. Evtl. hilft es die PAM Einbindung ein wenig höher zu setzen, oder in der sshd den User nochmal explizit durch die 2fa.so zu schicken.


    Hat wer vielleicht Tipps für PDF Viewer unter Windows die auch zb. Seiten zuschneiden können?

    Gimp, Foxit

  • Habe von Hardware wenig/keine Ahnung: Bemerkt man beim RAM (Desktop-PC für Gaming/Grafik/Musikproduktion) einen großen Unterschied zwischen 2666 und 3000 MHz? Habe 2x16GB GSkill 3000MHz aber mein Mainboard unterstützt nur 2666 X/ (Ich hätte mich vor dem Kauf besser informieren sollen...)


    Laut Windows’ Taskmanager taktete der RAM aber nur mit 2133MHz, das konnte ich jedoch im BIOS auf 2666 ändern.


    Außerdem ist die Spannung im Auto-Modus für den Speicher auf 1,2V eingestellt, obwohl (glaub ich) XMP aktiviert ist und auf den Riegeln 1,35V steht. Dann sollte ich wahrscheinlich auch 1,35 V einstellen, nicht wahr? :wacko:


    Bitte nicht lachen, die Fragen sind ernst gemeint :D

    Meine Minecraft-Plugins auf SpigotMC (Open Source): www.mfnalex.de

    Discord: discord.jeff-media.com

  • Habe von Hardware wenig/keine Ahnung: Bemerkt man beim RAM (Desktop-PC für Gaming/Grafik/Musikproduktion) einen großen Unterschied zwischen 2666 und 3000 MHz? Habe 2x16GB GSkill 3000MHz aber mein Mainboard unterstützt nur 2666 X/ (Ich hätte mich vor dem Kauf besser informieren sollen...)


    Laut Windows’ Taskmanager taktete der RAM aber nur mit 2133MHz, das konnte ich jedoch im BIOS auf 2666 ändern.


    Außerdem ist die Spannung im Auto-Modus für den Speicher auf 1,2V eingestellt, obwohl (glaub ich) XMP aktiviert ist und auf den Riegeln 1,35V steht. Dann sollte ich wahrscheinlich auch 1,35 V einstellen, nicht wahr? :wacko:


    Bitte nicht lachen, die Fragen sind ernst gemeint :D

    Es kommt immer auch ein wenig auf die restliche Hardware an. Wenn du z.B. eine AMD APU nutzt, dann profitiert die sehr stark von höher getaktetem RAM. Wenn sowieso eine dedizierte GPU eingebaut ist, dürfte der Unterschied kaum spürbar sein. Prinipiell profitiert wohl AMD eher von der höheren Taktfrequenz. Aber das wird man so wohl nur in Benchmarks spüren. In normalen Workflows spielt das keine Rolle.

  • Es kommt immer auch ein wenig auf die restliche Hardware an. Wenn du z.B. eine AMD APU nutzt, dann profitiert die sehr stark von höher getaktetem RAM. Wenn sowieso eine dedizierte GPU eingebaut ist, dürfte der Unterschied kaum spürbar sein. Prinipiell profitiert wohl AMD eher von der höheren Taktfrequenz. Aber das wird man so wohl nur in Benchmarks spüren. In normalen Workflows spielt das keine Rolle.

    Danke für die Antwort; ich habe eine 2080 RTX Super und einen Intel i7 9700K, dann muss ich mir ja hoffentlich nicht weiter Gedanken um die „fehlenden“ 334MHz machen :)


    1,35V sollte ich dann aber trotzdem einstellen, oder?

    Meine Minecraft-Plugins auf SpigotMC (Open Source): www.mfnalex.de

    Discord: discord.jeff-media.com

  • Bei zu wenig Volt wird dein PC einfach ausgehen bzw. wenn du gerade so am Limit bist, dann gibt es sporadische RAM-Fehler. Also lass die 1.2V, wenn alles so stabil läuft. Das kannst du Testen mit z.B. prime95 und cpuz/hwmonitor zur Kontrolle.

  • Das müsste auch mit Key funktionieren; zeig doch mal deine sshd_config

    habe quasi fast alle #-Zeilen entfernt, so sieht /etc/ssh/sshd_config aus


    Detail am Rande, will ich mich ohne dem Key anmelden, komme ich gar nicht rein, dafür habe ich dann in der

    ./var/log/audit/audit.log folgendes

    Code
    1. type=AVC msg=audit(1571853098.690:36): avc: denied { read } for pid=1502 comm="sshd" name=".google_authenticator" dev=sda3 ino=7272 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

    scheint ich darf da SELinux a bissi erweitern ...


    Code
    1. #============= sshd_t ==============
    2. allow sshd_t admin_home_t:file read;


    oder den file context von /root/.google_authenticator auf auf ssh_home_t setzen, und nachdem ändert sich das Problem nicht, audit.log bekommt keine weiteren 'denied' Einträge, und folgendes zeigt PuTTY


    Code
    1. login as: root
    2. Keyboard-interactive authentication prompts from server:
    3. | Verification code:
    4. | Password:
    5. End of keyboard-interactive prompts from server
    6. Access denied
    7. Keyboard-interactive authentication prompts from server:
    8. | Verification code:

    und in /var/log/secure finde ich das


    Code
    1. Oct 23 22:01:11 lxlanvm-000 sshd[1647]: error: PAM: Cannot make/remove an entry for the specified session for root from MYPC
    2. Oct 23 22:01:33 lxlanvm-000 sshd(pam_google_authenticator)[1665]: Failed to update secret file "/root/.google_authenticator"


    google-authenticator habe ich natürlich aufgerufen, wobei was soll mir das da sagen?


    Your verification code is 312762


    ich hab auch den File mit den Rechten auf 0600 gesetzt ...


    Tja und ein Blick auf audit.log liefert das da


    Code
    1. type=AVC msg=audit(1571861254.813:75): avc: denied { create } for pid=1692 comm="sshd" name=".google_authenticator~" scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

    ich hab mal touch gemacht und dem File den selben Context und die selben Rechte gegeben

    und das brachte nichts;

    und funktionieren tut es auch nicht ...

    irgendwie Buggy :(

  • Die Statistik ist leider kaputt weil netcup die Sichtbarkeit der Benutzerseiten auf registrierte User beschränkt hat. Somit kann. Ich leider nicht mehr alle Daten crawlen.


    Muss ich mal™ fixen.

    (für den Fall, dass du curl zum crawlen nutzt)

    Ich hatte mal ein ähnliches Problem und habe das wiefolgt gelöst:

    - Anmelden im Browser auf der entsprechenden Seite (ggf. eingeloggt bleiben aktivieren)

    - Auslesen der Cookies mit einem entsprechenden Addon und Speichern und in einer Datei

    - Übertragen der Datei auf den Server

    - Ergänzen des curl commands: -b, --cookie <data|filename>

  • Danke für die Antwort; ich habe eine 2080 RTX Super und einen Intel i7 9700K, dann muss ich mir ja hoffentlich nicht weiter Gedanken um die „fehlenden“ 334MHz machen :)


    1,35V sollte ich dann aber trotzdem einstellen, oder?

    XMP stellt schon selbst die passenden Werte ein, da muss man nichts mehr selber schrauben.

  • Die Post erstellt leider immer Paketmarken in A4 (viel weise leere Fläche), ich muss die immer zuschneiden damit sie auf A5 passen.

    Oder gibts da ne andere Lösung?

    Unter Linux drucke ich die mit jedem PDF-Reader und meinem HP LaserJet immer so: Querformat & nicht skalieren - dann wird der rechte Bereich automatisch abgeschnitten. Das klappt mit A5-Etiketten einwandfrei.


    (Kann sein, dass es statt Quer- doch das Hochformat war, aber prinzipiell geht es darum, dass die Software nicht automatisch verkleinern darf. Notfalls die Druckgröße auf >100% stellen, sofern möglich.)

  • Unter Linux drucke ich die mit jedem PDF-Reader und meinem HP LaserJet immer so: Querformat & nicht skalieren - dann wird der rechte Bereich automatisch abgeschnitten. Das klappt mit A5-Etiketten einwandfrei.

    Danke, super Tipp. War schon kurz davor mir PhantdomPDF (Foxit) zu kaufen xD. Hast mir bares Geld gespart. Auf das hätte ich auch selber kommen können xD.

  • Hat jemand eine Testseite f. SMTP und TLS parat die auch mit IPv6 funktioniert?


    sowas

    https://tls.imirhil.fr/smtp/mx01.ipv6help.de


    und dabei der Fehler

    Code
    1. Oct 24 12:55:58 vhost01 postfix/smtpd[12821]: NOQUEUE: reject: CONNECT from
    2. unknown[2001:bc8:47c0:162e::1]: 550 5.7.1 Client host rejected: cannot find your
    3. hostname, [2001:bc8:47c0:162e::1]; proto=SMTP

    ist ein absolutes NoGo

    (nein kein temp. Problem im DNS bei meinem Server, sondern siehe hier:

    https://dnslytics.com/ipv6/2001:bc8:47c0:162e::1 )