Das längste Thema

  • Anlass, warum ich gefragt habe, war eigentlich nur eine kurze Gedankenverirrung, die ich gestern hatte, beim Installieren von Ubuntu von CD auf einen neuen Server. Als ich den Namen für den Hauptbenutzer eingegeben habe, war ich (nur ganz kurz ;)) irritiert und hatte mich gefragt: Lege ich da eigentlich einen zusätzlichen superuser an, oder benenne ich da gerade root um?

    Na klar ist es ein neuer superuser und nicht root (Man sollte keine Server installieren während man dabei einen Sixpack leert 8)), aber das war der Auslöser dass ich mich gefragt habe:

    An was identifiziert das System eigentlich den root-Account? Was passiert, wenn ich root in den entsprechenden Dateien (passwd/group/shadow...) umbenenne (nicht dass das eine gute Idee wäre) und dann einen anderen Account mit Namen root anlege?

  • was dich zu dieser Frage bewegt?

    Sixpack

    :D:D:thumbup: sehr geil.


    Soweit ich das überblicke, funktioniert das über die UID - insbesondere bei Dateisystemrechten und Prozessrechten.

    Der Name selber ist dabei irrelevant.


    Wenn du einen Prozess mit einem anderen User ausführst, machst du nach POSIX eigentlich einen fork() => setgid() => setuid() => exec()

    wobei der fork hier optional ist - und die Gruppenrechte kommen zuerst, falls der Zielnutzer die Gruppe nicht mehr wechseln darf, aber die Quellgruppe zu viele Rechte hat.


    Der Username ist dabei nur ein griffiger Name, für den Menschen an der Tastatur - ähnlich wie Domain Names.

    Korrigiert mich bitte, wenn ich falsch liege.

  • Boah. Eben habe ich mir das Filesystem geschrottet, als ich Platz zwischen lvm-Partitionen verschieben wollte.

    lvreduce --resizefs ging nicht im laufenden Betrieb (weil "in use") also ins Rettungssystem und dort das eine Volume verkleinert, das andere vergrößert.

    Schien auch prima geklappt zu haben.

    Aber nach reboot FS-Fehler beim vergrößerten Volume und nur bis zum rescue-prompt gekommen. :(

    Zum Glück hat dort e2fsck die fünf gefundenen Fehler behoben und nach erneutem reboot scheint es nun zu laufen. :wacko:

    Hab ich auch nicht wirklich gebraucht heute...


    Ich hatte schon mal ein ähnliches Problem mit lvm. So ganz geheuer ist mir das mittlerweile nicht mehr. :/

    Aber ich denke es lag an mir. ;) (Irgendwas vergessen vor dem reboot)

  • Hi.


    Gibt's irgendwie neues vom Ausfall des Servers a2e46?


    Ich bekomme auch den Zertifikatsfehler (da wird ein abgelaufenes Plesk-Zertifikat ausgeliefert, anstatt das von Lets Encrypt generierte). Wenn man die Warnung überspringt, bekommt man ein 404 Not Found anstatt die Datei, die ich versuche herunterzuladen.


    https://a2e46.webhosting.systems/... gibt einen 504 Gateway Time-Out. Zum Glück sind die Datenbanken nicht betroffen.


    Meine letzte E-Mail-Meldung ist von 12:22, die erste von 4:30..

  • Vielen Dank aber war eigentlich anders ^^ mein Vater hatte ne Herz-OP und ich war sehr nervös aber ist zum Glück alles gut gegangen :):):)

    Meine Minecraft-Plugins auf SpigotMC (Open Source): www.mfnalex.de

    Discord: discord.jeff-media.com

  • Gibt's irgendwie neues vom Ausfall des Servers a2e46?


    Ich bekomme auch den Zertifikatsfehler (da wird ein abgelaufenes Plesk-Zertifikat ausgeliefert, anstatt das von Lets Encrypt generierte). Wenn man die Warnung überspringt, bekommt man ein 404 Not Found anstatt die Datei, die ich versuche herunterzuladen.


    https://a2e46.webhosting.systems/... gibt einen 504 Gateway Time-Out. Zum Glück sind die Datenbanken nicht betroffen.

    Die eine Webseite, die bei mir noch draufliegt kann ich aufrufen. Auch das cert ist OK

    Aber ich komme über das CCP nicht ins Webhosting rein.

    "Ein Fehler ist aufgetragen bei WebhostingOnyxHelper::getSession"

    Meine letzte E-Mail-Meldung ist von 12:22, die erste von 4:30.

    same here

  • Also meine Website auf dem Server läuft wieder, auf den ersten Blick jedenfalls völlig normal. Kein Zertifikatsfehler, es wird das korrekte LE-Zertifikat angezeigt. Allerdings komme ich immer noch nicht ins WCP. "Ein Fehler ist aufgetragen bei WebhostingOnyxHelper::getSession".

  • Also meine Website auf dem Server läuft wieder, auf den ersten Blick jedenfalls völlig normal. Kein Zertifikatsfehler, es wird das korrekte LE-Zertifikat angezeigt. Allerdings komme ich immer noch nicht ins WCP. "Ein Fehler ist aufgetragen bei WebhostingOnyxHelper::getSession".

    Meine läuft nun auch wieder. Hatte mir schon etwas Sorgen gemacht, dass die Daten von dort futsch sein könnten. WCP geht auch nicht.

  • Ich bräuchte mal nen Denkansoß von euch:


    habe auf einem Server (Debian 10) mittels ssh-keygen einen SSH key erstellt, anschließend wollte ich diesen auf den Zielserver kopieren:


    ssh-copy-id root@SERVERNAME.de


    Mir wird dann folgender fehler ausgeschmissen:

    /usr/bin/ssh-copy-id: INFO: Source of key(s) to be installed: "/var/lib/USER/.ssh/id_rsa.pub"

    /usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed

    /usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed -- if you are prompted now it is to install the new keys

    root@SERVERNAME.de: Permission denied (publickey,password).


    Auf einem anderen System klappt dieser Vorgang ohne Probleme, ich wüsste auch nicht dass ich etwas anders konfiguriert habe.


    VG Fisi

  • Also meine Website auf dem Server läuft wieder, auf den ersten Blick jedenfalls völlig normal.


    Ich denke mal, dass du wohl auch schon das Mail mit dem Dateisystem-Fehler bekommen hast. Bei mir ist ein Verzeichnis mit ca 1GB an Daten verschwunden. Das ist so das, was mir auf den ersten Blick aufgefallen ist. Also wäre es vielleicht angebracht, wenn du dir deine Verzeichnisse mal genauer anschaust.


    Da ja angeblich Backups zurückgespielt werden, frage ich mich, wie es sich mit diesem Ordner verhalten wird, wenn das Tool sieht, dass ich das Verzeichnis wieder neu angelegt habe und wieder eine Handvoll neuer Dateien drin sind. Hoffentlich kommen die alten Dateien dann trotzdem wieder.

  • Ich denke mal, dass du wohl auch schon das Mail mit dem Dateisystem-Fehler bekommen hast. Bei mir ist ein Verzeichnis mit ca 1GB an Daten verschwunden. Das ist so das, was mir auf den ersten Blick aufgefallen ist. Also wäre es vielleicht angebracht, wenn du dir deine Verzeichnisse mal genauer anschaust.


    Da ja angeblich Backups zurückgespielt werden, frage ich mich, wie es sich mit diesem Ordner verhalten wird, wenn das Tool sieht, dass ich das Verzeichnis wieder neu angelegt habe und wieder eine Handvoll neuer Dateien drin sind. Hoffentlich kommen die alten Dateien dann trotzdem wieder.

    Also ich warte jetzt erst mal bis ein Abschluss der Arbeiten vermeldet wird. Dann überprüfe ich das.

  • ssh-copy-id root@SERVERNAME.de

    /usr/bin/ssh-copy-id: INFO: Source of key(s) to be installed: "/var/lib/USER/.ssh/id_rsa.pub"

    /usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed

    /usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed -- if you are prompted now it is to install the new keys

    root@SERVERNAME.de: Permission denied (publickey,password).

    Versuch mal einfach so vom Quellserver aus ssh root@SERVERNAME.de :)

    Behaupte das wird auch nicht klappen (PermitRootLogin no auf Zielserver?)

    Erwartet wäre ein PW-gestützter Login als root auf Zielserver.

  • Also ich warte jetzt erst mal bis ein Abschluss der Arbeiten vermeldet wird. Dann überprüfe ich das.

    Sieht erst mal gut aus, aber die Tausenden von Download-Links mag ich jetzt nicht alle einzeln manuell durchtesten. Eigentlich müssten fehlende Dateien, die irgendwo benutzt werden, auch beim Linkcheck im Backend erkannt werden. Da dort nur vier externe Links als defekt angezeigt werden, gehe ich mal davon aus, dass alle benötigten Dateien vorhanden sind.