Das längste Thema

  • Nope, nur diese eine Partition. Ich habe gerade bemerkt, das die GPT kaputt sein soll und versuche sie gerade (bis jetzt vergeblich) wiederherzustellen...

    Ich kann mir nicht einmal erklären, was die Partitionstabelle kaputt gemacht haben soll... Das letzte Mal via USB am Laptop (Linux) und danach ordentlich abgemeldet/umount... Mit Partitionen "rumgeschrieben" habe ich noch nie, also keine Ahnung...

  • Ich glaube ich piepe auf die Daten (im Endeffekt eh "nur" ein Backup von einem gerade laufenden System)... Hier der Output von gdisk:

    Oder hat jemand noch eine Idee, die nicht stundenlang dauert (denn das sind mir die Daten nicht wert)? :)

  • Ich tippe irgendwie auf reboot tut gut. :S

    Leider nicht :(


    Was sagt dmesg dazu? (Besonders beim Anstecken der Platte.)

    Von Hot Plug hält der P410i leider nicht so viel. (Gar nichts)

    Das kommt beim Booten rum:

    Code
    1. 2019-08-10T20:44:57.944152+00:00 grml kernel: [ 6.715995] sd 0:1:0:1: [sda] 468792000 512-byte logical blocks: (240 GB/224 GiB)
    2. 2019-08-10T20:44:57.944156+00:00 grml kernel: [ 6.716137] sd 0:1:0:1: [sda] Write Protect is off
    3. 2019-08-10T20:44:57.944158+00:00 grml kernel: [ 6.716140] sd 0:1:0:1: [sda] Mode Sense: 6b 00 00 08
    4. 2019-08-10T20:44:57.944161+00:00 grml kernel: [ 6.716397] sd 0:1:0:1: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
    5. 2019-08-10T20:44:57.944164+00:00 grml kernel: [ 6.720359] sd 0:1:0:1: [sda] Attached SCSI disk
  • I don't get it... Gerade nochmal an den Laptop drangehangen, alles super. Automatisch eingebunden, GPT in Ordnung, alles super. Was auch immer der P410i bzw. grml daraus macht... Aber das ergibt auch keinen Sinn, denn das gleiche Laufwerk hatte ich vor ein paar Wochen über den Controller an der gleichen Version von grml dran hängen. Ich habe seitdem nichts verändert, außer höchstens den Steckplatz im Server, aber das sollte es doch (hoffentlich) nicht sein...


    Trotzdem danke für eure Bemühungen:)

  • Was sagt denn das dmesg am Laptop, wo es funktioniert dazu?

    Diese Frage beantworte ich gerne, wenn du mir sagst wie ich ein dd if=/dev/zero of=/dev/sdb bs=1M count=10 rückgängig mache:) if und of vertauchen wird glaube nichts

    Die Daten waren mir den Aufwand wirklich nicht wert und ich wollte einfach nur einen weiteren Test bzgl. des Problems mit den "magischen" ~100MB/s machen...


    Edit: Aber das hat das syslog mitgeschrieben:

    Code
    1. Aug 10 20:53:17 holzwurm kernel: [60112.048775] sd 4:0:0:0: [sdc] 468862128 512-byte logical blocks: (240 GB/224 GiB)
    2. Aug 10 20:53:17 holzwurm kernel: [60112.048780] sd 4:0:0:0: [sdc] 4096-byte physical blocks
    3. Aug 10 20:53:17 holzwurm kernel: [60112.048943] sd 4:0:0:0: [sdc] Write Protect is off
    4. Aug 10 20:53:17 holzwurm kernel: [60112.048946] sd 4:0:0:0: [sdc] Mode Sense: 53 00 00 08
    5. Aug 10 20:53:17 holzwurm kernel: [60112.049256] sd 4:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    6. Aug 10 20:53:17 holzwurm kernel: [60112.049543] sd 4:0:0:0: [sdc] Optimal transfer size 33553920 bytes not a multiple of physical block size (4096 bytes)
    7. Aug 10 20:53:17 holzwurm kernel: [60112.053760] sdc: sdc1
    8. Aug 10 20:53:17 holzwurm kernel: [60112.055189] sd 4:0:0:0: [sdc] Attached SCSI disk
  • Edit: Aber das hat das syslog mitgeschrieben:

    Ich denke aufgrund Deiner divergierenden dmesg-Ausgaben, dass Dein P410i, respektive der Kernel des grml zwar die logische Blockgröße von 512 erkannt hat, nicht aber die (modernere) physische Blockgröße von 4096 bei Advanced Format. Möglicherweise hat die (laut Laptop-Kernel als) 512e (erkannte) -Firmware der Platte oder die des P410i da einen Bug. Das würde die Fehlermeldung zum GPT „mismatch“ erklären, dass Daten auf dem HP über den Sektor hinausgehen. Der Controller wird seit 2015 nicht mehr supportet (https://h20195.www2.hpe.com/v2/GetPDF.aspx/c04111713.pdf) - ist denn die letzte Firmware (6.64B) drauf?


    Pardon, falls ich eine Info, über die eventuell diskutiert worden ist, überlesen haben sollte.


    Was die Performanceprobleme anbelangt, siehe: https://serverfault.com/questi…-proliant-dl385-g7/221553

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • Aug 10 20:53:17 holzwurm kernel: [60112.048775] sd 4:0:0:0: [sdc] 468862128 512-byte logical blocks: (240 GB/224 GiB)
    Aug 10 20:53:17 holzwurm kernel: [60112.048780] sd 4:0:0:0: [sdc] 4096-byte physical blocks

    eripek sollte es denn aus Sicht des OS nicht irrelevant sein, ob es eine 512e (Advanced Format) od. 512n (das was früher überhaupt nur gab) Platte ist?

    welches OS kann denn überhaupt mit 4Kn (echte 4K Blöcke, und keine 512 Byte Emulation) Platten tatsächlich umgehen?

    Grüße / Greetings

    Walter H.


    RS 1000 SAS G8 xRAM; RS 500 SSD G8; S 1000 G7; VPS 200 G8 Akt.; Webhost. 1000 m. 75%

  • Wegen der Firmware schaue ich dann Mal nach (denke aber schon, alles andere im Server war aktuell). Ich vermute, das es vielleicht ein Problem wegen der "JBOD"-Regelung des Controllers (aka RAID0 mit einer Festplatte) gibt... Wieso es dann ursprünglich ohne Änderungen an der Festplatte/SSD Mal geklappt hat verstehe ich natürlich trotzdem nicht...


    Danke für die Seite, ich kannte so gefühlt die ersten 10 Google-Seiten...

    Das Problem mit den Geschwindigkeiten hat sich gestern final geklärt. Ich habe mir ein paar SAS-Festplatten bestellt und erhalte mit "JBOD" 120MB/s und (testweise) mit einem RAID0 aus zwei Festplatten die doppelte Geschwindigkeit. Ein RAID10 hätte ich gerne noch probiert, aber selbstverständlich musste eine der "einwandfrei geprüften" Festplatten ja kaputt sein...

    Also entweder hat die SSD so "schlechte" Geschwindigkeiten, wenn sie nur per SATA-II angebunden wird (mit SATA-III flutscht es ja förmlich) oder ich weiß auch nicht, denn alle probierten Controller unterstützten nur SATA-II. An der Backplane oder SAS-Kabel liegt es übrigens nicht, ich habe die SSD (SanDisk SSD PLUS 240GB) auch Mal direkt mit so einem SAS/4xSATA-Kabel dran gehangen.

    Ich werde mal noch ein bisschen rumprobieren, aber derzeit verdächtige ich die SSD.

  • Kann man eigentlich von der Shell eines Webhostings aus eine Mail versenden?

    Ich würde mir gerne die HDD-Auslastung zusenden lassen. Die Programme mail, mailx etc. scheinen nicht installiert zu sein, ich will sie aber auch nicht drauf pfuschen.

    Gibt es eine einfach Möglichkeit, abgesehen von einem PHP-Script, dem Webhosting die Informationen zu entlocken?

  • Gibt es eine einfach Möglichkeit, abgesehen von einem PHP-Script, dem Webhosting die Informationen zu entlocken?

    Naja, prinzipiell kannst du halt alle Scriptsprachen nutzen, die dir dort zur Verfügung stehen... Der Einfachheit halber würde ich persönlich aber zu PHP greifen. :S

    VPS 1000 G8 Plus | VPS 200 G8 | selbstgebautes NAS


    Wer im Netz Anstand und Respekt verliert, der ist auch im realen Leben für nichts zu gebrauchen! ;)

  • Falls es jemanden interessiert, ich habe eine Lösung mit curl gefunden:


    Shell-Script
    1. #!/bin/bash
    2. cd /backups/
    3. cat head.txt > message.txt
    4. du -sh /backups/ >> message.txt
    5. find /backups/ >> message.txt
    6. cat tail.txt >> message.txt
    7. curl --url 'smtps://smtp.mailbox.org:465/' --ssl-reqd --mail-from 'mail@domain.tld' --mail-rcpt 'mail@domain.tld' --upload-file message.txt --user 'mail@domain.tld:<password>'

    Den SMTP Host müsst ihr natürlich ggf. anpassen :)


    head.txt und tail.txt ergeben am Ende mit den Ausgaben von du und find folgende message.txt:

  • Ich nutze für solche Sachen mittlerweile einen Telegram Bot, mit einem kleinen Webrequest kann man sich dann auf Telegram anschreiben lassen ^^


    Code
    1. /usr/bin/curl --silent -s -X POST "https://api.telegram.org/bot<BOT-ID>:<BOT-SECRET>/sendMessage" -d chat_id=<CHAT-ID> -d text="Serverneustart am `/bin/date`" > /dev/null

    Aber eignet sich nur eingeschränkt für längere Meldungen mit Logs :pinch:

    Den Log kann man aber theoretisch als Dateianhang mitsenden

  • Kann man eigentlich von der Shell eines Webhostings aus eine Mail versenden?

    Ich würde mir gerne die HDD-Auslastung zusenden lassen. Die Programme mail, mailx etc. scheinen nicht installiert zu sein, ich will sie aber auch nicht drauf pfuschen.

    Gibt es eine einfach Möglichkeit, abgesehen von einem PHP-Script, dem Webhosting die Informationen zu entlocken?

    http://phpsysinfo.github.io/phpsysinfo/

    Versendet zwar glaube ich keine Mails, aber für mich eins der besten kleinen Systeminfo Tools 😊🛠️