Neue Produktsparte: Cloud-Webhosting Reselling

  • Hallo zusammen,


    Kurzes Update:

    Die letzten Tage hatte ich viel mit dem Support zu tun, welcher jetzt wirklich bemüht und hilfsbereit war und es konnten jetzt soweit alle Fehler (bis auf aktuell zwei kleine) behoben werden und aktuell läuft alles zuverlässig.

  • Das einzig größere Problem das aktuell noch auftritt, ist eine E-Mail-Blacklist bei mehreren Providern....


    Bei T-Online konnte ich die Sperre selber entfernen lassen, Yahoo fordert immer mehr Infos ein, aber macht nicht wirklich voran und Microsoft weigert sich aktuell die IP zu entfernen, hat aber angeblich einen kompletten Teil von NetCup gesperrt....


    Das ist natürlich ziemlich ärgerlich so.



    Habt ihr noch Tips wie man die eigenen Mails auf nem Reseller Webspace möglichst compliant gestalten kann? SPF Records wollte ich jetzt noch für alle betroffenen Domains setzen. Viel mehr Möglichkeiten dürfte ich dann aber auch hier nicht mehr haben....

  • Bei T-Online lief es ohne Probleme, da habe ich die Mail das der Server entfernt wurde nur an den Support weitergeleitet. Bei Microsoft und yahoo habe ich den Support informiert und zeitgleich Microsoft und Yahoo kontaktiert. Bei Microsoft hakt der Support auch nach. Zwischenzeitlich habe ich von Microsoft direkt die Meldung erhalten, dass sie das Blacklisting "abschwächen" der Support von Netcup will aber wohl weiter dran bleiben bis er komplett delisted ist.


    Bei Yahoo muss ich laut Support aber selber tätig werden, obwohl dort wohl auch eine generelle Sperre vorliegt. Naja, auf jeden Fall bin ich da jetzt dran...


    DKIM & DMARC sind beim Reseller Webhosting ja vermutlich nicht möglich oder? Ich wüsste daher nicht was ich, abgesehen von SPF, machen könnte.

  • Eine Sache habe ich auch zum Reseller-Paket, wo ich das mit dem Support nicht zufriedenstellend klären konnte.


    Mir ist es schlichtweg nicht möglich die eigene Domain für den Email-Dienst also für den E-Mail-Eingangsserver und Ausgangsserver in Form von mail.domainname.de zu nehmen, den dabei tritt ein Fehler mit der Vertrauensstellung des Zertifikats auf und ein Verbindungsaufbau über SSL ist nicht mehr möglich. Fehlermeldung in der Art wie NET::ERR_CERT_INVALID und das xxx.webhosting.systems nicht mit dem mail.domainname.de übereinstimmt.


    Laut Support ist die Serveradresse xxx.webhosting.systems ausreichend "ge-White-Labled".


    Also für mich ist es nicht, zumindest wenn die eigene Domain nicht als Mailadresse genommen werden kann, hier habe ich wohl den begriff White-Labled nicht richtig verstanden.


    Was kann man hier machen? Gibt es eine Möglichkeit die eigene Domain zu verwenden ohne das man gezwungen ist den fqdn xxx.webhosting.systems zu nutzen, den auf der Startseite der Domain webhosting.systems ist eine Impressum Verlinkung zu netcup?


    VG

  • Wenn ich mich recht erinnere wurde das an mit dem Mailserver bereits an anderer Stelle diskutiert. Ein perfektes White-Labeling kann es da nicht geben, der Mailserver wird von mehreren Kunden gemeinsam genutzt und das Zertifikat des Mailservers lautet nun mal nicht auf jede x-beliebige Domain, die sich irgendein Kunde registriert hat sondern auf seinen eigenen Namen. Das ist auch nicht die Startseite von webhosting.systems sondern eine Weiterleitung auf die CCP-Login Seite (https://www.customercontrolpanel.de/). Und diese Seite braucht nun einmal ein Impressum und eigentlich m.E. noch dringender auch eine Datenschutzerklärung. Vielleicht kann Netcup diese Weiterleitung auf die CCP-Login Seite rausnehmen, ohne dass etwas dabei kaputt geht. Dann wäre es nicht ganz so offensichtlich, dass das Ganze eigentlich bei Netcup gehostet wird. Wenngleich jeder, der es wirklich wissen will, es wohl immer herausfinden wird.

  • Ein perfektes White-Labeling kann es da nicht geben, der Mailserver wird von mehreren Kunden gemeinsam genutzt und das Zertifikat des Mailservers lautet nun mal nicht auf jede x-beliebige Domain, die sich irgendein Kunde registriert hat sondern auf seinen eigenen Namen.

    Das erwarte ich doch nicht, sondern schlicht die eigene Domain zu nutzen. Bei anderen Anbietern habe ich es gesehen, also sollte das kein Problem sein.


    Die Herausnahme der Weiterleitung von webhosting.systems auf die CCP-Login Seite würde ich begrüßen.


    VG

  • Das Reseller-Webhosting wird wohl genauso wie das Webhosting mit Plesk Onyx betrieben. Ich hab mir leider immer noch kein Reseller-Webhosting zum Testen geholt. Von Plesk Onyx wird SNI nicht unterstützt. In der neuesten Version dagegen schon, dafür reicht aber wiederum Debian 8 nicht aus. Kann natürlich auch sein, dass die Reseller-Webhosting Server bereits unter einer neueren Version laufen, dann nehme ich alles zurück und behaupte das Gegenteil. ;)

  • Ja jetzt läuft es wieder. Sind bei Euch auch die Logs mit


    Code
    1. mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

    voll?


    Fast alle Seiten bei mir bekommen immer wieder nen Gateway Fehler und das taucht dann in den Logs auf.... Der Support möchte aber nicht die Limits erhöhen.... Passiert auch bei Seiten die vorher hier auf einem günstigeren Webspace bei Netcup liefen...


    Ein Fehler der die Verbindung von externen SMTP Servern betroffen hat wurde nun endlich behoben, nachdem ich ewig mit dem Support diskutieren musste, weil mir immer wieder unterstellt wurde es läge an meinen Scripten.... War wohl nen Fehler in der ipv6 Config und wurde jetzt endlich behoben.

  • Nach einiger Diskussion wurden die Limits übrigens erhöht. Die Logs sind aber immer noch voll mit Fehlern (es treten aktuell aber keine bemerkbaren auf). Der Support weiß auch nicht woher / warum die Fehler immer weiter in die Logs geschrieben werden. NetCup wollte dann bei Plesk nachfragen - bisher gabs aber keine Rückmeldung an mich.


    Eine Katastrophe ist allerdings das Vorgehen in Bezugs auf Mails. Am 16.10 habe ich NetCup darüber informiert, dass keinerlei Mails an Yahoo zugestellt werden können. Es wurde mehr oder weniger nur etwas gemacht wenn ich noch einmal aktiv nach gehakt habe. Mir wurde zwischenzeitlich zwei Mal mitgeteilt, dass es angeblich jetzt funktioniert -> Tut es natürlich nicht. Da frage ich mich, wofür ich NetCup u.a. die Zugangsdaten für ein Test-Postfach habe zu kommen lassen.


    Wer auf Mail-Versand angewiesen ist, ist bei Netcup offensichtlich komplett falsch. Nach fast einem Monat immer noch keine Lösung für ein doch nicht all zu unkritisches Thema zu liefern ist auch ein Armutszeugnis....

  • Eine Katastrophe ist allerdings das Vorgehen in Bezugs auf Mails. Am 16.10 habe ich NetCup darüber informiert, dass keinerlei Mails an Yahoo zugestellt werden können.

    ... von den normalen (neuen) Webhostingtarifen aus gesendet sind die Mails bei yahoo im Spam-Ordner zu finden.

  • Ende November hat Yahoo den Server auf dem ich liege auch endlich aus dem Blacklisting entfernt. Ich musste da aber leider selber ziemlich hinterher sein, damit da was passiert. Jetzt landen sie, wie bei Dir, im Spam-Ordner.


    Aktuell gibts leider wieder ein neues Problem, so kann man aktuell die Werte der PHP-Einstellungen nicht mehr "händisch" eingeben sondern nur noch (aus einer viel zu kleinen Auswahl) an Werten mittels Dropdown auswählen. Das widerrum matcht nicht im geringsten mit meiner Tarif-Struktur.... Laut Support soll hierfür aber wohl jetzt wieder eine Lösung kommen... Kommuniziert wurde davon aber auch nichts. Sprich man ändert einfach und schränkt den Kunden stärker ein. Immerhin kann ich aktuell - aber auch erst nach einer "Beschwerde" - auch die Leistungen zuteilen für die ich bezahle. Es wurden in den Dropdowns zu beginn nämlich nicht einmal die Maximal-Werte die mir zustehen angezeigt. Es wirkt leider alles ziemlich unausgereift.

  • Mein absolutes Highlight: Bei 90% der Domain hat die Verlängerung der Let's Encrpt Zertifikate nicht funktioniert. Sowas erwartet man eigentlich von Plesk, wer weiß aber, was dort alles intern in der Konfig herumgespielt wurde...

  • Mein absolutes Highlight: Bei 90% der Domain hat die Verlängerung der Let's Encrpt Zertifikate nicht funktioniert. Sowas erwartet man eigentlich von Plesk, wer weiß aber, was dort alles intern in der Konfig herumgespielt wurde...

    Gleiches ist bei mir jetzt auch noch passiert... Die API von Plesk wurde zwischenzeitlich auch seitens NetCup ohne Info deaktiviert. Das führt dazu, dass man die App nicht mehr verwenden kann und z.B. auch nicht mehr automatisiert Pakete übers Shop System anlegen kann,...