DNS-Einstellungen für externe Domains, Emails funktionieren nicht

  • Hallo zusammen,


    ich bin neu hier bei netcup. Hab den Reseller Account gebucht und soweit alle Domains auf die netcup ip-adresse in den DNS-Einstellungen eingetragen:

    Beispiel: domain.de
    NS des ext. Anbieters:


    Bei den Reslleraccount sind die Domains und Emails eingerichtet, der Webserver ist einwandfrei und löst alles auf, allerdings funktionieren die Emails nicht.

    Netcup ticket war erfolglos mit der Begründung, dass die Domain von extern ist und die dafür nicht zuständig sind.

    Der Domainanbieter(mit obere einträgen) sagt, dass die Einträge sauber sind und die können für mich nichts machen ich sollte mich an netcup wenden.

    So, jetzt stehe ich zwischen zwei Parteien und weiß nicht wo das Problem liegt den eigentlich sind die Einträge sauber.


    Hat jemand eine Idee? Oder werde ich 12 Monate für ein Produkt bezahlen, was ich nicht nutzen kann für umsonst:?:


    Danke im Voraus.

  • Woran machst du das fest/inwiefern?

    Kein Emailversand möglich, es kommt nach einen Tag eine Time-Out als Fehlermeldung:
    Mit den Email-Client oder über Webmail geht Email raus, aber es kommt nie beim Empfänger an, hab mit mehreren externen Emails las Empf. getestet.


  • In dem Beispiel im Wiki ist die IP für e-mail eine andere als für Webserver. Ich sehe in deinen Records aber keinen A-Record für mail.domain.de.

    In den anderen Domain habe ich es mit mail.domain.de drin als A-Record mit der ip des "resellers", hat nichts gebracht.

    Hast du den link vom Wiki für mich?

  • Ich bin mir nicht sicher, aber für mich sieht das nicht wie ein DNS-Fehler aus... Die Mail wird ja nicht vom Empfänger-Server abgelehnt, sondern geht gar nicht erst raus sondern bleibt bei netcup hängen...

  • Ich bin mir nicht sicher, aber für mich sieht das nicht wie ein DNS-Fehler aus... Die Mail wird ja nicht vom Empfänger-Server abgelehnt, sondern geht gar nicht erst raus sondern bleibt bei netcup hängen...

    DAs habe ich versucht NetCup zu erklären, aber vom Support werde ich alleine gelassen. Siehe Emails.

    Bildschirmfoto 2019-10-06 um 21.16.54.png


    Bildschirmfoto 2019-10-06 um 21.14.48.png


    Meine bitte auch nach ein DNS-Einstellungsvorlage nach NetCup-Vorgabe blieb bis jetzt unbeantwortet.

  • Also zu perryflynn und „kein A-Record“ - jein, macoku hat einen Wildcard angelegt.

    Wegen #8, #9 - ich glaube ihr verwechselt da in Bezug auf den Begriff Domain etwas. Domain im Sinne von FQDN im CCP ist wohl nicht gemeint, sondern „(Sub-)Domain“ im Plesk-Jargon. AFAIK wird das immer noch über das WCP, nicht das CCP angelegt. Möglich, dass man zuvor im CCP unter Produkte für den Resellertarif die verwalteten Kundendomains eintragen müsste. Da ich den Tarif nicht verwende, ist das nur eine Vermutung.


    Ohne Plesk-(Sub)domain gibt es keinen „grounding alias“ für die Domain, deren MX auf den Hostingserver zeigt.

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • Die E-Mail Server sind beim Webhosting doch bei Netcup andere IPs und FQDNs als die Webserver beim Webhosting.

    Ja, und oben wurde auch schon gesagt, dass er keinen A record für mail.domain.de hat. Hat er aber wohl ignoriert..

    Also zu perryflynn und „kein A-Record“ - jein, macoku hat einen Wildcard angelegt.

    Wenn der mx Eintrag auf einen CNAME zeigt funktionierts nicht. Das gilt afaik auch und gerade für Wildcard Einträge.


    Wäre nachzulesen in: https://www.rfc-editor.org/rfc/rfc2181.txt

    10.3. MX and NS records

    The domain name used as the value of a NS resource record, or part of the value of a MX resource record must not be an alias. Not only is the specification clear on this point, but using an alias in either of these positions neither works as well as might be hoped, nor well fulfills the ambition that may have led to this approach. This domain name must have as its value one or more address records. Currently those will be A records, however in the future other record types giving addressing information may be acceptable. It can also have other RRs, but never a CNAME RR.

    Also:

    mail.domain.de A Record anlegen und auf die IP vom Mailserver (nicht Webserver!) zeigen lassen.

  • Hallo Steini,

    Ja, und oben wurde auch schon gesagt, dass er keinen A record für mail.domain.de hat. Hat er aber wohl ignoriert..

    das ist nicht so ganz richtig, hatte ich anfangs drin gehabt für die Dauer von ca. zwei Tagen. -> Dann wieder nach zwei Tagen gelöscht, bei andere Domains ist es noch drin, aber kein Effekt.


    Der MX-Eintrag zeigt auf einen A-Record der wiederum auf reseller-ip zeigt. Das sollte doch so sein, sonst macht es doch keinen Sinn, oder

    verwendet netcup als MTA was anderes das explizit in "mail" eingetragen werden muss?



    Gestern habe ich den A-Record "mail" => IP-Reseller eingetragen und heute an extern getestet, Fehler.

    pasted-from-clipboard.png

    pasted-from-clipboard.png



    Hier ein Bild mit einer zweite Domain:

    pasted-from-clipboard.png

    Nach der Vorlage, was ich weiter oben gelesen habe.


    Wofür steht der autoconfig eintrag?



    Gruß

    Macoku

  • Steini , H6G


    Also ich habe nur den Ist-Zustand erklärt. Demnach ist sehr wohl ein RFC-konformer MX vorhanden - dass er nicht richtig ist, steht auf einem anderen Blatt.

    Code
    1. @ 3600 IN MX 10 mail.domain.de.
    2. [...]
    3. * 300 IN A 10.10.10.10 (IP von NetCup Reseller Account)

    macoku : In Deinen jüngeren Screenshots zeigt der MX einer .net-Domain auf einen Hostname in einer .org-Domain.


    Bedenke, dass Änderungen im DNS zwar lokal bei Netcup mehr oder weniger sofort aktiv werden, bei einem externen Zugriff allerdings noch die alten Zonendaten ausgeliefert werden können (Caching, TTL) - Du findest mehr dazu in dieser Problematik hier im Forum über die Suchfunktion.


    Dass Du ein Timeout bekommst, bedeutet, dass entweder kein Maildienst auf dem genannten Server auf Port 25 existiert, Du den Server nicht erreichen kannst oder, dass der Server Deine Quell-IP auf IP-Ebene vorerst abblockt. Überprüf das alles noch einmal auf Richtigkeit.

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • Dass Du ein Timeout bekommst, bedeutet, dass entweder kein Maildienst auf dem genannten Server auf Port 25 existiert, Du den Server nicht erreichen kannst oder, dass der Server Deine Quell-IP auf IP-Ebene vorerst abblockt. Überprüf das alles noch einmal auf Richtigkeit.

    Aber der timeout (aus Beitrag #4) tritt doch auf der Seite von netcup auf und nicht von außerhalb. Ich habe die Mail/Zitat so interpretiert, dass sie beim Senden von netcup zu web.de entstanden ist. Oder täusche ich mich da?

  • Ich bin bei #6 und darf zusammenfassen:

    Code
    1. This is the mail system at host xxxx.webhosting.systems.
    2. The mail system
    3. [...]
    4. <mail_von_mir_extern@web.de>: connect to
    5. forward-relay.netcup.net[2a03:4000:21:611:1479:86ff:fe4e:c332]:25:
    6. Connection timed out

    Das E-Mail, das von mail_von_mir_extern@web.de stammt, ist vom webhosting.systems-Relay angenommen worden, und soll nun weitergeleitet werden an forward-relay.netcup.net[2a03:4000:21:611:1479:86ff:fe4e:c332]:25. Auf forward-relay.netcup.net[2a03:4000:21:611:1479:86ff:fe4e:c332]:25 läuft aber entweder kein SMTP-Dienst, oder er ist vorübergehend gesperrt (Spam, Fehlkonfiguration, ...).

    Dass Web.de an diesen Host senden möchte, ist wohl einer Information (MX/AAAA) im DNS zu verdanken.


    D.h. der Web.de-Mailer konnte zwar mit dem Host xxx.webhosting.systems reden, dieser kann aber das E-Mail lokal nicht routen, da 2a03:4000:21:611:1479:86ff:fe4e:c332 nicht antwortet. Er sendet web.de darüber einen Fehlerbericht.

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • eripek : "In Deinen jüngeren Screenshots zeigt der MX einer .net-Domain auf einen Hostname in einer .org-Domain."


    Bei der Anonymisierung es ist mir durchgerutscht. Es geht um die selber Domain die ich hier aber nicht reinschreiben möchte.


    Jetzt sind alle Domains wie folgt aufgebaut:

    Beispieldomain: domain.de
    IP: 1.2.3.45 => (Reseller-Account-IP)

  • Bei der Anonymisierung es ist mir durchgerutscht. Es geht um die selber Domain die ich hier aber nicht reinschreiben möchte.

    Die Anonymisierung bewirkt leider auch, dass man Dir keinen konkreten Rat geben kann, und es immer nebuloser wird. Wenn Du möchtest, kannst Du mir die Info (domainnamen) auch als PN schicken, ich schau dann einmal drüber und antworte ebenfalls per PN. Sollte es Dir geholfen haben, kannst Du die Lösung anonymisiert wieder hier posten.


    Ich muss aber darauf hinweisen, dass ich selbst kein Reseller-Paket habe, und daher nur Mutmaßungen äußern oder zu offensichtlichen Problemen Kommentare abgeben kann.

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░


  • Mit dieser Einstellung bekomme ich jetzt E-Mails rein, aber nicht raus. Das versenden über Webmail (Roundcube) steht im "Gesendet" Ordner aber es kommt nicht an, nach ein paar Stunden bekommt man die Fehlermeldung wie oben. Auch nur weitergeleitete Postfächer funktionieren nicht.


    Gruß

    Macoku

  • ... Wenn Du möchtest, kannst Du mir die Info (domainnamen) auch als PN schicken, ich schau dann einmal drüber und antworte ebenfalls per PN. Sollte es Dir geholfen haben, kannst Du die Lösung anonymisiert wieder hier posten.

    Nachricht ist eben raus, danke dir.