Posts by fibis

    Ich finde es irgendwie merkwürdig, dass Wordpress in Zusammenhang mit Laravel genutzt wird, kenne bis jetzt immer nur das eine oder das andere. Laravel ist letztendlich auch nur PHP und kann somit auch auf eine, Shared Hosting installiert werden. Dabei gibt es aber einige Einschränkungen:

    • Das Ausführen von node Befehlen, wie laravel mix sind nicht möglich
    • Redis kann nicht als Cache oder Queue Driver genutzt werden
    • Generell sind Queues oder Horizon schwierig zu nutzen, da du keinen Service definieren kannst, der den Worker permanent ausführt. Somit müssten Jobs synchron asugeführt werden.

    Vielen Dank an alle, es war tatsächlich so, wie ihr gesagt habt . Adern getauscht, wieder hineingesteckt, zack fertig, Internet.

    (Ja ich hatte einfach Lust zu malen)

    Man muss ja auch seiner künstlerischen Freiheit Freiraum lassen ^^

    Danke euch beiden für den Tipp, werde ich nachher mal direkt probieren. Mich würde es nicht wundern, dass hier irgendetwas vertauscht worden wäre :D.

    Meinst du damit, dass eine Direktverbindung zwischen beiden Konvertern geklappt hat, aber mit den Etagen dazwischen geht es nicht mehr? Oder einfach nur, dass die Stecker gepasst haben? Falls das Adern tauschen oben nicht klappt, könntest du das dann erstmal per Konverter -> Konverter probieren, um ein Problem zwischen den Etagen auszuschließen.

    Genau, wenn ich die beiden Konverter direkt mit einem Kabel verbinde, klappt es ohne Probleme, damit hätte ich den Fehler zumindest nicht bei den Kabeln und bei der Hardware gesucht.

    Wir ziehen aktuell in ein neues Büro und ich bin für unser Internet zuständig. Dieses hat es auch schon bis in den Keller geschafft und muss nur noch in den dritten Stock kommen. Und damit fängt das Problem an und hoffe hier ein wenig das Schwarmwissen des Forums nutzen zu können.


    Man kam bei dem Gebäude auf die Idee jede Etage aus dem Keller heraus mit Fiber zu verbinden. Folgende Anschlüsse sind vorhanden.

    keller.jpg   etage.jpg


    Nach ein wenig Recherche habe ich mich dazu entschieden, unten im Keller Ethernet zu Fiber zu konvertieren und das gleiche Spiel wieder zurück bei uns in der Etage. Nach ein wenig Recherche habe ich mich dann für folgenden Konverter entschieden: https://www.amazon.de/gp/produ…tle_o02_s00?ie=UTF8&psc=1, zwei OM3 LC Kabel dazu und auf gut Glück diese Konstruktion probiert.


    Leider musste ich dann feststellen, dass es zwar geklappt hat, beide Konverter mit einem Kabel zu verbinden, es aber leider nicht geklappt, weder unsere Etage mit dem Keller zu verbinden noch testweise die erste Etage. Meine einzige Vermutung, welche ich noch habe, ist, dass ich OM3 Kabel verwendet habe, die Anschlüsse jedoch OM4 sind (obwohl diese eigentlich kompatibel sein sollten).


    Aus diesem Grund: Hat vielleicht einer von euch eine Idee, wieso es bis jetzt nicht möglich war, eine Verbindung aufzubauen oder ich einfach komplett falsche Hardware benutze?

    Wenn man das meiste schon vorher macht, z.B. mit einer CI in GitLab, muss der Server nichts mehr compilieren, etc. Was nicht geht sind Queues, da man hier einen Prozess haben muss, der immer läuft. Dafür sind die Webhostingpakete nicht vorgesehen.

    Natürlich kann man soetwas easy mit Containern in Kubernetes in der Cloud wie z.B. "GCP" oder "AWS" umsetzen. Ist natürlich auch immer mit ein wenig Wartung verbunden, dennoch aber mit weniger als die Umsetzung auf bare metal servern. Unsere Anwendungen laufen da mittlerweile ohne Probleme drauf und skalieren ohne Probleme hoch und runter.


    Ich würde mich da aber trotzdem den anderen anschließen. Vorallem für Wordpress gibt es spezialisierte Anbieter, die das automatisiert erledigen für weniger Geld als eine eigene Lösung.

    Das kann eigentlich nicht sein. Ich habe die Option bei meinen Domains aktiviert und die automatische Verlängerung funktioniert trotzdem.

    Dann scheint das wohl von Instanz zu Instanz unterschiedlich zu sein. Beim Reseller Tarif (also die neuste Plesk Version) ist genau dies der Fall und mir wurde das so vom Support zurückgegeben, dass diese Option deaktiviert werden soll für LE. Bei meinen alten Tarifen war diese Funktion aber immer aktiv und es hat trotzdem geklappt.

    Ich weiß zwar nicht in welchen Abständen LE es versucht, aber ich habe nachdem ich dir geantwortet habe die Umleitung entfernt, jedoch hat sich bis jetzt noch nichts getan. Wie bereits erwähnt warte ich noch einfach ein paar tage. Was sagt den der Netcup Support dazu?

    Der Support wird dir genau das sagen, was ich dir gesagt habe. Am einfachsten ist es einfach das Zertifikat zu verlängern

    D.h. du empfiehlst das generell abzuschalten?

    Ich habe das bei allen meinen hosting-domains drin.

    Ich hatte es auch überall aktiviert und meine Zertifikate haben sich dann leider nicht weiter verlängert. Es kam dann heraus, dass es genau an dieser Einstellung lag, zumindest so hat der Support es so kommuniziert. Da es aber auch mal mehrere Jahre geklappt hat, hat mich das ein wenig gewundert. Eventuell liegt es auch am Reseller Webhosting.


    Link zur Beschreibung bei Plesk: https://talk.plesk.com/threads…safe-301-redirect.344817/

    P.S. Du könntest noch zusätzlich die Option "Dauerhafte, für SEO geeignete 301-Weiterleitung von HTTP zu HTTPS " in den Hosting Einstellungen aktivieren.

    Auf keinen Fall. Plesk bzw. Netcup sorgt seit neustem damit dafür, dass Let's Encrypt die Zertifikate nicht verlängern kann. Weil LE dann den Status Code 301 und nicht 200 zurück bekommt. War früher besser gelöst und hat geklappt ...