DNS für Domain eingerichtet => Sevrver aber nciht erreichbar

  • Ich hab über die Fritzbox schon div. Nameserver durch 8.8.8.8, 1.1.1.1 etc.

    Immer das gleiche Fehlerbild. Aber da jemand hier gefragt hat, ob am Server schon was eingestellt wurde: Nein.


    Was soll ich dort einstellen, dort läuft aktuell weder Apache noch Nginx, nur Docker.

  • bei dem adventskalender wurde ich ja praktisch genoetigt mir eine neue domain zuzulegen.

    habs damit nicht so eilig und statt eigener dns jetzt wie du nur die ips auf meine http/mail server geandert.

    und fuer http://www.bremnet.de eine ipv6 eingetragen.

    ttl 360

    expire 648000

    retry 900

    refresh 1800

    5min spaeter wurde die ipv6 gefunden, und auf einem testrechner auch die ipv4 (bremnet.de)


    bischen warten wuerd ich sagen.

  • Setze doch mal auf deinen Rechner (Windows?) feste Nameserver (die von Google) und probiere nochmal.

    pasted-from-clipboard.png

    4.4.4.4 ist sicher keine IP von Google. Du meinst bestimmt 8.8.4.4, oder?


    Interessent: Wenn du die Domain nicht öffentlich nennen willst – magst du sie vielleicht einem von uns via PN zukommen lassen?

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • zu dem thread faellt mir noch was ein,

    ich hab ein ziemlich einfaches system fuer interne webseiten, oder seiten in bearbeitung, selbst signierte certifikat,

    mit clientcerts.

    https://www.teanet.org/downloads/root.le.selfsigned.tar.xz

    cd /root/le/selfca

    ./cert_ca.sh


    danach belieg viel wildcardcerts erstellbar

    ./cert_srv_client.sh


    ca und client muessen importiert werden, aber nur einmal.


    da gibs jetzt keine grosse doku, aber vlt. kann es ja jmd gebauchen.

  • Wenn du zuhause bei einem nslookup/ping/whatever nicht die korrekte IP zurück erhälst, hat das rein gar nichts mit dem Server und seiner Config selbst zu tun.

    Edit: ich mag ja Vergleiche: wenn du eine falsche Anschrift für ne Hotelübernachtung hast, spielt es auch gar keine Rolle, üb dein Zimmer dort für dich vorbereitet wurde oder nicht, du findest ja nicht mal den Weg zum Hotel. :)


    Vorausgesetzt es stimmt, dass dir eine falsche IP mitgeteilt wird. Du gehst ja leider auf die Tipps bzgl DNS und alternativer DNS-Server zum Testen nicht wirklich ein...

  • Okay, hab ich überlesen, sorry. :)


    Trotzdem bleibt die Tatsache unlogisch, dass wenn du 8.8.8.8 befragst die falsche IP ausgeliefert wird, whatsmydns weltweit aber die korrekte IP zurückgibt. Dass es lange dauern kann, bis solche Einträge überall aktualisiert wurden ist ja bekannt, aber nach mittlerweile über 35h sollte das eigentlich durch sein.


    Hast du mal jemanden hier per PM die Domain genannt zum Gegenchecken? Vier Augen sehen mehr als zwei.


    Noch ne Nachfrage: die beiden A-Records * und @ zeigen beide auf den Server? (ist nicht eindeutig geklärt und auf dem Screen ja nicht ersichtlich)

  • Ich hab über die Fritzbox schon div. Nameserver durch 8.8.8.8, 1.1.1.1 etc.

    Vorgenommene Änderungen der Nameserver am eigenen Rechner oder vorgeschalteten Geräten gewährleisten noch lange nicht, dass einmalig erfragte Werte/Caches dadurch invalidiert werden. Deswegen sollte die Abfrage auf der Kommandozeile mit expliziter Wahl des abzufragenden Nameservers ("an der Systemeinstellung vorbei") erfolgen:

    Code
    % dig +short example.org @1.1.1.1
    % host example.org 8.8.8.8
    C:\>nslookup example.org 9.9.9.9

    Alternativ kann man Dienste wie https://www.whatsmydns.net/ verwenden, welche weltweite Abfragen zusammentragen (und bei Erstnutzung in der Regel von der fraglichen Domäne noch nie etwas gehört haben, also ihrerseits keine Cache-Einträge vorhalten).


    Wenn die Fehlerquelle auf der Netcup-DNS-Serverseite liegt, dann sollte man nach Ausschöpfung der obigen Möglichkeiten im CCP eine beliebige DNS-Eintragsänderung vornehmen (und sei es ein zusätzlicher "TEST"-TXT-Eintrag, der ansonsten nicht stört). Parallel dazu lässt sich für 24h auch das DNSSEC-Häkchen löschen, was eine sofortige Invalidierung aller Netcup-Einträge (welche noch irgendwo existieren könnten) zur Folge haben muss. Bei der Gelegenheit würde ich für künftige Tests den TTL-Wert heruntersetzen, wenn er noch auf 86400 oder noch höher steht.

    Wenn auch das nichts bringt, hilft nurmehr der Support zwecks Nachforschung auf Hosterseite mit Angabe der Domäne. (Sofern man nicht externe Nameserver nutzen will, was auch wiederum zuverlässig jegliche Caches bei Netcup löschen sollte.)



    EDIT:

    laut deinem #7 passen die DNS-einträge ja.

    Wenn das Problem gar nicht auf DNS-Seite/-Ebene liegt (und die IP-Adressen stimmen und exklusiv für die eigene Verwendung zur Verfügung stehen), muss es auf der Dienstseite/-ebene liegen. Ergo: Die Definitionen für den Webserver analysieren. Fühlt sich der Dienst zuständig für Anfragen? Gibt es Weiterleitungen?

    VServer IOPS Comparison Sheet: https://docs.google.com/spreadsheets/d/1w38zM0Bwbd4VdDCQoi1buo2I-zpwg8e0wVzFGSPh3iE/edit?usp=sharing