Netcup Domäne auf VServer konfigurieren

  • @ = domain.tld

    * = *.domain.tld, also ALLE Subdomains.

    Statt * kannst du natürlich auch einzelne Subdomains vergeben, wie z.b. www.

    Meine (Netcup) Produkte: S 1000 G7, VPS 200 G8 Ostern 2019, IPs, Failover..

  • Ich helfe dir mal, die Info aus dem von dir verlinkten Wiki-Beitrag zu extrahieren:


    Quote

    Das @-Zeichen Das @ bezeichnet in den Ihnen vorliegenden DNS Einstellungen die gebuchte 2nd-Level-Domain selbst. Lautet Ihre Domain domain.tld so ist der Record @ IN A 12.34.45.56 für domain.tld zuständig.

    also deinedomain.de



    Weiterhin schreibt das Wiki:

    Quote

    Als Wildcard dient hier das * (Sternchen)

    heißt also *.deinedomain.de (jegliche nicht von dir angelegte Subdomain, Wildcard halt..)


    Gruß

    René

  • Danke dir.

    Nur leider funktioniert es noch nicht.

    Meine Domain zeigt immer noch das folgende Bild:

    dns2.png


    Es steht auch bei Gültigkeit "unknown" Einstellungen (Host = *, Type A, Destiation = IP vom VServer).



    Ich war / bin jahrelanger Kunde bei United Domains. Dort war die Einstellung sehr einfach. Auch was Subdomains betrifft.

    Habe jetzt nur meine Hauptdomain zu netcup umgezogen wg dem VServer.


    Des weiteren suche ich nämlich wie ich einer Subdomain eine URL zuweisen kann.

    (Ich habe eine selbstgebaute Steuerung per myFritz Dyndns und entsprechendem Port im Internet geöffnet)

    Habe eben eine Subdomain angelegt und bei Destination nimmt er mir nur eine IP.

    Gibts eine andere möglichkeit?

    URL schaut so ähnlich aus (http://zzzyzzzz.myfritz.net/gui/phase2/viewdsp.htm)


    Danke

  • Was müsste ich machen wenn ich subdomains anlegen würde?


    Wie mfnalex meinte, deckt der * Eintrag alles ab, was nicht nochmal irgendwo sonst extra spezifiziert wurde.

    Wenn du eine bestimmte Subdomain wohin leiten willst, dann gibst du vorne in dem "Host" Feld einfach deine gewünschte Subdomain ein, wie "blog" oder "server", und bei Destination eben die IP.


    Der @ Eintrag steht für die Domain selber (domain.de), ohne Subdomain.


    Wenn man am frühen Morgen nicht bemerkt, dass es eine zweite Seite gibt... uff, war ja eigentlich schon erledigt.



    Danke dir.

    Nur leider funktioniert es noch nicht.

    Meine Domain zeigt immer noch das folgende Bild:


    Hast du wirklich DEINE IP von deinem vServer eingetragen? Neulich hatte jemand die selbe Verwirrung und hat bei Destination die Platzhalter IP drin gelassen, die bei ihm SEHR ähnlich wie seine Server IP aussah.

    Des weiteren suche ich nämlich wie ich einer Subdomain eine URL zuweisen kann.

    Habe eben eine Subdomain angelegt und bei Destination nimmt er mir nur eine IP.

    URL schaut so ähnlich aus (http://zzzyzzzz.myfritz.net/gui/phase2/viewdsp.htm)


    Das machst du mit einem CNAME  Record. Also wählst du statt dem "A" einfach "CNAME" aus.

  • Ich habe gerade meinen Beitrag nochmal bearbeitet, dort steht jetzt etwas mehr drin.


    Was den Fehler angeht:

    Du gibst nur xxxxxx.myfritz.net als Destination ein. Im DNS ist der Pfad (also /gui//...) völlig egal)

  • Und bedenke, dass die geänderten DNS-Einträge erst dann "live" sind, wenn bei der Gültig-Spalte YES steht. Erst dann wurde die Zone neu geladen.


    Danach kann es je nach eingestellter TTL nochmals 24-48 Stunden dauern, bis sich der neue Eintrag weltweit rumgesprochen hat.

    "Wer nur noch Enten sieht, hat die Kontrolle über seine Server verloren." (Netzentenfund)

  • Hast du wirklich DEINE IP von deinem vServer eingetragen? Neulich hatte jemand die selbe Verwirrung und hat bei Destination die Platzhalter IP drin gelassen, die bei ihm SEHR ähnlich wie seine Server IP aussah.


    Das machst du mit einem CNAME  Record. Also wählst du statt dem "A" einfach "CNAME" aus.


    Ja habe die richtige IP drin. Das habe ich gestern schon ein paar Mal probiert, ist auch das was am nagliegensten ist :)


    Ich habe gerade meinen Beitrag nochmal bearbeitet, dort steht jetzt etwas mehr drin.


    Was den Fehler angeht:

    Du gibst nur xxxxxx.myfritz.net als Destination ein. Im DNS ist der Pfad (also /gui//...) völlig egal)

    Das Protokoll muss weg. Wie du schreibst mit xxx anstatt http://xxx und dann eben ohne Pfad.

    Heisst das, dass er nur auf den Port 80 lauscht und dann intern im NAT auf den Pfad geht?

    Ich habe eine index.html in /var/www liegen.

    (Sonst im Apache nichts geändert. OS ist CentOS)


    Meine Subdomain funktioniert. Aber die Domain zeigt immernoch den blauen netcup screen. :(

  • Heisst das, dass er nur auf den Port 80 lauscht und dann intern im NAT auf den Pfad geht?


    Wenn du einen CNAME Record setzt, beispielsweise heim.domain.de zeigend auf horst.myfritz.de, dann ist das so als würdest du auf deiner Hausnummer eine andere Nummer kleben. Der Pfad in deine Wohnung/Haus ist ja der selbe. Du ersetzt wortwörtlich nur das Aussehen der (Sub-)Domain, einfach gesagt, ohne auf die genaue Technik einzugehen.


    heim.domain.de/gui/settings ist genau das selbe wie horst.myfritz.de/gui/settings

    heim.domain.de:22 ist genau das selbe wie horst.myfritz.de:22

    heim.domain.de:8443/dashboard ist genau das selbe wie horst.myfritz.de:8443/dashboard

    Meine Subdomain funktioniert. Aber die Domain zeigt immernoch den blauen netcup screen. :(


    Woran machst du denn fest, dass sie funktioniert? Löst sie wirklich auf deine IP auf?

    z.B. mit dig deine.domain.de prüfen

  • Wie kann ich denn einen redirect unter nginx einrichten?

    Wie vor einigen Wochen in diesem Thread erörtert muss man ja immer den genauen URL String beim Domainname auf den server angeben.


    (Zur Erinnerung: bei United domains konnte man eine domain incl. der Subverzeichnisse

    https://forum.netcup.de/system/attachment/5513-fdsa-png auf die Zieldomain (Hauptdomain) verweisen lassen. Das vermisse ich bei Netcup schmerzlich)


    Nachdem das bei Netcup nicht geht ist meine Frage:


    Wie kann ich es auf dem server mit CentOS und Nginx einrichten, dass beim Aufruf der Hauptdomain http://www.hauptdomain.de automatisch einen "redirect?" auf das Subverzeichnis macht z.b. http://hauptdomain.de/ich/bin/ein/subfolder.html

  • foxi Nur die Hauptdomain, also wirklich nur /?


    Dann verwende folgenden Codeschnippsel im entsprechenden Serverblock:

    Code: nginx.conf
    location = /
    {
        return 302 "/ich/bin/ein/subfolder.html";
    }

    "Wer nur noch Enten sieht, hat die Kontrolle über seine Server verloren." (Netzentenfund)

  • Hi, ich habs leider nicht ganz hinbekommen, da er mir ja mit dem return befehl nur den Subfolder konkateniert. Aber so dürftig wie ich es beschrieben hatte war es natürlich richtig.


    Das hier war jetzt die Lösung

    Code
    location / {
            #       return 302 "/gui/phase2/viewdsp.htm";   
            rewrite ^/(.*)$ http://cdfdasfdsafdsax.myfritz.net/gui/phase2/viewdsp.htm$1 permanent;
            }

    Ist nicht schön, da die ursprüngliche URL nicht mehr im Browser steht, aber es klappt.

  • Wenn du die URL behalten willst, dann kannst du einen ProxyRequest machen. Vorraussetzung ist hier aber, dass die Anwendung dahinter damit klar kommt.

    "Security is like an onion - the more you dig in the more you want to cry"