Performance Webserver - was könnte hier nicht stimmen

  • Hallo,


    ich nutze den größten VServer bei netcup (SSD) und habe nginx laufen. Bei meiner WordPress Multisite kommt es teilweise zu hohen Latenzen. Für meine Seite Currywurst Test - Wer hat die beste Currywurst? hat der Google Speed Test gerade eine Antwortzeit von 4 Sekunden beim Server gemessen (PageSpeed Insights).


    Für die Hardware, die Anbindung laut netcup und nginx viel zu langsam. Ich weiss auch nicht, ob das wirklich meine Einstellungen bei nginx sind (gzip läuft, expire max bei verschiedenen Dateitypen ist gesetzt). Andere CMS wie limesurvey sind sehr schnell. Bei WordPress setze ich MU Domain Mapping ein. Das frisst zwar etwas Zeit, sollte sich aber nicht im Sekundenbereich auswirken. Errors habe ich im Log keine und auch MySQL kann es eigentlich nicht sein, da die Ladezeit scheinbar bereits vor Aggregieren der Daten zustande kommt, nämlich beim Warten auf den Host. So zumindest interpretiere ich das.


    Habt ihr Empfehlungen für mich, was ich austesten könnte - weil ich schon länger etwas ratlos bin? Kann es am Wirtsystem liegen, kann ein Paket am Server fehlen, das nicht installiert ist?


    Liebe Grüße


    Ben

  • Guten Abend,



    bei Wordpress ist gerne ein Plugin für langsame Ladezeiten die Ursache, dass Daten von extern anfordert. Wordpress ist je nach Plugin erst fertig geladen, wenn der Request nach extern bearbeitet ist.


    Wie schnell baut sich eine statische Seite zum Vergleich auf?



    Mit freundlichen Grüßen


    Felix Preuß

  • Ich habe einmal eine einfache php-Seite ohne Datenbankabfrage getestet und komme auf 1 sec laut gtmetrix bei page load time. Bei einer uninstallierten WordPress Version, d.h. bei der Anzeige des Setups komme ich auf eine Seitenladezeit von 2,5s.


    Beides mal habe ich Dateien abgefragt, die keinerlei Datenbankabfrage starten. Das müsste doch eigentlich viel schneller gehen? Ich habe meine fpm Einstellungen durchgesehen und sie von TCP auf Socket umgestellt, aber es hat sich nichts geändert. Hat jemand Tipps? Scheint wohl an FPM zu liegen?

  • Hi!


    Ich kenne das Problem mit Wordpress und das langsam laden. Meine (nicht MU) Wordpressseite hat immer ewig geladen.


    Mittlerweile läuft es jedoch sehr gut und schnell:


    - nginx: Hast du da entsprechende Einstellungen vorgenommen? (epoll, tcp_nodelay, etc.)
    -> SSL: Das aktivieren von spdy durch nginx hat den Seitenaufbau schonmal gewaltig beschleunigt
    - Cache: Benutzt du einen cache bzw. ein Plugin? Ich nutze redis als cache und das redis object cache plugin
    - mysql: Optimierungen vorgenommen?

  • 4 Sekunden bis zur ersten Antwort (auch ohne https) ist schon sehr lange. :!:


    Meine WordPress Seite hatte ähnliche Antwortzeiten auf einem Shared Webhosting.
    Mit dem Umzug auf meinen Root Server M v6 SSD (auch nginx/php-fpm) ist diese jetzt bei erträglichen 500-700ms (weitere Optimierungen mit WP-/PHP-Caches sind noch auf der TODO-Liste).
    Eine andere Webseite mit einem einfachen PHP Skript, dass aus einer Datenbankabfrage eine Tabelle generiert, antwortet in 45ms.


    Ich setze auf CentOS 7, nginx 1.8.0 (vom nginx repo), PHP 5.6.12 (vom remi-php56 repo) und mariadb 5.5.41 (CentOS repo) und bin äusserst zufrieden mit der Performance.
    Kannst du deine OS, nginx, php-fpm und mysql/mariadb Versionen, sowie (auszugsweise) deine nginx und php-fpm Konfigurationen posten?


    CentOS 7 / nginx / php-fpm / postfix / rspamd / dovecot / nextcloud / docker / elk running on Root Server M SSD v6 (gekündigt) / VPS 500 G8 / VPS 2000 G8 Plus

  • Hi,


    danke für eure Antworten. Generell ist es so, dass die einzelnen WordPress Seiten unter 1 Sekunde laden, aber Seiten innerhalb der Multisite scheinbar das hauptsächliche Problem sind, aber ich hab schon generell das Gefühl, dass es etwas zu langsam läuft. Spdy werde ich gleich ausprobieren und nochmal Zwischenstand liefern. e_poll ist aktiviert, tcp_nodelay ist an. Ich benutze auf WordPress Seite kein Caching-Plugin. memcache und apcu sind an bei PHP.


    Allgemeine Systeminfos:
    PHP 5.5.27-1~dotdeb+7.1


    10.0.21-MariaDB
    nginx/1.2.1
    Debian 7


    php fpm conf sieht folgendermaßen aus:



    nginx multisite setting (eine Seite):




    In drop.conf stehen Sachen wie robots.txt und favicon sowie expire max header für Dateien. Wordpress-sec.conf sind die Security Regeln von iThemes Security Plugin.

  • Da mir dieses Apache und Nginx zu groß sind für solche Zwecke sind, besser allgemein zu groß benutze ich Lighttpd.


    Es ist schnell und einfach installiert und in verbindung mit FastCGI extrem Performant, hab das mit Wordpress am laufen. 1000 Datein in 15 Sekunden geuploadet und die Seite liefert diese Datein in einer Sekunde aus das mit 256bit Verschlüsselung TLS1.2 :D Im Hintergrund laufen paar Plugins sowie SSL das kommt halt noch dazu :3