Posts by sdellenb


    Scheint je nach Gerät nicht so wirklich zu klappen, außer als Chroot-Umgebung. Vielleicht hat's auch niemand ernsthaft probiert, weil technisch möglich wäre es sicher irgendwie. Die Frage ist halt trotzdem, ob man sich dann extra so ein Gerät kauft, wenn man die (mitbezahlte) Software gar nicht verwendet. Rein für die Hardware sind die Preise ja durchaus stolz, wenn man von der Größe und dem Design mal absieht. Letzten Endes wäre es dann trotzdem wieder eine Bastellösung, wenn man ein anderes OS aufspielt.

    Ich hatte mein QNAP TS-569L mit CentOS 7 neu aufgesetzt, weil die zusätzlichen Apps immer mehr zum Gebastel wurden oder nicht mehr aktualisiert wurden.


    Es hat ein paar missglückte Experimente (und Hardware für die Wühlkiste) gebraucht, bis ich einen funktionierenden 9-PIN USB DOM Ersatz hatte und auch der hatte übelst Probleme beim Schreibzugriff (ständig USB Resets und damit korruptes FS).
    Als dann nur noch Grub im MBR und /boot drauf blieben, lief es problemlos 2 Jahre als normaler Home Server, sogar mit dynamischer Lüftersteuerung.


    Leider ist er seit 3 Jahren in der Umzugskiste, weil die aktuelle Wohnung keinen passenden Platz hat. Der Raspi lässt sich einfach im Elektroschrank verstecken.


    Ja, hast Recht. Es ist immer noch ein Gebastel, aber ein hübsches und kompaktes. 8)

    "Ein frei im Internet stehender Server mit 1 Gbps Anbindung bringt eine grosse Verantwortung und sollte nur mit entsprechenden Admin-Kenntnissen und Zeit dafür betrieben werden."


    Too soon? :D

    Wie haltet ihr das mit dem Geolocation für Tracking (z. B. Matomo)?


    Wie sind hier die Meinungen zu:

    ip2location vs maxmind

    Ich benutze ip2location, weils von Matomo so vorgeschlagen wurde. Funktioniert zufriedenstellend für die paar WP Seiten. 👍

    Annahme: Alles von killerbees19 erwähnte wurde bereits korrekt umgesetzt.

    Google hat ein paar einzelne Mailserver, die bei IPv6 rumzicken. Ich hab meinen Postfix so konfiguriert (nach dieser Anleitung), dass er bei dieser Fehlermeldung eine erneute Zustellung über IPv4 versucht. Das klappt bisher immer.


    Update: Ich seh grad, Google hat die Fehlermeldung leicht geändert. Muss ich gleich meine Regex anpassen.


    Code: main.cf
    1. # Working around Google's broken IPv6 implementation returning 5.5.0 on random tries.
    2. # Found here: https://blog.hqcodeshop.fi/archives/122-Fixing-Googles-new-IPv6-mail-policy-with-Postfix.html
    3. # Gmail IPv6 retry:
    4. smtp_reply_filter = pcre:/etc/postfix/smtp_reply_filter


    Code: smtp_reply_filter
    1. # Convert Google Mail IPv6 complaint permanent error into a temporary error.
    2. # This way Postfix will attempt to deliver this e-mail using another MX
    3. # (via IPv4).
    4. # See https://blog.hqcodeshop.fi/archives/122-Fixing-Googles-new-IPv6-mail-policy-with-Postfix.html
    5. /^5(\d\d )5(.*p=IPv6AuthError .* - gsmtp.*)/ 4${1}4$2


    Update 2: OK, ich seh grad in den Logs, dass ich den Fall schon ewig nicht mehr hatte.

    Ich persönlich sende nichts benutztes zurück wenn es nicht ein Garantiefall ist. Aber ich hab auch eine Kiste mit unbenutztem Elektrokram im Schrank... :/

    Verwunderlicher Fall :D


    Sind die Header der Mails gleich, also auch Date, X-PPP-Message-ID und X-NC-CID und so?

    (kopiert aus Post #7)

    Vielleicht verwirren die erwähnten fehlenden Header den Netcup Mailer...


    Update: Gibt's evtl mehr als eine .msmtprc? VIelleicht lungert je nach User eine im Home, die Unsinn enthält (ist mir schon mal passiert)?


    Update 2: In der Crontab kannst du Sender und Empfänger definieren:

    Code
    1. MAILFROM=from@example.com
    2. MAILTO=to@example.com