Posts by meisterpropper

    Hi,


    danke für die Tipps soweit.
    Also beide Server geben mit einem Testnutzer ohne require SSL aus:




    +---------------------+----------------------------+
    | Variable_name | Value |
    +---------------------+----------------------------+
    | have_openssl | YES |
    | have_ssl | YES |
    | ssl_ca | /etc/mysql/ca-cert.pem |
    | ssl_capath | |
    | ssl_cert | /etc/mysql/server-cert.pem |
    | ssl_cipher | |
    | ssl_crl | |
    | ssl_crlpath | |
    | ssl_key | /etc/mysql/server-key.pem |
    | version_ssl_library | OpenSSL 1.0.1k 8 Jan 2015 |
    +---------------------+----------------------------+
    10 rows in set (0.00 sec)


    Die Abfrage, ob der Nutzer SSL verwendet ist:



    +---------------+-------+
    | Variable_name | Value |
    +---------------+-------+
    | Ssl_cipher | |
    +---------------+-------+
    1 row in set (0.00 sec)


    Wenn ich die SSL Parameter direkt angebe (

    Code
    1. mysql --ssl-ca=ca.pem --ssl-cert=client-cert.pem --ssl-key=client-key.pem -h 1.1.1.1 -u test1 -p

    ) dann geht es und der User hat eine Cipher:


    +---------------+---------------------------+
    | Variable_name | Value |
    +---------------+---------------------------+
    | Ssl_cipher | DHE-RSA-AES256-GCM-SHA384 |
    +---------------+---------------------------+
    1 row in set (0.00 sec)


    Log warnings sind aktiviert, aber die eine Log ist mit MySQL Statements überflutet, da finde ich nichts. Hast du noch einen Tipp, wie ich es enger eingrenzen könnte, weil es scheint ja mit der User Deklaration zu tun zu haben?

    Hallo zusammen,


    ich möchte eine komplette Datenbank auf einen Vserver bei Netcup unter Debian 8 mit MariaDB replizieren - der netcup Server fungiert als Slave.
    Die Verbindung vom Slave zum Master klappt ohne Probleme, allerdings nicht, wenn der Nutzer, der sich auf den Master verbinden darf, SSL nutzen muss. Ich habe MySQL mit SSL nach folgendem Wiki auf beiden Servern eingerichtet: MySQL Verbindungen mit SSL verschlüsseln – Thomas-Krenn-Wiki


    Fehlermeldung, sobald dieser Nutzer nach der Anleitung damit angelegt wurde (allerdings nur mit USAGE Rechten): ERROR 1045 (28000): Access denied for user. Wie gesagt: Das tritt nur auf, sobald REQUIRE X509; oder REQUIRE SSL; bei einem Nutzer gesetzt ist. Ich habe die Ca, Certs und Keys auf den netcup Server vom Master kopiert. Die Firewall blockt es auch nicht, da die Authentifikation am Master ankommt.


    Hat jemand einen Rat, woran das liegen könnte?

    Ist Opcache nur installiert oder auch aktiviert und richtig konfiguriert? Bitte beachte auch, dass der Cache erst ab dem 2. Aufruf gefüllt sein kann.

    Ja:



    Opcode Caching Up and Running
    Optimization Enabled
    Startup OK
    Shared memory model mmap
    Cache hits 481009
    Cache misses 110213
    Used memory 134215488
    Free memory 24
    Wasted memory 2216
    Cached scripts 2226
    Cached keys 2507
    Max keys 3907
    OOM restarts 0
    Hash keys restarts 0
    Manual restarts 0

    Hallo zusammen,


    ich nutze Debian 7, nginx 1.80 und PHP 5.6.13 (Dotdeb) auf dem VS XL. Nach der Aktualisierung auf PHP 5.6.13 von 5.5.xx ist nun der PHP Prozess langsamer geworden, obwohl es laut mehrere Seiten schneller hätte werden müssen. Opcache läuft, memcache angeblich auch laut phpinfo, obwohl der noch gar nicht implementiert sein dürfte laut dotdeb (verwirrend), aber wenn ich jetzt z.B. einen Benchmark Test mit dem WordPress Performance Test Plugin mache, erhalte ich folgende Werte:


    Time to perform:Math test: 0.53 secondsTime to perform:StringManipulation test: 0.97 secondsTime to perform:test Loop test: 0.47 secondsTime to perform:test IfElse: 0.45 secondsTotal time(all PHP tests): 2.42 seconds



    Ich weiß jetzt nicht genau, ob es sinnvoll ist hier einen Link zu meiner kompletten phpinfo zu posten oder ob einzelne Werte ausreichen würden, aber generell meine Frage: Wie kann ich das ganze noch performanter gestalten? Ich nutze FPM und dort lege ich eigene Confs im Ordner pool.d/ ab, z.B.


    [web folder]


    listen = 127.0.0.1:9001
    listen.allowed_clients = 127.0.0.1


    user = web
    group = web
    listen.mode = 0660


    pm = ondemand
    pm.max_children = 100
    pm.process_idle_timeout = 10s
    pm.max_requests = 200


    chdir = /


    php_admin_value [open_basedir] = /var/kunden/web/www:/usr/share/php5:tmp:/var/tmp:/var/kunden/web/tmp
    php_admin_value[disable_functions] = dl,passthru,shell_exec,system,proc_open,popen,show_source



    Hat jemand Tipps für mich?

    Hi,


    danke für eure Antworten. Generell ist es so, dass die einzelnen WordPress Seiten unter 1 Sekunde laden, aber Seiten innerhalb der Multisite scheinbar das hauptsächliche Problem sind, aber ich hab schon generell das Gefühl, dass es etwas zu langsam läuft. Spdy werde ich gleich ausprobieren und nochmal Zwischenstand liefern. e_poll ist aktiviert, tcp_nodelay ist an. Ich benutze auf WordPress Seite kein Caching-Plugin. memcache und apcu sind an bei PHP.


    Allgemeine Systeminfos:
    PHP 5.5.27-1~dotdeb+7.1


    10.0.21-MariaDB
    nginx/1.2.1
    Debian 7


    php fpm conf sieht folgendermaßen aus:



    nginx multisite setting (eine Seite):




    In drop.conf stehen Sachen wie robots.txt und favicon sowie expire max header für Dateien. Wordpress-sec.conf sind die Security Regeln von iThemes Security Plugin.

    Ich habe einmal eine einfache php-Seite ohne Datenbankabfrage getestet und komme auf 1 sec laut gtmetrix bei page load time. Bei einer uninstallierten WordPress Version, d.h. bei der Anzeige des Setups komme ich auf eine Seitenladezeit von 2,5s.


    Beides mal habe ich Dateien abgefragt, die keinerlei Datenbankabfrage starten. Das müsste doch eigentlich viel schneller gehen? Ich habe meine fpm Einstellungen durchgesehen und sie von TCP auf Socket umgestellt, aber es hat sich nichts geändert. Hat jemand Tipps? Scheint wohl an FPM zu liegen?

    Hallo,


    ich nutze den größten VServer bei netcup (SSD) und habe nginx laufen. Bei meiner WordPress Multisite kommt es teilweise zu hohen Latenzen. Für meine Seite Currywurst Test - Wer hat die beste Currywurst? hat der Google Speed Test gerade eine Antwortzeit von 4 Sekunden beim Server gemessen (PageSpeed Insights).


    Für die Hardware, die Anbindung laut netcup und nginx viel zu langsam. Ich weiss auch nicht, ob das wirklich meine Einstellungen bei nginx sind (gzip läuft, expire max bei verschiedenen Dateitypen ist gesetzt). Andere CMS wie limesurvey sind sehr schnell. Bei WordPress setze ich MU Domain Mapping ein. Das frisst zwar etwas Zeit, sollte sich aber nicht im Sekundenbereich auswirken. Errors habe ich im Log keine und auch MySQL kann es eigentlich nicht sein, da die Ladezeit scheinbar bereits vor Aggregieren der Daten zustande kommt, nämlich beim Warten auf den Host. So zumindest interpretiere ich das.


    Habt ihr Empfehlungen für mich, was ich austesten könnte - weil ich schon länger etwas ratlos bin? Kann es am Wirtsystem liegen, kann ein Paket am Server fehlen, das nicht installiert ist?


    Liebe Grüße


    Ben

    Danke für die vielen Tipps. Ob es damit mein eigentliches Problem gelöst hat, kann ich noch nicht sagen, aber ist ein spannendes neues Thema.


    Nutzt von euch jemand wirklich DMARC Record und vor allem DKIM? DKIM erscheint mir sehr aufwendig zu verwalten oder werden die Keys automatisch nach erstmaligem Aktivieren generiert?

    Hallo zusammen,


    ich habe einen Vserver bei netcup mit Debian 7 und nutze den Postfix smtp(s) Server. Mir ist neulich aufgefallen, dass Mails, die entweder durch php oder direkt über Thunderbird etc. verschickt werden z.T. nie bei outlook oder hotmail Adressen zugestellt werden. Das komische ist, dass es scheinbar nicht direkt am Mailserver, sondern an der Domain liegt. Nutze ich z.B. mein Standardmailkonto kommt jede Mail an. Nutze ich eine andere Domain und damit anderes Postfach, die mit dem gleichen Server und dem gleichen Mailserver verknüpft ist, kommt sie nicht an.


    Ich habe bereits über die IP-Adresse des Server auf Blacklisten geprüft, aber hatte nirgends Probleme gefunden. Auch der Support von outlook findet keine Probleme mit meiner Server-IP. Hatte jemand von euch schonmal so ein Problem? Es handelt sich dabei um ganz normale Mails: kein Newsletter-Versand, keine HTML Mails.


    Die Mails gehen definitv raus, hab den Mail log überprüft und er ist jedes Mal identisch zu anderen Empfängermailadressen, bei denen die Mails zugestellt werden. Wie könnte ich weiter vorgehen?