Storage space kann nicht gemounted werden

  • Huhu,


    ich habe eine VPS und Storage-Space dazu gemietet. Davor hängt eine pfsense. Alles hängt in einem VLAN. Die VPS kommt ohne Probleme ins Internet.


    Bei versuch den Storage Space zu mounten habe ich folgende Anleitung verwendet:

    https://www.netcup-wiki.de/wiki/Storagespace_mounten


    Ich erhalte den Fehler:

    Systemfehler 53 - Netzwerkpfad wurde nicht gefunden.


    Troubleshooting:

    - Windows-Firewall ausgeschlossen (deaktiviert - Hier ist ausgehend sowieso alles offen)

    - Pfsense ausgeschlossen (nichts im LOG)

    - Verschiedene IPs freigegen

    -- Da das Internet der VPS über die VPS mit pfsense läuft, habe ich die WAN-IP freigegeben

    -- Interne IPv4 (macht keinen Sinn aber wer weiß)

    -- Die IPv4 der eigentlichen VPS (Karte ist aber deaktiviert)

    - IP vom Storage ist pingbar

    - Tracert hat mir jetzt auch keine neuen Erkenntnisse gebracht

    - ...


    Ich habe ein aktuelles Windows Server 2016 Standard installiert und das Storage ist als AddOn zu dieser VPS gekauft.


    Würde mich über ein paar Ansätze/Hilfe freuen.


    VG

    Green14

  • Hay,

    Ich habe ein aktuelles Windows Server 2016 Standard installiert und das Storage ist als AddOn zu dieser VPS gekauft.


    Versuch mal https://www.rootusers.com/how-…e-in-windows-server-2016/ da gibts "kleine" Abweichungen zur Netcup-Beschreibung für Windows Server 2012.


    CU, Peter

  • der nfs-Client ist tatsächlich installiert ? Hatte schon mal den Fall, das die Installation scheinbar sauber durchgelaufen war, aber nix funktionierte. Nach der Installation aus der PS heraus ging es dann ...

    Gruss

    Habs gerade noch einmal mit PS gemacht:

    Daran liegts auch nicht.


    VG

    Green14

  • Ich habe mal nur den Storage-Host im Explorer aufgerufen (\\IP-Storage-Host\). Und man kann alle Volumes sehen (siehe Screen). Danach habe ich meines rausgesucht. Ein Doppelklickt löst die oben bereits erwähnte Meldung aus. Man muss dazu sagen, dass es bei allen anderen Volumes den gleichen Fehler gibt. Wenn ich dann auf "Diagnose" klicke wird mir mitgeteilt, dass SMB nicht funktioniert / nicht unterstützt wird.


    Ich hau NFS-Client noch einmal runter und installiere den mal neu.

  • die Meldung würde ich ja verstehn - ist ja ein NFS-Share und kein Samba(WIndows)-Share.

    Muss ich passen, weit weg von meinem scope ..

    Gruss

    Habs mal ohne NFS-Client probiert und da lässt er mich nicht mal auf den Host. Also doch wieder nur Mist aus der Windows Diagnose :P - Kein Problem vielleicht ein Problem von Netcup.

  • installier das ding mal durch und dann gucken wir mal. Obs die Windows-Kiste ist

    :-) wenns meine Server wären, würd ich jetzt Wetten abschliessen :-)

    Aber wenn du ein Debian da hast: mach doch mal ein "showmount -e ip_vom_storage", da sollte an sich erstmal der Export sichtbar sein, mal seh was da als Errror beim Mounten kommt ...

    Gruss

    PS: so, Feierabend

  • SOOOOOOO


    Ich habe mal auf nem debian die sachen ausprobiert. Da ich jetzt nicht unbedingt der Linux pro bin kurz zur konfig:

    - Debian 9.3 minimal Image

    - Nur Systemwerkzeuge mitinstalliert

    - Auch hinter pfsense

    - nur apt-get update und upgrade gemacht

    - dann die Anleitung befolgt


    Code
    1. showmount -e ip_vom_storage

    Das zeigt mir alle Verzeichnisse an. Witziger weise steht hinter jedem Ordner (everyone).


    Das mounten hat nicht funktioniert. Es wird der Fehler: access denied by server while mounting xxxxx angezeigt.

  • Hay,


    bitte mach mal den Mount "more verbose"... dann sieht man vielleicht eine genauere Ursache, z.B.


    Code
    1. mount -t nfs -vvvv xxx.xxx.xxx.xxx:/meinshare /mnt

    -vvvv = verboseverboseverboseverbose :D

    xxx.xxx.xxx.xxx = IP vom Storagespace


    CU, Peter

  • Habs getan:


    - Trying text-based options 'vers=4.2,addr=HOST-IP,clientaddr=IP-DES-INTERFACE-AM-CLIENT-AN-DER-PFSENSE'

    - mount (2): Protocol not supported

    - Trying text-based options 'vers=4.1,addr=HOST-IP,clientaddr=IP-DES-INTERFACE-AM-CLIENT-AN-DER-PFSENSE'

    - mount (2): Protocol not supported

    - Trying text-based options 'vers=4.0,addr=HOST-IP,clientaddr=IP-DES-INTERFACE-AM-CLIENT-AN-DER-PFSENSE'

    - mount (2): Protocol not supported

    - prog 100003, trying vers=3, prot=6

    - trying HOST-IP pro 100003 ver 3 prot TCP port 2049

    - prog 100005, trying vers=3, prot=17

    - trying HOST-IP pro 100003 ver 3 prot TCP port 635

    - mount (2): Permission denied

    - access denied by server while mounting


    Ich habe auch mal jegliche IP freigegeben, die irgendwie beim Zugriff genutzt wird. WAN, Clientinterface und Gateway an der pfsense zum Clientnetz. Auch habe ich mal von einer weiteren VPS (Windows 10, welche ich direkt ins Internet gehängt habe, getestet. Hier lief es auf das gleiche Ergebnis hinaus.