Posts by moritzh

    Sagt mal, zählen irgendwelche Forenbereiche nicht zum Beitragszähler? :/


    Im Profil habe ich 8.777 Beiträge, laut der Forensuche komme ich aber auf 8.782.


    (Nicht, dass das wichtig wäre. Ich bin nur gerade zufällig über die Differenz gestolpert.)

    Das mit dem nicht zählen einzelner Foren wäre eine Möglichkeit, aber der Beitragszähler ist auch manchmal nicht 100% richtig. Der Wert dahinter ist in der Usertabelle der Foren DB "gecached" und wird dort vermutlich immer nur hoch und runtergezählt. Da kann scheinbar ab und zu was schieflaufen, das konnte man auch schon in anderen Foren beobachten. Es gibt im Admin Bereich des Forums einen Cleanup Task, "Beiträge neu zählen" (oder so ähnlich). Eventuell müsste man das mal ausführen.

    Auch eine Möglichkeit wären die Logfiles. Ich hatte insbesondere bei Nextcloud auf Webhosting schon ein paar mal denn Fall beobachtet, dass ~ 50MB Log pro Sekunde produziert werden bis das nach ein paar Minuten in den Timeout läuft. Da kommen schnell einige GB zusammen. Ist ab und zu beim Upgrade aufgetreten, aber war leider nicht systematisch reproduzierbar.

    Ich bezweifle an dieser Stelle, dass es sich bei 96 Cent um die volle Jahresgebühr handelt.

    So ist das. Bei S. kostet die domain 96 cent pro Monat, aber mit einer Mindestlaufzeit von 12 Monaten. Der Umzug hat dich also 11,50 gekostet

    Das stimmt nicht, es sind tatsächlich 0,96€ pro Jahr / 0,08€ pro Monat bei S****o für eine .de Domain. Allerdings ist das ein Werbeangebot, dass nur die ersten 12 Monate gilt, danach sind es 0,80€ / Monat. Es ist aber möglich nach 12 Monaten zu kündigen.


    Edit: Da waren jetzt gleich zwei schneller beim absenden :-)

    error_log und proxy_error_log sind leer.

    In welche error_log Datei hast du geschaut? Es gibt mehrere.

    In meinem Webhosting beinhaltet /logs/error_log nur die Meldungen für die Default hosting... Domain. Im logs Ordner gibt es noch Unterordner pro Domain und darin weitere error_log Dateien, z.B.: /logs/example.com/error_log (gleiches gilt für proxy_error_log).

    Sind diese ebenfalls leer?

    Hat jemand hier Erfahrung mit selfhostet Kanban Boards und kann da was empfehlen?

    Zielgruppe kleines Team (5-10 Personen), soll php basiert sein (= soll auf Webspace hier bei netcup laufen). Gerne mit viel Klickibunti :-)

    Hat jemand eine Idee was alles dafür verantwortlich sein könnte, dass Mails im Spam Ordner nach 30 Tagen gelöscht werden?


    Ich hab im Webhosting hier (2000) ein Postfach und die Mails im Spam Ordner verschwinden nach 30 Tagen, was ich gerne nicht so hätte.

    Das Postfach hat den netcup Spamfilter aktiviert mit der Einstellung alle Spam Mails in eben diesen Spam Ordner zu verschieben.

    Dass die Mails weg sind sehe ich immer morgends (also heute morgen war der 25.12. gelöscht).

    Clientseitig habe ich schon folgendes probiert (jeweils nacheinander):

    - Ich habe das Passwort geändert und 24 Stunden nur wie Webmail (Roundcube von netcup) zugriffen

    - Passwort geändert und nur via Evolution zugegriffen

    - Spam Filter im CCP/WCP deaktiviert

    Am nächsten morgen waren die Mails jeweils immer weg dann.

    Ich habe auch schon den netcup Support befragt, aber nur die Aussage bekommen, netcup löscht keine Kundenmails, das muss am Client liegen.

    Weder bei Roundcube noch bei Evloution habe ich eine solche Funktion gefunden.

    Der Filter ist zudem noch fehlerhaft. Manchmal überleben einzelne ältere Mails ein paar Tage und sind dann irgendwann später gelsöcht.

    Dass beide Programme keine Einstellung anzeigen und diese Funktion automatisch an und gleichzeitig noch der Filter die gleichen Lücken hat, halte ich für nicht so sehr warscheinlich.

    (Die Sieve Filter habe ich auch gecheckt, aber dort ist nur das default "empty script")


    Hat jemand noch eine Idee was die Mails löschen könnte (insbesondere Clientseitig)?

    Interessanterweise sind auf dem neuen Host einige Fehlermeldungen nicht aufgetaucht.

    Beziehst du das auf die /dev/urandom Warnung? Dann könnte es auch an Nextcloud 15 liegen, dort wurde das glaube ich endlich behoben. (Zumindest laut github, habe noch nicht selbst geupdated.)

    JKMakowka Was genau rufst du auf?

    Ich habe es gerade unter zwei verschiedenen Webhosting Accounts probiert mit

    /usr/local/php72/bin/php composer.phar --version

    (bzw. php56, php70, php71 php72, php73)

    und es funktioniert ohne Probleme.


    Dazu hab ich gesehen gibt es mittlerweile direkt in /bin auch ein php binary (Softlink auf die obige 7.2).

    Das heißt php composer.phar --version oder direkt ./composer.phar --version geht auch. Das muss netcup irgendwann eingebaut haben, das gab es definitiv noch nicht als ich damals dann eine passende .bash_profile angelegt hab.
    (Die letzten beiden Optionen sind dann halt fest mit php 7.2, bzw für anderen Versionen kann man ja immer noch eine .bash_profile anlegen und den Pfad entsprechend setzen)

    Oder die "Ein Anderer wird das schon machen" Mentalität greift um sich - weil die Mail ja nicht nur an einen Teilnehmer geht.

    wenn nach 12h niemand die Mail angefasst hat, wird das Tool renitent und nach 24h wird der Chef informiert, dass noch nichts gelaufen ist.

    Als Kontext, es geht um einen kleineren Verein. Es kann fast nichts von außen kommen, dass Zeitkritisch wäre. Dazu handelt es sich um Freizeitaktivität, was heißen soll die Personen sind durchaus Motiviert und nicht unbedingt darauf aus, dass es ein anderer macht. Aber hat halt nicht jeder immer gleich Zeit dann dafür. Es ist klar, dass sowas nur im kleinen Maßstab funktioniert wenn sich die Personen einigermaßen gut kennen. Das wird so sicher nicht Skalieren wie das aktuell gehandhabt ist, und erst recht nicht in geschäftlichem Maßstab funktionieren.


    Danke auf jedenfall für den Tipp mit dem Ticketsystem. Ich würde mal zum ausprobieren ein Ticketsystem testen. Interessant hört es sich auf jedenfall an, muss ich wenigsten dann mal probiert haben :-) (Falls jemand eine Empfehlung hat was sich auch für eher kleinen Maßstab eignet, gerne her damit, sonst les mich bei Gelegenheit mal ein was es da passendes gibt.)

    Meine Befürchtung wäre nur, dass das halt ein weiteres Tool ist, wo sich jeder einloggen muss zum etwas tun. Das ist halt das schöne an den Mailpostfächern, die muss jeder nur einmal einrichten und bekommt passiv alles mit :-)

    (Zumal >50% der Kommunikation der info@ eh wie eine Mailingliste unter den Personen geht.)

    Ich frage mich nämlich: Wie löst Du es aktuell, dass nicht mehrere Empfänger die gleiche Mail bearbeiten?


    Bisher hat sich die Frage gar nicht gestellt. Das Mailaufkommen ist generell (abgesehen von Massen an Spam) sehr gering. Generell kommen eh so gut wie kaum externe Mails. Die info@ wird entweder als Verteiler genutzt von den 10 Empfängern untereinander oder die Zuständigkeit ergibt sich aus dem Kontext (Antwort auf Anfrage von uns, die info@ wird CC gesetzt, damit jeder Kentnis davon bekommt) Das es Bearbeitungskonflike gibt sollte sehr sehr Unwahrscheinlich sein. Der Gedanke ist eher, wenn alle die Mail bekommen findet sich eher jemand der dann Zeitnah reagieren kann, wenn doch mal was wichtiges kommen sollte :-)


    Würde kein Spam kommen, dann wären 10 Mails/Stunde vermutlich sehr viel mehr als oversized, aber der lässt sich leider erst in den Postfächern danach dann (zumindest ein wenig) filtern.


    Deswegen hat bisher die Weiterleitung ja gut funktioniert, meine Sorge wäre jetzt nur, dass Nachrichten halt verloren gehen wenn mal wieder ein Spam Peak die 10Nachrichten /Stunde schafft.

    Ich dachte eigentlich Plesk-seitig zählen interne Weiterleitung an mehrere Ziele nicht in das Limit rein

    info@ ist nur als Weiterleitung eingerichtet nicht als Postfach, also kann sonst nichts gesendet werden außer die Weiterleitung. Der Sendelog hat als Anzahl immer nur vielfaches von 10 angezeigt. Und dass fast 100 Mails pro Stunde empfangen werden habe ich noch nicht beobachtet. Da ich genau 10 Weiterleitungen habe, hatte ich daraus geschlossen, dass jede einzeln zählen muss. Dann würde das hinkommen.

    Da in einem anderen Beitrag die 100 Mails/Stunde erwähnt wurden, hätte ich auch eine Frage in die Richtung. Bin da auch letzte Woche drüber gestolpert.


    Für einen Verein habe ich hier ein Webhosting Paket. Dort habe ich mehrere Mailpostfächer und die info@ Mailadresse ist eine Weiterleitung an 10 Postfächer hier im gleichen Paket. Leider zählt das weiterleiten als Senden und jede Weiterleitung einzeln. D.h. bei 10Mails / Stunde an die info@ Adresse kommen keine Mails mehr durch. Da ja leider auch sehr viel Spam reinkommt kommen 10 Mails/h schonmal vor. (Über die Warnung davon im WCP bin ich da erst draufgekommen.) Ist natürlich doof wenn dann die 11. Mail kein Spam ist.

    (Btw. weiß jemand ob in diesem Fall die 11. Mail verworfen wird oder nur später zugestellt wird dann?)


    Das einzige was mir dazu einfällt wäre die info@ Mail zum Postfach machen und das Passwort zwischen den 10 Leuten zu teilen. Aber so richtig schön ist die Lösung auch nicht. Das Passwort muss dann häufiger geändert werden wenn sich der Personenkreis ändert, jeder muss 2 Postfächer abrufen und 10 Verschiedene Mailprogramme im gleichen Postpach müssen auch auch erstmal einig werden welcher Ordnername denn jetzt wie zu interpretieren ist :P


    Hat jemand eine Idee wie man das noch Organisieren könnte?


    Support hatte ich auch schon gefragt, die 100 Mail Grenze ist nicht veränderbar, das ist ja prinzipiell auch gut so, nur unpraktisch, dass das auch für interne Weiterleitungen innerhalb des gleichen Pakets gilt.


    Edit:

    Ein Thread für alles und jedes Problem reicht. Wie wäre es mit diesem hier?

    Ok ein Problem genau hier drunter zu posten ist jetzt natürlich sehr ungeschicktes Timing :), aber dachte die Frage "Wie organisier ich meine Mailpostfächer" gehört in dem Offtopic bereich ^^

    mainziman du könntest es ja trotzdem erstmal ohne CSR probieren um herauszufinden, ob es grundsätzlich Probleme gibt oder nur mit eigenem CSR.

    Falls du als DNS API die von netcup verwendest reicht dnssleep von 240 nicht aus (ich habe 560 gesetzt, bin aber noch nicht ganz sicher ob das in jedem Fall reicht)

    Auch könntest du den manual mode probieren: https://github.com/Neilpang/acme.sh/wiki/dns-manual-mode

    Das ist natürlich keine Dauerlösung, aber eignet sich auch super dazu herauszufinden ob es generell mit der Validierung Probleme gibt oder eventuell mit der DNS API.

    zu zeigen dass es nicht geht;

    da Du aber das Gegenteil meinst, dann bitte ich darum, das hier verwende ich ...


    https://github.com/Neilpang/acme.sh

    Funktioniert wunderbar damit, ich verwende acme.sh mit direktem Zugriff auf die netcup DNS API und bekomme ein Zertifikat, dass sowohl meinedomain.tld als auch *.meinedomain.tld abdeckt. Dass mehrere TXT Records unter dem gleichen Key erlaubt sind steht ja schon oben.


    Und Let's Encrypt schreibt ja auch selbst:

    Orders that contain both a base domain and its wildcard equivalent (e.g. *.example.com and example.com) are valid. In that case, there will be two authorization objects in the order for “example.com 229”, one of which represents the wildcard validation and one of which represents the base domain validation. Redundant entries will produce an error. For instance, and order containing both *.example.com and www.example.com would produce an error since the wildcard entry makes the latter redundant.



    Der Zitierte Beitrag ist direkt in den FAQ verlinkt: https://letsencrypt.org/docs/faq/

    Nun würden wir aber am liebsten den "Webhosting 2000 de" wählen, welcher bei der Soft-Migration aber nicht angeboten wird.

    Man kann auch einfach ein zweites Webhosting ganz unabhängig buchen und die Daten dann umziehen. Technisch sollte das exakt das gleiche wie die Softmigration sein, nur Abrwchnungstechnisch hat man eventuell nachteile, je nach Tarif kann sich das auf dauer aber eventuell trotzdem lohnen. Die nachteile wären:

    - Man hat einen Zeitraum in dem man beide Tarife zahlt.

    - Man muss beim alten Tarif die Vertragslaufzeit abwarten und zahlt ggf. solange doppelt.

    - Gebüren für Wechsel der Inklusivdomain (z.B. 5€ bei .de) (oder je nach aktezeptabler Downtime der Umweg über weg von netcup und dann zurück von netcup, das kann günstiger sein)


    Wenn die laufzeit des alten Vertrags nicht mehr allzu lang ist und es den neuen Tarif gerade als Aktion gibt kann sich das auch Preislich auf dauer lohnen.

    [netcup] Felix P. da es hier gerade um Bankverbindungen geht. Mit ist schon ein paar mal aufgefallen, dass in dem pdf Dokument der Rechnungen unten immer noch Kontonummer und BLZ bei Bankverbindung national stehen. Das ist für copy paste etwas unpraktisch. (Rechts daneben steht zwar die IBAN, aber unter Bankverbindung international, aber irgendwie check ich da doch jedesmal ob das auch die IBAN ist die zur nationalen Kontonummer gehört :-) )


    (Vorbehaltlich das ist noch aktuell, meine letzte Rechnung ist von Mai :-) )

    Du hast glaube ich den falschen error_log. Der gepostete log Eintrag ist ja auch schon von heute 0:10.


    Es sollte einen Ordner /logs/<subdomain.example.com>/ geben und dort drin sollten dann die richtige error_logs Datei sein. Die error_logs Datei direkt im /logs Ordner hat nicht die Fehler für die entsprechende Domain.

    Das hier sollte prinzipiell schon die richtige Stellschraube sein:

    'datadirectory' => ((php_sapi_name() != 'cli') ? '/var/www/vhosts/hosting***.***.netcup.net' : '').'/httpdocs/data',

    Bei dir ist eventuell das nxc an der falschen stelle. Auch via cli sollte der Pfad absolut sein.


    Dazu kommt dann aber, dass Nextcloud bei fast allen occ Befehlen die config Datei überschreibt. Man muss daher jedes mal neu die config Datei anpassen.

    Ich habe so grundsätzlich schon mehrere Nextcloud updates erfolgreich gemacht.


    Das mit dem explodierenden Logfile hatte ich beim letzten Update aber auch. Selbst nachdem ich alle Nextcloud Dateien in einen neuen Ordner außerhalb des Document root verschoben hatte und die max_execution_time mehrfach vorbei hätte sein sollen, ist das logfile weiterhin sehr schnell angewachsen. Ich konnte das ganze bei glaube ich ~ 20GB warens abbrechen indem ich im CCP php für diese Domain kurz ganz abgeschaltet hatte. Danach war dann wieder alles in Ordnung.