Backbone / Routing Q&A

  • was ist da bloß los?:/

    ist es logisch dass Hop 6 lt. dem hier sich in AT befindet?

    mainziman gerne Antworte ich dir:


    1. Frage: Das kann ich dir hier aus dem Stehgreif natürlich nicht beantworten. Kannst du uns bitte mal einen Trace für den Rückweg zukommen lassen? Gerne auch statt traceroute das Tool "mtr" verwenden, vielen Dank.


    2. Frage: Du schaust hier auf die sog. "Geolocation", eine Ortsangabe, die von Dritten (privaten Anbietern) berechnet wird. In diesem Fall ist dies nicht korrekt, der Hop befindet sich natürlich in Deutschland. Insofern hier bitte nicht auf die Geolocation verlassen. Und ganz speziell bei sog. "Link-Netzen", also Verbindungen zwischen Routern, auch nicht auf Einträge in RIR-Datenbank (bspw. RIPE), da hier ein Netz, bspw. ein /48, weltweit verwendet wird in einem Backbone.

  • Hallo,


    ich habe hier 2 Traces mit mtr gemacht, einmal vom Router zu Hause zum Server

    und einmal vom Server zum Router nach Hause;


    from Home to Server:

    screenFromHometoSrvr.png

    anzumerken sei hier, dass die Packet Loss bei 5 und 6 gegen 0 tendieren, und beim 2ten Start diese 0 sind;

    alleine von dem würde man meinen irgendjemand knippst da regelmäßig was aus;


    from Server to Home

    screenFromSrvrtoHome.png


    besten Dank;


    so ein weiteres Detail über dieses Verhalten; der vServer ist auch ausgehender Mailserver, und regelmäßig hängen bei mir zu Hause Mails in der Queue,

    weil keine IPv6-Verbindung zum SMTP-Server auf meinem vServer zu stande kommt;

    Grüße / Greetings

    Walter H.


    RS 1000 SAS G8 xRAM; RS 500 SSD G8; S 1000 G7; VPS 200 G8 Akt.; Webhost. 1000 m. 75%

  • Wie sieht das eigentlich mit der Anbindung nach Übersee aus? Bin gerade beruflich in Chicago und die Verbindung ist teilweise echt miserabel (nicht unbedingt vom Ping, aber vom Durchsatz). Ich schätze aber dass die Probleme hier eher bei AT&T zu verorten sind (gut für Netcup, blöd für mich weil ich da nichts machen kann). Speedtest.net in die Umgebung hier zeigt wie bestellt 100/20 MBit, in die Heimat (ein Server bei Frankfurt) kommt oft (abends) nicht über 2 MBit (während die Verbindung hier in der Nähe gut bleibt). Das reicht leider nicht für HD-Fernsehen und VPN fühlt sich auch eher nach letztem Jahrtausend an. Werde wohl meine Backupzeiten anpassen müssen ;)

    Hi Steini , wir übergeben deine Datenpakete "sauber" an TeliaCarrier (AS1299). Paketverlust 0%. Hier ist alles so, wie es sein soll. Ich empfehle dir zur Eingrenzung des Problems verschieden "iperf3"-Messungen zu unterschiedlichen Endpunkten in gleicher geografischer Lage zu machen.

  • Hier etwas von heute, ich muss beim Mailversand händisch nachhelfen ...X(

    hier der Ausschnitt vom postfix-log auf meinem lokalen System;

    Code
    1. Feb 25 12:22:18 mailout postfix/qmgr[3784]: 82726104: from=<MYEMAIL>, size=2072, nrcpt=1 (queue active)
    2. Feb 25 12:22:48 mailout postfix/smtp[4632]: connect to smtp00.ipv6help.de[2a03:4000:31:345:0:53:4d54:5030]:587: Connection timed out
    3. Feb 25 12:22:48 mailout postfix/smtp[4632]: 82726104: to=<RECIPIENT>, relay=none, delay=30, delays=0.01/0.03/30/0, dsn=4.4.1, status=deferred (connect to smtp00.ipv6help.de[2a03:4000:31:345:0:53:4d54:5030]:587: Connection timed out)
    4. --- hier hatte ich mittels { ping6 smtp00.ipv6help.de; postqueue -f } eingegriffen ---
    5. Feb 25 12:24:01 mailout postfix/qmgr[3784]: 82726104: from=<MYEMAIL>, size=2072, nrcpt=1 (queue active)
    6. Feb 25 12:24:09 mailout postfix/smtp[4632]: 82726104: to=<RECIPIENT>, relay=smtp00.ipv6help.de[2a03:4000:31:345:0:53:4d54:5030]:587, delay=111, delays=103/0.01/0.73/7.9, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 74F4264EC6)
    7. Feb 25 12:24:09 mailout postfix/qmgr[3784]: 82726104: removed

    Grüße / Greetings

    Walter H.


    RS 1000 SAS G8 xRAM; RS 500 SSD G8; S 1000 G7; VPS 200 G8 Akt.; Webhost. 1000 m. 75%

  • Hallo,


    hier mehrere ping6 - einmal zu einer IPv6 in Frankfurt, zum Test auf einer Site gefunden, klappt ohne Probleme

    und dann zu meinen vServern, jeweils beim 1ten mal erst eine Reaktion nach dem xten Paket ..., siehe mtr-Output weiter oben ...


    dieses Phänomen scheint auch von anderen Stellen, z.B. von hier: http://nl.traceroute6.net/

    zu existieren, ohne dass ich an der Netzkonfiguration/Firewall etwas geändert hätte ...

    läuft das schon seit mehreren Wochen ;(

    Grüße / Greetings

    Walter H.


    RS 1000 SAS G8 xRAM; RS 500 SSD G8; S 1000 G7; VPS 200 G8 Akt.; Webhost. 1000 m. 75%

  • Macht bitte etwas, dieser Zustand ist bereits anhaltend seit mehreren Wochen,

    und mittlerweile ist es wirklich unerträglich - siehe diverse Auswirkungen weiter oben;

    Danke


    ein ping6 smtp00.ipv6help.degeht ohne Probleme,

    dann ein postqueue -fum die ZWEI Mails, welche seit heute Morgen,

    davon EINES, welches seit Mitternacht in der Queue ist absenden zu könen;

    vergebens, dann ein weiteres ping6 smtp00.ipv6help.de

    hier das Ergebnis:

    screenPing6Mail.png


    ich hatte meine Mail-VM zu Hause zum xten mal neu gestartet;

    Grüße / Greetings

    Walter H.


    RS 1000 SAS G8 xRAM; RS 500 SSD G8; S 1000 G7; VPS 200 G8 Akt.; Webhost. 1000 m. 75%

  • jetzt kommt das seltsame an der Geschichte, es hat mit meinem IPv6-HE-Tunnel gar nichts zu tun,

    woran es liegt kann ich gar nicht sagen, aber hier, nach mehrmaligen gescheiterten Versuchen

    wie z.B. hier:

    screenSSLvalidate.png

    dann doch endlich wie es sein soll

    screenSSLvalidateOK.png

    was das alles und diese negativen Auswirkungen verursacht weiß der Geier;

    Grüße / Greetings

    Walter H.


    RS 1000 SAS G8 xRAM; RS 500 SSD G8; S 1000 G7; VPS 200 G8 Akt.; Webhost. 1000 m. 75%

  • Probably related: https://forum.netcup.de/admini…work-is-down-unreachable/


    traceroute6: Warning: one.one.one.one has multiple addresses; using 2606:4700:4700::1001

    traceroute6 to one.one.one.one (2606:4700:4700::1001) from 2a03:4000:36:4c6::1, 64 hops max, 20 byte packets

    1 2a03: 4000: 36 :: 2 0.562 ms 0.371 ms 0.576 ms

    2 2a00:11c0:47:3::32 0.757 ms 0.347 ms 0.369 ms

    3 * * *

    4 * * *

    5 * * *

    6 * * *

    7 * * *

    8 * * *

    9 * * *


  • [Anexia] Theo V.


    Bei mir gibt es noch Unterschiede im Routing sowohl von Unitymedia nach Netcup als auch andersherum. IPv4 läuft laut Hostnames via FFM nach NBG. IPv6 nimmt in beiden Richtungen einen Umweg via Wien. Dementsprechend höhere Latenzen bei IPv6.


  • dot0x danke, das ist bekannt und wir arbeiten zumindest für unsere Seite am Traffic Engineering. In einer bestimmten Kombination aus Netcup-Router und Backbone-Router bei uns, ist der Weg nach Wien zu unserer LibertyGlobal-Übergabe einen "Hauch" kürzer. Ich melde mich, wenn das erledigt ist.

  • Gerade einen interessanten Kommentar auf Reddit gefunden, für diejenigen, die sich für das Thema interessieren:


    https://www.reddit.com/r/netwo…fvo4ed/bgp_peers/fmkg3z4/

    Ja, so ist leider die Realität. Beispielsweise ein Kabel in New York umstecken lassen in einem Gebäude, das mehrere Rechenzentren beherbergt, aber einer Immobilienfirma gehört, das kann gerne mal einen Tag dauern. Gleiches aber auf der anderen Seite, viele "NOCs" antworten uns bspw. nie auf unsere Mails.

  • Ich bin Kunde der deutschen Glasfaser (ASN 60294). IPv4 läuft leider über CGNAT aber ohne Probleme. Der Ping via IPv4 liegt bei ca. 12-15ms.

    Anders verhält es sich bei IPv6. Dort habe ich ab einem bestimmten Hop eine höhere Latzenz. Hier zwei Auszuge:


    Deutsche Glasfaser -> netcup:

    Code
    1. mtr -r -w -c5 -n 2a03:4000:41:x:x:x:x:x
    2. HOST: XXXXXX Loss% Snt Last Avg Best Wrst StDev
    3. 1.|-- 2a00:6020:1cfc:6501::1 0.0% 5 0.3 0.3 0.2 0.3 0.0
    4. 2.|-- ??? 100.0 5 0.0 0.0 0.0 0.0 0.0
    5. 3.|-- ???              100.0 5 0.0 0.0 0.0 0.0 0.0
    6. 4.|-- 2001:7f8::a5e9:0:3 0.0% 5 8.3 9.2 8.3 10.7 1.0
    7. 5.|-- 2a00:11c0:47:1:47::140 0.0% 5 14.2 12.9 11.8 14.2 1.0
    8. 6.|-- 2a00:11c0:47:3::21 0.0% 5 14.3 13.4 11.9 14.3 1.1
    9. 7.|-- 2a03:4000:41:x:x:x:x:x               0.0% 5 25.4 24.2 23.3 25.4 1.0


    netcup -> Deutsche Glasfaser:


    Mache ich das gleiche mit einem Server der bei H3tzner steht, bekomme ich folgende Resultate:


    H3tzner -> netcup:

    Code
    1. mtr -r -w -c5 -n 2a03:4000:41:X:X:X:X:X
    2. HOST: XXXXXX Loss% Snt Last Avg Best Wrst StDev
    3. 1.|-- 2a01:4f8::a:16:b 0.0% 5 0.3 0.4 0.3 0.8 0.2
    4. 2.|-- 2a01:4f8:0:3::69 60.0% 5 0.5 0.5 0.5 0.6 0.1
    5. 3.|-- 2a01:4f8:0:3::3fd 0.0% 5 2.7 2.7 2.7 2.8 0.0
    6. 4.|-- 2a00:11c0:47:3::2a 0.0% 5 2.8 2.9 2.8 3.0 0.1
    7. 5.|-- 2a00:11c0:47:3::33 0.0% 5 2.8 2.8 2.7 2.9 0.0
    8. 6.|-- 2a03:4000:41:X:X:X:X:X                0.0% 5 2.9 2.9 2.8 3.0 0.0


    netcup -> H3tzner:

    Code
    1. mtr -r -w -c5 -n 2a01:4f8:X:X:X:X:X:X
    2. HOST: XXXXXX Loss% Snt Last Avg Best Wrst StDev
    3. 1.|-- 2a03:4000:41::2 0.0% 5 0.4 0.4 0.3 0.4 0.1
    4. 2.|-- 2a00:11c0:47:3::32 0.0% 5 0.6 0.5 0.5 0.6 0.0
    5. 3.|-- 2a00:11c0:47:3::2b 0.0% 5 0.4 0.5 0.4 0.5 0.0
    6. 4.|-- 2a01:4f8:0:3::3fe 0.0% 5 6.1 7.0 2.9 20.1 7.4
    7. 5.|-- 2a01:4f8:0:3::6a 0.0% 5 2.8 3.0 2.8 3.7 0.4
    8. 6.|-- 2a01:4f8:162:X::X     0.0% 5 2.9 2.9 2.9 2.9 0.0


    Es wäre klasse wenn überprüft wird, ob das so stimmt. Vielen Dank!

  • so ne komische Kiste ist bei mir auch - aber nur einem meiner vServer - im Weg und wirft Pakete kiloweise weg ...

    sprich vServer -> Home (HE-IPv6tunnel)

    Code
    1. [root@vhost01 ~]# mtr -r -w -c15 -n HE-IPv6tunnel
    2. HOST: vhost01.ipv6help.de Loss% Snt Last Avg Best Wrst StDev
    3. 1. 2a03:4000:31::2 0.0% 15 0.3 2.4 0.3 11.2 4.0
    4. 2. 2a00:11c0:47:3::32 0.0% 15 0.7 2.0 0.4 17.8 4.4
    5. 3. 2a00:11c0:47:1:47::212 0.0% 15 22.3 23.1 22.0 36.8 3.8
    6. 4. 2001:7f8:1::a500:6939:1 80.0% 15 23.2 22.8 22.5 23.2 0.4
    7. 5. 2001:470:0:2d4::2 0.0% 15 16.1 16.2 16.0 17.0 0.3
    8. 6. 2001:470:0:69::2 0.0% 15 21.8 21.6 19.9 24.1 1.0
    9. 7. HE-IPv6tunnel 0.0% 15 39.8 40.7 39.5 51.4 3.0

    was zum Henker veranstaltet der Hobel auf Hop 4?


    Code
    1. [root@vhost02 ~]# mtr -r -w -c15 -n HE-IPv6tunnel
    2. HOST: vhost02.ipv6help.de Loss% Snt Last Avg Best Wrst StDev
    3. 1. 2a03:4000:f::3 0.0% 15 0.3 3.5 0.3 41.6 10.6
    4. 2. 2a00:11c0:47:3::20 0.0% 15 0.5 0.6 0.4 1.1 0.2
    5. 3. 2a00:11c0:47:1:47::141 0.0% 15 3.5 4.2 3.5 8.8 1.4
    6. 4. 2001:7f8::1b1b:0:1 0.0% 15 4.4 4.0 3.8 4.9 0.3
    7. 5. 2001:470:0:69::2 0.0% 15 8.3 9.4 8.3 10.6 0.6
    8. 6. HE-IPv6tunnel 0.0% 15 29.9 30.7 29.3 36.4 1.9

    wieso nicht auch auf vHost01 so wie auf vHost02?

    Grüße / Greetings

    Walter H.


    RS 1000 SAS G8 xRAM; RS 500 SSD G8; S 1000 G7; VPS 200 G8 Akt.; Webhost. 1000 m. 75%