subdomains sind down

  • Erst mal ein Hallo in die Runde, ich bin neu in eurer Runde und habe bei netcup ein Webhostingpaket Sommer 2019.

    Erst mal nur als Test um hinterher eventuell auf einen Server oder größeres Paket umzusteigen.

    Ich habe vor zwei Tagen eine Domain per KK-Transfer ins Paket geholt. Hat auch gut geklappt. Ebenfalls habe ich vor zwei Tagen eine Subdomain angelegt. Hat auch geklappt. Sowohl Haupt- als auch Subdomain sind zu erreichen.

    Gestern habe ich eine weitere Subdomain angelegt. Sowohl meine Browser als auch https://downforeveryoneorjustme.com melden allerdings, die Seite sei down. Der Fehler liegt also auf der Serverseite, sprich bei netcup.

    Mache ich was falsch oder hat jemand von euch eine Idee?

    vg

  • DNS:
    Status: invalid, ist aber bei Subdomains so üblich. Die Hauptdomain


    Nserver: root-dns.netcup.net

    Nserver: second-dns.netcup.net

    Nserver: third-dns.netcup.net

    Status: connect

    Ansonsten finde ich keine Einstellungsmöglichkeiten in dem Hostingpaket.



    Browser: ohne Timeout, kommt direkt ERR_CONNECTION_REFUSED



    Aufgelöst wird ja nach website.de. und die Anfrage kommt ja auch beim Apache an. Er wird dann die Anfrage ablehnen, ich weiß nur nicht warum und hab im Hostingpaket keinen Einfluss darauf.



    Ich weiß mittlerweile doch warum:



    AH01909: mail.website.de:443:0 server certificate does NOT include an ID which matches the server name



  • Ich schließe mich der Frage von timkoop an. Das musst du uns mal bitte erläutern.


    Außerdem:

    AH01909: mail.website.de:443:0 server certificate does NOT include an ID which matches the server name

    Da fällt mir auf, dass du von mail.website.de sprichst. Diese Subdomain ist im DNS per default bereits hinterlegt - sofern Mailfunktion im Webhosting aktiv - und zeigt per A-Record auf einen der Netcup-Mailserver. Diese wiederum besitzen natürlich nur ein Zertifikat für ihren eigenen Hostnamen (z.b. mxabc12.netcup.net, siehe Maileinstellungen im WCP). Kann es sein, dass das schlicht ein Zertifikatsfehler ist? Welches Zertifikat wird denn ausgegeben?


    Es wäre zudem hilfreich, wenn du dein Problem etwas weniger allgemein schilderst und genau beschreibst was du mit welcher Subdomain genau vorhast. Auch wäre es hilfreich die besagte Domain zu benennen, damit wir dies einmal prüfen können. :)

  • Also http://mail.netgerman.de als Subdomain anlegen geht schon mal nicht. Wenn Netcup die Subdomain schon vorbelegt, sollte diese eigentlich auch laufen. Ist aber ein anderes Thema.

    Zertifikate sind bei der Domain noch nicht angelegt.

    Und was heißt "sofern Mailfunktion im Webhosting aktiv"? Sind die nicht immer aktiv?

    Bisher habe ich noch keine Subdomain angelegt und wenn ich http://hans.netgerman.de oder irgendeine andere nicht angelegte Subdomain aufrufe, kommt die Standart-Seite von netcup. Normal sollte da ein 404 von Apache kommen. Kann man das vielleicht irgendwo einstellen?

  • Was heißt "sollte diese auch laufen"? Was erwartest du als Reaktion auf welche Aktion deinerseits? Ein ping darauf zeigt jedenfalls die Adresse deines Mailservers. Das ist keine normale Subdomain sondern ein Alias des Mailservers. Dass der Mailserver irgendwelche HTTP-Requests nicht beantwortet ist für mich nachvollziehbar.


    Wenn du ein 404 willst, musst du im Dokumenten-Stammverzeichnis (aka document root) die dort automatisch angelegte index.html rausnehmen.

  • Die mail Subdomain geht vermutlich nicht, da sie auf den Mailserver von Netcup zeigt. Was die Weiterleitung von nicht angelegten Subdomains betrifft: Im Webhosting können soweit ich weiß Wildcard Subdomains angelegt werden. Diese „fangen“ alle nicht angelegten Subdomains auf.

  • Wenn du ein 404 willst, musst du im Dokumenten-Stammverzeichnis (aka document root) die dort automatisch angelegte index.html rausnehmen.

    so wie ich das verstehe geht es darum ein 404 anzuzeigen wenn die Subdomain nicht im Webhosting angelegt ist. Das geht soweit ich weiß nicht. Man könnte jedoch den * DNS Record entfernen, dann bekommt man zwar kein 404 aber man kann die Seite nicht aufrufen weil die nicht aufgelöst werden kann. Muss dann allerdings für jede Subdomain einen DNS Record anlegen


    Edit: Laut Webhostingbeschreibung geht es doch. Einfach * als Subdomain anlegen und dann solltest du die Index im doc root löschen können und bekommst da das gewünschte 404

  • Und was heißt "sofern Mailfunktion im Webhosting aktiv"? Sind die nicht immer aktiv?

    Kann man bei Bedarf abschalten, ja. Welche Auswirkungen das genau hat: keine Ahnung, hatte ich noch nicht das Bedürfnis.

    maildienst-deaktivieren.png


    Bisher habe ich noch keine Subdomain angelegt und wenn ich http://hans.netgerman.de oder irgendeine andere nicht angelegte Subdomain aufrufe, kommt die Standart-Seite von netcup. Normal sollte da ein 404 von Apache kommen. Kann man das vielleicht irgendwo einstellen?

    Wie von Doim1990 beschrieben, müsstest du hierfür den Umweg einer eigenen Wildcard-Subdomain gehen und dort einfach eine eigene 404-Seite hinterlegen.

    wildcard-subdomain.png


    Also http://mail.netgerman.de als Subdomain anlegen geht schon mal nicht. Wenn Netcup die Subdomain schon vorbelegt, sollte diese eigentlich auch laufen. Ist aber ein anderes Thema.

    Könntest auch, wenn du mail.domain.tld unbedingt verwenden möchtest, den entsprechenden A-Record der betroffenen Domain im CCP einfach entfernen. Hat dann ggf. negative Auswirkungen auf die Mailfunktion, siehe mx-Record.

    dns-mail.png

  • Tatsächlich kommt "nur" ein 403 vom Apache, wenn man die index.html rausnimmt, weil die Default-Einstellungen (zum Glück) so sind, dass kein directory listing ausgegeben wird. Insofern müsste man ür einen 404 tatsächlich irgendwelche Klimmzüge machen, was aber keiner wirklich braucht. Ich jedenfalls nicht. Eventuell käme auch ein 404, wenn das document root nicht existiert. Probiere ich aber jetzt nicht aus.


    Edit: Konnte ich mir jetzt doch nicht verkneifen das auszuprobieren, kommt tatsächlich ein 404 vom Apache ;). Was immer uns das auch bringen mag,,,

  • So, es geht auch anders als bei jeder Domain eine Wildcard-Subdomain anzulegen.Im doc-root (bei mir httpdocs) die index.html so ändern, das sie als Status ein 404 zurückgibt oder die index.html löschen und eine index.php anlegen:

    PHP
    1. <?php
    2. header('Status: 404', TRUE, 404);
    3. ?>


    shit, vergesst es, anderer Provider ;)

    Krieg ich aber auch noch hin, morgen!

  • dann bekommst du doch immer einen 404? Ich hatte das so verstanden, dass nur bei nicht existierenden Subdomains ein 404 zurückgegeben werden. Oder wolltest du die Domain gar nicht nutzen sondern nur eine Subdomain?

    Wie oben schon jemand sagte, man bekommt einen 403 wenn man kein Index-File im doc root hat.
    Ich will 8-10 Domains in das Paket packen. Ich habe für jede Domain ein eigenes Stammverzeichnis im doc-root. Und ich will nicht für jede Domain eine Wildcard-Subdomain anlegen müssen.

    Gibt noch ein paar Möglichkeiten. php.ini oder ein redirekt auf ein nicht existierendes Verzeichnis oder irgend sowas in der Art. Ich schau morgen mal.

  • Also über Linux


    Code
    1. wget willi.netgerman.de

    wird Status 404 korrekt zurückgegeben.


    Wird dann wohl bei Suchmaschinen auch klappen. Da drum geht es mir nämlich. Ich hab im Moment beim anderen Providern soviel Schrott auf den Domains, Zeit mal aufzuräumen ;)

  • Eventuell käme auch ein 404, wenn das document root nicht existiert. Probiere ich aber jetzt nicht aus ...


    Ich habs probiert, geht ;)

    Aber bringt nicht viel, denn dann geht einiges anderes nicht. Ist aber egal, ich bezahl jetzt bei einem anderen Hoster geringfügig mehr, hab aber die Leistungen, die ich mir vorstelle, mit ein paar Klicks zusammengestellt. Das ist das, wo ich hin will. Keinen V- oder Rootserver, brauche ich in meinem Alter nicht mehr. Mir reicht mein Raspi ;)

    Danke!