Webhosting 2000 SE mit Nextcloud?

  • Klinke mich hier mal ein.

    Bekomme auch noch die ...

    Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der Leistungsfähigkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen findest Du in der Dokumentation.... Meldung

    Laut der verlinkten Doku von NC soll man mindestens folgende Einstellungen treffen:

    Code
    1. opcache.enable=1
    2. opcache.interned_strings_buffer=8
    3. opcache.max_accelerated_files=10000
    4. opcache.memory_consumption=128
    5. opcache.save_comments=1
    6. opcache.revalidate_freq=1

    Folgende Einstellungen sind laut phpinfo() gesetzt:


    Code
    1. opcache.enable=1
    2. opcache.interned_strings_buffer=8
    3. opcache.max_accelerated_files=10000
    4. opcache.memory_consumption=128
    5. opcache.save_comments=1
    6. opcache.revalidate_freq=2

    Wie man sieht ist der Wert nur beim revalidate_freq anderst.

    Habe seit gestern das 4000 SE Webhosting Paket welches ja den OpCache mit drin hat. Muss ich noch was ein- bzw umstellen?

  • Heißt mit

    Code
    1. 'memcache.local' => 'none',

    in der config.php lässt sich die Meldung ausblenden/entfernen?


    // nein offensichtlich nicht. :D

    Schönheitsfehler ja, aber gibts ne Möglichkeit die Meldung zu killen?

  • Heißt mit

    Code
    1. 'memcache.local' => 'none',

    in der config.php lässt sich die Meldung ausblenden/entfernen?


    // nein offensichtlich nicht. :D

    Schönheitsfehler ja, aber gibts ne Möglichkeit die Meldung zu killen?

    Um die Meldung zu deaktivieren gibt es aktuell keinen Parameter den du setzten könntest.


    Man könnte es eventuell direkt im Quellcode abändern. Das ist aber Quark weil Nextcloud dann meckern könnte das es eine Datei Inkontinenz gibt und zudem Updates es wieder zurückgängig machen.


    Im großen und ganzen würde ich mich mit der Meldung abfinden. Zudem rufst du die Übersichtsansicht ja nicht jeden Tag auf.

  • Datei Inkontinenz

    Meintest du "Inkonsistenz"? ^^

    Und weiß zufällig jemand, wie ich Nextcloud bei dieser Meldung wieder glücklich mache?

    Code
    1. PHP scheint zur Abfrage von Systemumgebungsvariablen nicht richtig eingerichtet zu sein. Der Test mit getenv("PATH") liefert nur eine leere Antwort zurück. Bitte die Installationsdokumentation ↗ auf Hinweise zur PHP-Konfiguration durchlesen, sowie die PHP-Konfiguration Deines Servers überprüfen, insbesondere dann, wenn PHP-FPM eingesetzt wird.


    Paket: EiWoMiSau
    FPM application served by nginx

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Hallo zusammen, bin neu hier und blutiger Anfänger.


    Habe mittlerweile nextcloud installiert und folgende Meldungen bleiben offen:


    Es gibt einige Warnungen bei Deiner Systemkonfiguration.

    • Der "Strict-Transport-Security" HTTP-Header ist nicht auf mindestens "15552000" Sekunden eingestellt. Für mehr Sicherheit wird das Aktivieren von HSTS empfohlen, wie es in den Sicherheitshinweisenerläutert ist.
    • Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der Leistungsfähigkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen findest Du in der Dokumentation.

    Kann ich die so belassen und mit der nextcloud bedenkenlos arbeiten oder gibt es da noch Handlungsbedarf?


    Lg Thomas

  • Meintest du "Inkonsistenz"? ^^

    Rechtschreib-inkonsistenz 8|^^



    Und weiß zufällig jemand, wie ich Nextcloud bei dieser Meldung wieder glücklich mache?

    Code
    1. PHP scheint zur Abfrage von Systemumgebungsvariablen nicht richtig eingerichtet zu sein. Der Test mit getenv("PATH") liefert nur eine leere Antwort zurück. Bitte die Installationsdokumentation ↗ auf Hinweise zur PHP-Konfiguration durchlesen, sowie die PHP-Konfiguration Deines Servers überprüfen, insbesondere dann, wenn PHP-FPM eingesetzt wird.


    Paket: EiWoMiSau
    FPM application served by nginx

    Bei php-fpm sind die Umgebungsvariablen nicht standardmäßig aktiviert. Du könntest Mal php-cli probieren und dann entscheiden was besser für dich geeignet ist.

  • Ich hatte die Meldung auch immer wieder bei verschiedenen WH Paketen (1000 und 2000). Seit dem ich Nextcloud auf einem "Webhosting 2000 SE Plus" installiert habe, kommt die Meldung bei mir nicht mehr. Warum auch immer, die Settings nun passen ..


    VG


    edit: Wuhu, mein 100. Beitrag :P

    Gruß p4scal

    __________________

    Webhosting: WH 2000 SE Plus - WH Bestprice Classic

    Server: VPS 200 G8 Ostern 2019 - Rootserver Spring 2019 - VPS Karneval 2020

  • Du könntest Mal php-cli probieren und dann entscheiden was besser für dich geeignet ist.

    Bei "FastCGI application served by Apache" kommt diese Meldung tatsächlich nicht. Jedoch habe ich mich bewusst für "FPM application served by nginx" entschieden, da ich bei den anderen Möglichkeiten Abbrüche bei Downloads über eine langsame Internetverbindung festgestellt habe: https://forum.netcup.de/anwend…oad-bricht-ab/#post117403

    Sind Umgebungsvariablen denn überlebenswichtig für Nextcloud? Ansonsten könnte ich auch mit dieser Meldung leben.

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Die erste Warnung kannst du beheben, indem du in den Einstellungen für Apache und nginx für die entsprechende (Sub-)Domain oben bei den allgemeinen Apache-Einstellungen unter Zusätzliche Header "Eigenen Wert eingeben" auswählst und einträgst:

    Strict-Transport-Security: max-age=15552000;


    Die zweite Warnung kannst du eventuell durch Umstellung in den PHP-Einstellungen auf "FastCGI application served by Apache" loswerden, selbst getestet habe ich das aber nicht, steht halt hier irgendwo im Thread. Bei mir kommt die Warnung auch seit Anfang, die Cloud läuft aber. Es ist ja nur eine Warnung, es ist auch ein PHP-Memory Cache konfiguriert. Nur nicht mit so hohen Werten wie von Nextcloud empfohlen. Das ist wohl ein Bug in der Ausgabe der Warnung durch Nextcloud, jedenfalls fällt mir keine andere Bezeichnung dafür ein.

  • Die zweite Warnung kannst du eventuell durch Umstellung in den PHP-Einstellungen auf "FastCGI application served by Apache" loswerden, selbst getestet habe ich das aber nicht, steht halt hier irgendwo im Thread. Bei mir kommt die Warnung auch seit Anfang, die Cloud läuft aber. Es ist ja nur eine Warnung, es ist auch ein PHP-Memory Cache konfiguriert. Nur nicht mit so hohen Werten wie von Nextcloud empfohlen. Das ist wohl ein Bug in der Ausgabe der Warnung durch Nextcloud, jedenfalls fällt mir keine andere Bezeichnung dafür ein.

    Hat das schonmal jemand getestet?


    Habe derzeit einige Bilder (je Bild ca 10mb) hochgeladen, bei denen hat mein Nextcloud ganz schön zu kämpfen. Die Vorschaubilder dauern und während die Bilder laden, ist Nextcloud kaum nutzbar.


    VG

    Gruß p4scal

    __________________

    Webhosting: WH 2000 SE Plus - WH Bestprice Classic

    Server: VPS 200 G8 Ostern 2019 - Rootserver Spring 2019 - VPS Karneval 2020

  • Wirklich gut und flüssig auch mit so (relativ) großen Dateien wird das nur mit einem VPS oder Rootserver laufen. Und auch da nicht mit dem kleinsten VPS. Im Webhosting hast du ja noch nicht mal einen einzigen Core zur alleinigen Verfügung. Irgendwer muss die Daten ja über das Netzwerk auf die Festplatte schaufeln und nebenbei die Datenbank aktualisieren. Da ist mein lokaler Rechner im Zweifelsfall wohl besser als Nextcloud-Server geeignet. Der hätte 4x mehr RAM und mehr Prozessorleistung als mein Webhosting 8000. Leider hat er nicht die entsprechende Netzwerkanbindung. Außerdem wäre er auch wesentlich teurer.

  • Danke für deine Antwort!

    Mittlerweile werden mir die Vorschaubilder viel schneller angezeigt. Ich denke Nextcloud holt die mittlerweile aus dem Cache oder so.


    Weiss einer wie lange es dauert, dass die Vorschaubilder nicht jedes mal neu erstellt werden?!

    Gruß p4scal

    __________________

    Webhosting: WH 2000 SE Plus - WH Bestprice Classic

    Server: VPS 200 G8 Ostern 2019 - Rootserver Spring 2019 - VPS Karneval 2020

  • Die Vorschaubilder werden in der Regel "ondemand" generiert. Abhilfe könnte hier folgende Erweiterung schaffen: https://apps.nextcloud.com/apps/previewgenerator Damit lassen diese sich auch per Hand oder Cronjob automatisch erstellen.

    Danke für den Tipp. Ich habe es heute ausprobiert und es hat leider nicht gut funktioniert. Als erstes habe ich wie in der readme folgenden Befehl ausgeführt:

    occ preview:generate-all -vvv


    Beim ersten Versuch habe ich nach 496 und beim zweiten Versuch nach 621 Sekunden folgende Meldung erhalten:


    Code
    1. The current PHP memory limit is below the recommended value of 512MB.
    2. PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 12288 bytes) in /var/www/vhosts/XXXX/lib/private/legacy/image.php on line 976

    Wenn ich dann den regulären Cronjob Befehl occ preview:pre-generate ausführe erhalte ich die Meldung:

    Code
    1. The current PHP memory limit is below the recommended value of 512MB.


    Ausgeführt habe ich die Befehle über das WCP, Geplante Aufgaben, PHP Script ausführen.


    Hat jemand einen Tipp?! Eigentlich habe ich ja ein Memory Limit von 512 MB


    Danke!

    Gruß p4scal

    __________________

    Webhosting: WH 2000 SE Plus - WH Bestprice Classic

    Server: VPS 200 G8 Ostern 2019 - Rootserver Spring 2019 - VPS Karneval 2020

  • Egal ob übers WCP oder per ssh ich erhalte immer "The current PHP memory limit is below the recommended value of 512MB"

    Gruß p4scal

    __________________

    Webhosting: WH 2000 SE Plus - WH Bestprice Classic

    Server: VPS 200 G8 Ostern 2019 - Rootserver Spring 2019 - VPS Karneval 2020