MySQL Import

  • Hallo zusammen,


    ich hab letzte Nacht zwar den Support angeschrieben, aber ich denke, da wird heute wohl keiner da sein...


    Ich habe dieses Webhosting 4000 Paket und versuche seit gestern Abend die Datenbank einer phpBB installation zu importieren.

    Die dump-File hat ca. 85MB Größe. Zunächst hatte ich den Import (erfolgreich!) über das WCP gemacht. Dann aber festgestellt, dass scheinbar nicht mit UTF-8-Zeichensatz importiert wurde - die Umlaute wurden falsch dargestellt.

    Also hatte ich den Import über phpmyadmin versucht. Ist natürlich an der execution time gescheitert. Hat dann versucht die Datei in mehrere Parts aufzuteilen. Bin aber auch mit kleineren Dateien gescheitert. Jedesmal, wenn ein Versuch scheiterte, war phpmyadmin danach mehrere Minuten nicht erreichbar.


    Heute morgen habe ich nochmal versucht, den Import via WCP zu machen (besser schräge Umlaute und dann auf MySQL-Basis korrigieren, als gar nicht) - dieser Task hängt jetzt bei 5% und lässt sich auch nicht beenden.


    a) wie importiert man bei NetCup zuverlässig DB-Daten?

    b) kann ich die betroffene Datenbank einfach löschen, wenn da so ein Task hängt und dadurch den Task abbrechen?


    netcup : Die Datenbank-Verwaltung ist sehr squishy... das muss stabiler werden oder gebt uns die Möglichkeit die entsprechenden Tasks zu verwalten

  • Probier mal den Import via SSH-Konsole.

    Gute Idee!

    Hat auch erst so ausgesehen als würde es funktionieren, allerdings steht der Cursor jetzt nach einer ganzen Reihe von Queries und der Import scheint nicht abgeschlossen zu werden.

    Ich kann im WCP auch keine Änderungen mehr machen (DB löschen, DB anlegen, User-PW ändern)... da reagiert nix mehr. Ich nehme an DB-User-Passwort über die Shell ändern ist nicht drin.


    Das alles ist sehr unbefriedigend :cursing:

  • Hay,


    weil ich gerade ebenfalls Probleme mit phpMyAdmin hatte: In Version 4.8.4 (welche in Plesk integriert ist) gibt es gerade beim Import/Export Fehler, beispielsweise ein Stackoverflow-Beitrag hierzu. Mit viel Rumgedrehe konnte ich meine Datensätze aus einer Datenbank in die andere transferieren, aber dazu konnte ich auf meinem RS 8000 schön in die PHP Scripte selbst eingreifen (hätte auch meinen eigenen Ex-/Importer bauen können oder über mysqldump - dafür war ich aber für die zwei Tabellen einfach zu faul).


    Ich kann natürlich nicht sagen, ob das für dieses Phänomen verantwortlich ist, aber der zeitliche Zusammenhang war einfach für mich zu augenfällig. Und wenn, dann liegt es weder an netcup / WCP noch an Plesk (außer dass schnell ein Update erfolgen sollte), sondern einfach an phpMyAdmin.


    Früher jedenfalls hatte auch ich keine Probleme beim Import/Export.


    CU, Peter

  • Quote

    Dann aber festgestellt, dass scheinbar nicht mit UTF-8-Zeichensatz importiert wurde - die Umlaute wurden falsch dargestellt.



    Im Dump selbst sind die Zeichen aber richtig?


    Ich hatte mal den "Spaß" bei einem anderen Webhoster. Die hatten eine alte MySQL Installation (ohne utf8mb4, also ohne emoji und pipapoh) aber zu dem Zweck auch eine MariaDB. Leider stammte das 'mysqldump' Tool vom veralteten MySQL und das hat brav aus der MariaDB-utf8mb4 Datenbank einen Dump erzeugt und völlig fehlerlos alles in Ascii-?-Fragezeichen verwandelt. Der Dump war unbrauchbar und es war mein Glück, daß ich es beim Umzug bemerkt habe...


    Solang die Zeichen im Dump richtig sind, manchmal reicht es dann aus, das Charset im Dump selbst anzugeben ( wenn nicht eh schon der Fall )


    Wenn die DB selber gar nicht mehr reagiert wirst wohl bei Netcup nachhaken müssen


    Viel Erfolg

  • Naja, das Charset ist, wie gesagt, nicht mehr mein Hauptproblem.


    Ich konnte jetzt zumindest herausfinden, dass das Problem beim Import wohl darin besteht, dass eine Tabelle mit viel Inhalt nicht gelöscht (drop if exist) wird... tut an der Stelle einfach nicht mehr.


    Im Datenbankbereich vom WCP geht gar nix mehr - NetCup hat sich noch nicht gemeldet. Wird heute (und morgen) wohl nix mehr :cursing:


    Dann muss ich wohl einen eigentlich ausgesonderten vServer reaktivieren

  • Du kannst den Import beschleunigen, wenn du vorher folgende Parameter setzt bzw. in eine Datei schreibst:


    SET AUTOCOMMIT = 0; SET FOREIGN_KEY_CHECKS = 0; SET UNIQUE_CHECKS = 0;


    d, h. effektiv führst du an der Shell folgendes aus:


    Code
    1. cat import_pre dump.sql import_post | mysql --max_allowed_packet=256M -u....


    Frei nach https://forums.mysql.com/read.php?24,645437,645437


    PS: Das Problem hatte ich hier in Plesk auch. Aus einem 24h Task (Import über Plesk bzw. PHPMyAdmin) wegen der Komplexität wurden dann effektiv 10 bis 15min für die einzelnen Datenbanken.

  • Ah, gut zu wissen. Kann ich dann verwenden, wenn dann wieder was funktioniert.


    wenn du die tabelle nicht löschen kannst, vielleicht geht umbenennen noch?

    Nope.



    Auf meinem vServer lief der Import reibungslos. ABER... wenn ich den in die configfile von phpBB eintrage, kommt "No route to host".

    Lasst mich raten:

    Nix externen DB-Server mit dem Webhosting-Paket?

  • Hay,

    Nix externen DB-Server mit dem Webhosting-Paket?

    glaube ich nicht.


    "No route to host" ist idR ein Netzwerkproblem. Der Zielserver wird einfach nicht gefunden. Wenn der Datenbank-Server / vServer nach außen offen ist, kein Problem. Versuchst Du es eventuell über das zubuchbare vlan? Das geht nicht auf dem Webhost, das vlan steht nur den root-Servern zur Verfügung, Du musst über die öffentliche IP.


    Nachtrag: grad getestet, von meinem Webhosting 1000 komme ich auf meinen Datenbankserver (aber da ich den Host nicht erlaubt habe, kann ich mich nicht einloggen, bekomme aber 100% korrekte Fehlermeldungen zurück).


    CU, Peter

  • Nachtrag 2: Ich habe jetzt mal einen passenden User mit Freigabe für remote-Zugriff angelegt, erfolgreich das Webhosting mit MySQL auf meinem RS verbunden. Ich lösche den User jetzt mal wieder :D


    , der auch bei netcup ist?

    ja. Würde es auch mit einem anderen testen, aber ich habe keinen mehr außerhalb...


    CU, Peter

  • Du kannst den Import beschleunigen, wenn du vorher folgende Parameter setzt bzw. in eine Datei schreibst:


    SET AUTOCOMMIT = 0; SET FOREIGN_KEY_CHECKS = 0; SET UNIQUE_CHECKS = 0;

    Das hat übrigens aktuell auch nicht funktioniert. Ich nehme an, dass da ein Prozess hängt, der die DB komplett blockiert.