RAM-Management nach Kernelupdate

  • Hallo,
    also seit dem Update auf Kernel 2.6.36 meines 1000er vServers läuft irgendetwas krumm.
    1. hängt die SSH-Konsole laufend, wenn ich darauf zugreife und
    2. ist der RAM-Verbrauch komisch.

    Code
    1. Mem: 1048576k total, 1048576k used, 0k free, 0k buffers
    2. Swap: 1048576k total, 0k used, 1048576k free, 986796k cached


    Mein RAM pumpt sich total zu, auch der Swap dann irgendwann. Dann geht nichts mehr. Wenn ich den Apache dann neustarte, ist der Cache immer noch komplett voll (s.o.), aber der eigentliche RAM-Verbrauch soll bei nur 57MB liegen. dies kann angesichts der ganzen Apacheprozesse und anderen Anwendungen kaum sein. 300MB waren es vorher mindestens.


    Code
    1. total used free shared buffers cached
    2. Mem: 1024 1024 0 0 0 966
    3. -/+ buffers/cache: 57 966
    4. Swap: 1024 0 1024


    Geht es euch vllt. ähnlich?


    Edit: jetzt nach einigen Minuten später, sind sogar laut "free -m" sogar nur 38MB in Benutzung.

  • 2.6.36 fährt auf produktive netcup Server?

    Seit wann?

    Will ich auch haben.:)

    zu deiner free ausgabe.

    Sie sieht bei mir nicht anders aus.
    Wir sind hier bei unix linux schwapp...

    Adressierter Speicher wird freigegeben wenn er gebraucht wird.

    Sei froh das der Kernel brav Daten vorhält.
    Umso schneller kann hier eine verarbeitung stattfinden.

  • Der Server rannte in diesem Zustand aber nicht ordentlich.


    Hing nur und aktuell sagt er ja auch:

    Code
    1. total used free shared buffers cached
    2. Mem: 1024 446 577 0 0 47
    3. -/+ buffers/cache: 398 625
    4. Swap: 1024 0 1024


    So ist das ja auch ok, aber nicht "32MB used" wie vor dem Neustart.


    Da ist etwas krumm und ich denke, es wird wieder auftreten.

  • Janny82: Schreibe das einmal an den Support, das sieht wirklich seltsam aus und hat sehr viele Ähnlichkeiten mit den Problemen aus der Testphase, die theoretisch alle behoben sein sollten. Aber vielleicht treten sie nur auf bestimmten Nodes auf. Auf meinem Bronze läuft der neue Kernel bisher problemlos, auch am Testserver.



    MfG Christian

  • möglicherweise laufen auch auf anderen vServern Apaches und die Virtualisierung kann den Ramverbrauch teilen? Kenne diese Funktion von VmWare womit man teilweise bei identischen Setups von virtualisierten Servern einen sehr geringen realen Verbrauch hat.

  • nachdem Update des Kernels, ist mein vServer des öfteren leider nicht mehr/schwer zu erreichen,


    dabei ist während dessen der Load auf 0, die CPU belastung bei 0% verbraucht vom Ram werden lediglich ca. 1GB seit dem updated Cached der aber auch wie Blöde (3,5GB) - was er vorher auch nicht gemacht hat.



    Grüße

  • Nachtrag:


    Bei mir geht gar nichts mehr, selbst wenn ich alle Services bis auf SSH Stoppe, braucht der für nen simplen COnnect per SSH meherere Minuten - load liegt während dessen bei 0, cpu verbrauch 0% und ram ganze 20MB ausgelastet


    Ich hoffe Netcup kümmert sich darum, auf mein Ticket gabs leider noch keine Resonanz.



    Beim Stop via OpenVCP gibts folgende Meldung:


    All processes ended within 1 seconds....done.
    Stopping portmap daemon....
    mount: permission denied
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    RTNETLINK answers: Cannot assign requested address
    vdlimit: vc_get_dlimit(): No such process
    vdlimit: vc_rem_dlimit(): No such process



    Gesund sieht das nicht aus...

  • Das hatte ich gestern auch.
    Eben war mein Server ein paar Minuten nicht erreichbar, obwohl er "lief".
    Dienste antworten minutenlang nicht.
    Och man, was ist da los? Nur Ärger seit dem Kernelupdate.

  • Ja, aber es war ja schon vorher klar, dass es auf einigen Nodes noch Probleme gibt. Vielleicht ist unser davon betroffen?!


    Edit: erstaunlich, der Server scheint laut Konsole ganz friedlich zu sein. RAM laut Anzeige alles gut, aber Webseiten lassen sich nicht öffnen. Er ignoriert sämtliche Request einfach. Ping ist ok.
    Alle Prozesse stehen quasi und nur ein "init" bewegt sich im "top".
    Edit2: die Konsole hängt nun auch mal wieder. Session wurde gerade gewaltsam vom Server beendet.
    Diesmal hat wohl aber wer manuell eingegriffen, nehme ich mal an. Server ganz down.


    Ich möchte den alten Kernel zurück!

  • Ich dachte es läge an nem bestimmten Raid Controller, Netcup wäre doch dämlich wenn Sie dann anschliesend noch nen Update mit dem selben Kernel auf Hosts mit dem inkompatiblen Raid Controller durch führen?


    /edit


    Jetzt grade geht mal wieder absolut gar nichts.

  • Jupp, ist offline geschaltet.


    BTW: ich hatte schon VOR dem Update 1-2 Tage ähnliche Probleme. Also RAM-Überlauf, aber nicht so massiv.
    Vielleicht ist am RAM was defekt?!


    Danke für euren Einsatz!