SSL für Vorabdomain

  • Moin!

    Ich habe das heutige Adventskalender Webhosting 4000 Paket gebucht. Dafür habe ich bereits eine Adresse ala "hosting1034510.*****.netcup.net" bekommen. Ich habe bereits Domains auf einem anderen Netcup-Hosting laufen, die demnächst umziehen sollen.


    Ist es für Testzwecke (vor dem Umzug) möglich, ein SSL-Zertifikat für die netcup-domain zu bekommen?


    Im CCP wird diese Domain nicht angezeigt, weshalb ich dort auch kein kostenloses Lets-Encrypt Zertifikat beantragen kann.


    Schöne Grüße

    Julian

  • Das wird mit dem WCP vermutlich nicht möglich sein, da für die automatische Validierung der Domaininhaberschaft (das was bei Ausstellung eines SSL-Zertifikats passiert) die DNS-Einträge der Domain schon auf das neue Webhosting zeigen müssten (also die Domain schon umgezogen sein müsste...)


    Die technische Möglichkeit wäre (weiß aber nicht ob das im WCP geht) das SSL-Zertifikat (und private Key?) herunterzuladen und im neuen Webhosting hochzuladen...

  • Mir ging es nicht um meine alten Domains, sondern um die von Netcup automatisch zugewiesene hosting***.***.netcup.de-Domain. Mein Wunsch wäre es, ein SSL-Zertifikat für diese Domain ausgestellt zu bekommen, sodass man die Website über diese Domain mit SSL testen kann. Und dann erst nach erfolgreich verlaufenden Tests die alten Domains vom alten Server auf den neuen Server umleitet.

  • Hallo,

    funktioniert wie bei jeder anderen Domain übers WCP.

    Habs gerade für dich getestet: siehe Fehlermeldung.

    Let's Encrypt erlaubt leider nur 20 Zertifikate pro Woche pro Domain.

    Also am Anfang der Woche um 0 Uhr probieren.

    Code
    1. Fehler: Could not issue a Let's Encrypt SSL/TLS certificate for hosting100xxx.afxxx.netcup.net.
    2. The "Certificates per Registered Domain" rate limit has been exceeded for hosting100xxx.afxxx.netcup.net. Let's Encrypt allows no more than 20 certificates to be issued per registered domain, per week.
    3. See the related Knowledge Base article for details.
    4. DetailsInvalid response from https://acme-v01.api.letsencrypt.org/acme/new-cert.
    5. Details:
    6. Type: urn:acme:error:rateLimited
    7. Status: 429
    8. Detail: Error creating new cert :: too many certificates already issued for: netcup.net
  • Hallo,

    funktioniert wie bei jeder anderen Domain übers WCP.

    Habs gerade für dich getestet: siehe Fehlermeldung.

    Let's Encrypt erlaubt leider nur 20 Zertifikate pro Woche pro Domain.

    Also am Anfang der Woche um 0 Uhr probieren.

    In dem Zusammenhang eine Idee/Verbesserungsvorschlag für Netcup:

    Ab Januar könnte ihr einfach ein Wildcard-Zertifikat von LE holen. Dann kann das jeder Kunder einfach nutzen ohne das jedes mal eine neue Validierung für jede Subdomain stattfinden muss.

  • In dem Zusammenhang eine Idee/Verbesserungsvorschlag für Netcup:

    Ab Januar könnte ihr einfach ein Wildcard-Zertifikat von LE holen. Dann kann das jeder Kunder einfach nutzen ohne das jedes mal eine neue Validierung für jede Subdomain stattfinden muss.

    Dann müsste sich doch alle Kunden auf einer Domain dasselbe Zertifikat (und denselben private key) teilen. Das führt den Sinn von SSL etwas ad absurdum.

  • Naja wer ein Webhosting hat braucht den private Key eigentlich nicht. Derjenige will ja nur das es funktioniert (denke ich). Müsste natürlich so eingerichtet sein, dass die Kunden den Private Key nicht sehen können, da wie du schon richtig sagst, ansonsten ja theoretisch jeder alles dieser Domain entschlüsseln könnte und die Sinnhaftigkeit sehr anzuzweifeln wäre.

  • Hallo,


    habe folgende Situation.

    Ich habe mir eine Domain registriert.

    http://www.meine-domain.de (Beispiel Domain)

    Den Präfix www konnte ich nicht mit registrieren, sondern nur ohne, kein Problem, konnte man im CCP einstellen.

    Ich würde jetzt aber gern den Präfix in der Adresseleiste anzeigen lassen, funktioniert aber nicht, wird immer nur ohne angezeigt.


    Weiterhin habe ich das Problem, das ich SSL Zertifikat für diese Adresse erhalten nur ohne Präfix. Weiterhin möchte ich die gesamte Website als HTTPS nutzen, es wird aber nur die erste Seite verschlüsselt.


    Ich habe zunächst gedacht, es ist falsch installiert, bei meinem alternativen Holster wird aber sowohl Zertifikat als auch Präfix korrekt angezeigt.


    Hat jemand einen Tipp?


    Gruß

  • Soweit ich weiß kannst du den Präfix bevorzugen in den Hosting-Einstellungen innerhalb des WCP bei deiner Domain (Hosting-Einstellungen => Bevorzugte Domain).

    Ich verwende das SSL Zertifkat von Let's Encrypt. Im WCP kann man dort einstellen, dass immer HTTPS verwendet werden soll und ebenfalls einstellen, dass es den Präfix (www) beinhalten soll.