Teil des IPv6-Subnetzes für LXC Container verwenden

  • Das heißt ich müsste innerhalb von meinen Containern beispielsweise konstant Pings auf eine v6 Adresse absetzen, damit das advertisment permanent aktiv bleibt?

    Theoretisch ja, die Einträge in den Netcup Routern verlieren nach einer gewissen Zeit ihre Gültigkeit - Adressen die nicht genutzt werden tauchen in den Routing Tabellen nämlich nicht auf.


    Wenn du dir ein zusätzliches IPv6 Netz kaufst, ist das nicht so - diese Netze werden direkt geroutet.

  • Theoretisch ja, die Einträge in den Netcup Routern verlieren nach einer gewissen Zeit ihre Gültigkeit - Adressen die nicht genutzt werden tauchen in den Routing Tabellen nämlich nicht auf.


    Wenn du dir ein zusätzliches IPv6 Netz kaufst, ist das nicht so - diese Netze werden direkt geroutet.

    Das ist Richtig, ich Besitze ein zusätzlich IPv6 Netwerk
    pasted-from-clipboard.png


    Edit: Habe das Adventskalender 2019 günstig bekommen, kostet sonst 12 € pro Jahr :)

  • Verstehe. Besonders prickelnd ist das ja nicht unbedingt zumal es mir schwer fallen dürfte mit den bereits verfügbaren knapp achtzehneinhalb Trillionen Addressen etwas sinnvolles anzufangen. Was soll ich dann mit nochmal so vielen?


    Ich werde mal versuchen ob ein Ping alle zehn Sekunden o.ä. reicht um das aufrecht zu erhalten.

  • Ich werde mal versuchen ob ein Ping alle zehn Sekunden o.ä. reicht um das aufrecht zu erhalten.

    Ich denke im Bereich von Minuten dürfte das auch funktionieren.

    Du kannst auch den Support fragen, ob es hier Tipps gibt - bzw. eine Beschwerde einreichen, warum die Adressen nicht direkt anliegen, zusätzliche Adressen allerdings schon.

  • Ich denke im Bereich von Minuten dürfte das auch funktionieren.

    Du kannst auch den Support fragen, ob es hier Tipps gibt - bzw. eine Beschwerde einreichen, warum die Adressen nicht direkt anliegen, zusätzliche Adressen allerdings schon.

    Habe ich vergangenen Freitag angefragt. Leider noch keine Antwort. Aber mal abwarten.


    Schöne Grüße

  • Es scheint generell ein Problem mit neighbour discovery zu geben. Ein Fix ist wohl in Arbeit. Allerdings klang es nicht unbedingt danach als gäbe es einen Unterschied zwischen zugekauften und inkludierten v6 Netzen.


    Ich habe einem LXC Container sechs fortlaufende Adressen zugewiesen welche im Sekundentakt durchgepingt werden um die Verbindung zu halten. Zuverlässig funktioniert das jedoch nicht. Ich hab jeweils einen IRC Clienten auf eine IP gebunden in diese in einen Channel gepackt. So kann man schön das Kommen und Gehen beobachten.


    Schöne Grüße

  • Nein, leider nicht.


    Acht IPs, acht Verbindungen in einen IRC-Channel. So sieht das die meiste Zeit aus. Bin am überlegen ob ich die kommende Rechnung wegen mangelnder Verfügbarkeit kürze.

    Du kannst auch den Support fragen, ob es hier Tipps gibt - bzw. eine Beschwerde einreichen, warum die Adressen nicht direkt anliegen, zusätzliche Adressen allerdings schon.

    Trotz direkter Nachfrage weigert man sich mir hierauf eine brauchbare Antwort zu geben. Es wird stets ausgewichen und auf die generelle Problematik verwiesen.


    Schöne Grüße

  • Ob das mehr Lösung oder Workaround ist weiß ich nicht, so tief bin ich in v6 (leider) noch nicht drin. Jedenfalls hab ich jetzt ne funktionierende Config, gefunden in dieser Anleitung: https://youngryan.com/2019/02/…-lxd-containers-on-a-vps/. Der Punkt, den ich noch uncool finde: v4-ping-Latenz 8ms, v6-Latenz 17ms.

    Nach der Anleitung habe ich mich auch gerichtet, aber hänge jetzt bei der neighbour discovery Problematik.

  • Ob das mehr Lösung oder Workaround ist weiß ich nicht, so tief bin ich in v6 (leider) noch nicht drin. Jedenfalls hab ich jetzt ne funktionierende Config, gefunden in dieser Anleitung: https://youngryan.com/2019/02/…-lxd-containers-on-a-vps/. Der Punkt, den ich noch uncool finde: v4-ping-Latenz 8ms, v6-Latenz 17ms.

    Hallo,

    so wie ich es verstanden habe hast du kein zus. IPv6 Netz und keine Probleme nach dieser Anleitung?

    Ich wüsste nicht wo ich noch schrauben könnte, ich komme nicht weiter....


    Schöne Grüße

  • Okay, habe aufgegeben. Das inkludierte IPv6 Netz ist faktisch unbrauchbar.


    Habe ein zusätzliches Prefix besorgt. Erste Tests sind äußerst vielversprechend.

    Von bisher 15378 abgesetzten Ping (entspricht gut vier Stunden) ging kein einziger verloren. Bin noch skeptisch. Morgen wissen wir mehr.


    Im Vergleich zu vorher (zufällig ausgewählte Log-Datei) von 267099 Pings gingen 5509 verloren. Der Neuaufbau der Route kann gut und gern mit mindestens 15 Sekunden veranschlagt werden. Das Verhältnis von Ausfallzeit zu Verfügbarkeit zu berechnen schenke ich mir an dieser Stelle.


    Im großen und ganzen dennoch eine rechte Enttäuschung. Wenn man schon 18 Trillionen IP-Adressen zur Verfügung stellt muss man als Anbieter auch damit rechnen, dass auch nur der Bruchteil eines Promills davon auch tatsächlich verwendet werden könnte...

    Einziger Lichtblick ist, dass seitens Netcup anerkannt wird, dass es ein Problem gibt.


    Mein Dank geht raus an H6G und Track1991 für den gelieferten Input.


    Schöne Grüße

  • Öhm. Nichts für ungut, aber perryflynn hat hier in meinen Augen (halt unter Proxmox) doch genau das gemacht, was du vor hast... vielleicht hilft es dir ja - falls nicht, habe ich nichts gesagt. :saint:

    RS Rentier 2019 | CX11-CEPH | CX21 | CPX11


    Wer im Netz Anstand und Respekt verliert, der ist auch im realen Leben für nichts zu gebrauchen! ;)

  • Ich habe mich auch mit dem selben Problem unter Proxmox beschäftigt.


    Der Tipp mit den ndppd Daemon war sehr hilfreich.


    Allerdings funktioniert der Aufbau bei mir nicht mit kleiner Netzwerkmaske als /64 bei IPv6.


    Wenn ich das so mache kann ich den Container von außen wegen NDP erreichen, komme mit Container aber über die Bridge nicht herraus ins Internet per IPv6.

    Die Firewall hatte ich zum Test auch schon aus und die Traceroute zeigt auch die IPv6 der Bridge an, danach geht es beim Gateway von Netcup nicht mehr weiter.

    Denke das wird abgeblockt, weil die MAC Adresse nicht stimmt oder ich muss noch eine feste Route einstellen.