[NPM / NODEJS] Installation auf Debian Wheezy

  • Moin zusammen.


    Ich hoffe, jemand von euch kann mir helfen.


    Vor einigen Monaten habe ich zuletzt an meinem Projekt mit NPM und NodeJS auf dem Server gearbeitet.


    Heute wollte ich mal wieder etwas dran machen, aber "grunt build" ließ sich nicht ausführen.

    Also wollte ich nach längeren Versuchen dann npm und node updaten, da die Versionen wirklich schon sehr alt waren (0.10.x).

    Dann hatte ich leider einen Fehler beim Update und ich löschte den npm Ordner unter /usr/local/lib/node_modules.


    Nun hab ich das Problem, dass ich npm nicht mehr installiert bekomme...


    Node ist mittlerweile auf Version 4.2, jedoch habe ich gerade gelesen, dass sich damit npm wohl nicht (mehr verträgt).


    Jetzt bin ich ganz ratlos und weiß einfach nicht mehr weiter :(


    Ich nutze den Root-Server L SSD v6.


    Vielleicht weiß jemand von euch weiter und kann mir helfen??


    Habe nun auch etwas Angst, dass ich mir noch mehr kaputt machen könnte, denn es läuft auf dem Server auch eine sehr aktive Seite - wenn die plötzlich nicht mehr geht wäre das sehr ärgerlich :/


    Liebe Grüße,

    Shirisu

  • node ist zurzeit schon bei Version 6 bzw. 8 und npm läuft noch immer ohne Probleme damit. Node solltest du über npm updaten können, ich weiß aber nicht, wie gut dies mit so einer alten Version läuft. Oder meinst du mit 4.2 die NPM Version?

  • node ist zurzeit schon bei Version 6 bzw. 8 und npm läuft noch immer ohne Probleme damit. Node solltest du über npm updaten können, ich weiß aber nicht, wie gut dies mit so einer alten Version läuft. Oder meinst du mit 4.2 die NPM Version?

    Ich habe gelesen, dass auf Wheezy (Debian 7) maximal Node 4.x läuft, darum diese Version (alles andere hat auch nicht funktioniert..) und ich kann den Befehl "npm" an sich nicht ausführen, weil es nicht gefunden wird, da es erst wieder installiert werden muss.


    Und das ist mein Problem aktuell, es lässt sich einfach nicht mehr installieren... :(

  • warum aktualisiert du nicht die Debian-Version ?

    Ich kenne mich dann leider doch nicht so gut damit aus, dass ich mir das mit mehreren laufenden Projekten auf dem Server zutraue.

    Vor allem wenn ich nicht so viel Zeit am Stück habe, um dann alles durchzuchecken.


    Vorher lief halt auch alles ohne Probleme.


    Sollte ich aber keine Lösung für das Problem finden, werde ich das ganze wohl einfach anders angehen.

  • Upgrade ist doch risikolos zu machen:

    Server herunterfahren -> Snapshot anlegen -> Server hochfahren -> dist-upgrade

    Sollte was schief gelaufen sein -> Snapshot zurück spielen


    Genau dafür gibt es die Snapshots ja.

    Ein Upgrade von Wheezy auf Jessie ist aber in der Regel ziemlich schmerzlos möglich.

  • Ah, ist das doch so einfach? :/


    Ok, dann nehm ich das vielleicht jetzt am langen Wochenende mal in Angriff.


    Vielen Dank für die ganzen Antworten! :)