Debian Jessie unter Froxlor FCGID oder PHP-FPM aktivieren, danach Restart Apache nicht möglich

  • Folgendes Image habe ich auf meinem VServer installiert:
    Debian Jessie



    ( cozy cloud, Froxlor, Minimal, Nextcloud, ownCloud, Plesk, PowerDNS Master, PowerDNS Slave, ... )


    Zusätzlich noch phpmyadmin dazu und gut war erstmal.


    Nach einigem basteln und üben (bin noch ein Anfänger unter Linux), habe ich bemerkt das sobald ich in "Froxlor -> Einstellungen -> FCGID oder PHP-FPM" aktivieren und einen Kunden anlege, nach dem cron, apache2 nicht mehr startet.Ein bekannter hat mit mir zusammen gegooglet und einiges versucht, aber er konnte den Fehler auch nicht finden, dazu scheint irgendetwas mit den Rechten des ftp-Users nicht zu passen. Eine installation wie z.B. joomla, hat nicht das Recht am Ende der Installationsroutine, eine configuration.php zu erstellen oder das Installationsverzeichnis zu loschen.Das ganze würde auch erklären, warum ich solche Probleme beim Umzug meiner Seite habe, und egal wie oft ich schon die configuration.php geprüft und angepasst habe, scheitert wohl die Verbindung zur Datenbank.


    Das schlimmste ist, in den Apache-Logs steht ab dem Zeitpunk an dem Apache kapituliert nichts mehr drin!


    Meine Frage ist, wie löse ich diese Probleme, bzw. was stimmt mit dem Image...
    Debian Jessie



    ( cozy cloud, Froxlor, Minimal, Nextcloud, ownCloud, Plesk, PowerDNS Master, PowerDNS Slave, ... )
    ...nicht!?

  • äähm
    auf welches der 8 genannten images beziehst du dich denn nun?


    jay

    Ich möchte nur Froxlor dazu haben, und erstmal ne Webseite zum laufen
    bekommen und genau da beginnen die Probleme (PHP-FPM und FCGID nach
    aktivieren kein Apache mehr Startbar).
    Auch die FTP-Rechte scheinen nicht zu passen.



    Unter dem Punkt "Konfiguration" in Froxlor komme ich nicht weiter, entweder ist da was veraltet oder ich kapiers nicht.


    Bei
    den Konfigurationen gibts jeweils ne Eingabemaske für Text und darunter
    eine für das "SQL-Passwort", wie genau muss ich vorgehen? Unter SSH
    scheinen die Zeilen auch nicht alle zu funktionieren (Beispiel
    Konfiguration PHP-FPM) schon 100 mal versucht, aber anscheinend
    scheitere ich immer.


    Hab mal paar Screenshots angehängt


  • Das schlimmste ist, in den Apache-Logs steht ab dem Zeitpunk an dem Apache kapituliert nichts mehr drin!

    Hatte ich doch in meinem ersten Beitrag geschrieben.


    Ich überlege die komplette Distribution neu aufzusetzen und Froxlor etc. nachträglich einzurichten.
    Ich hatte mich bewusst für diesen VServer entschieden um ertmal mit etwas Hilfe in die Thematik einsteigen zu können, dass schon jetzt solche Probleme losgehen hätte ich nicht erwartet, immerhin handelt es sich um ein vorbereitetes Image das mehr oder weniger unberührt ist. Ausser Phpmyadmin wurde nichts zusätzliches von mir eingespielt.

  • Das Image Funktioniert eigentlich auch ohne Probleme. Jedoch kannst du nicht einfach die Art wie PHP ausgeführt wird mit einem Klick ändern. Bei Froxlor gibst du nur an, wie bei dir PHP ausgeführt wird. Sprich wenn du PHP mit FPM nutzen möchtest, dann musst du das erst entsprechen Installieren und Konfigurieren.


    Im Internet gibt es auch einige Anleitungen die sich dabei auf Froxlor beziehen.


    z.B.: How to set up PHP-FPM together with Apache2 and Froxlor? « Mind of Matt

  • root@v220170550549227:~# apt-get install libapache2-mod-fastcgi php5-fpm
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libapache2-mod-fastcgi is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source


    Muss ich wohl die Source-Listen anpassen!?
    Habe schon einige anleitungen vergebens getestet.

  • apt update ausgeführt? non-free Bereich aktiviert? Dort gibt es das Paket zumindestens…



    MfG Christian

    apt update ausgeführt?
    Ja


    non-free Bereich aktiviert?
    Was meinst Du damit? Wie gesagt, ich lerne gerade!



    "main" habe ich durch "non-free" ersetzt wie es die Konfiguration in froxlor sagt!


    # add "non-free" after all occurrences of "main" in /etc/apt/sources.list
    # this is needed for libapache2-mod-fastcgi to install




    Meine "Surce-Liste"
    #


    # deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official amd64 NETINST Binary-1 20160604-15:31]/ jessie non-free


    #deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official amd64 NETINST Binary-1 20160604-15:31]/ jessie non-free


    deb Index of /debian jessie non-free
    deb-src Index of /debian jessie non-free


    deb http://security.debian.org/ jessie/updates non-free
    deb-src http://security.debian.org/ jessie/updates non-free


    # jessie-updates, previously known as 'volatile'
    deb Index of /debian jessie-updates non-free
    deb-src Index of /debian jessie-updates non-free



    EDIT: Der erste Fehler ist entdeckt, nach dem "main" noch ein "non-free", nicht ersetzen!


    #


    # deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official amd64 NETINST Binary-1 20160604-15:31]/ jessie main non-free


    #deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official amd64 NETINST Binary-1 20160604-15:31]/ jessie main non-free


    deb Index of /debian jessie main non-free
    deb-src Index of /debian jessie main non-free


    deb http://security.debian.org/ jessie/updates main non-free
    deb-src http://security.debian.org/ jessie/updates main non-free


    # jessie-updates, previously known as 'volatile'
    deb Index of /debian jessie-updates main non-free
    deb-src Index of /debian jessie-updates main non-free

  • Prima, mit der anpassung der "Surce-Liste" konnte ich nach Konfigurationsanleitung aus Froxlor tatsächlich alle Pakete installieren und zu meiner freude ist das apache2 Restart-Problem nach aktivieren von "PHP-FPM" endlich behoben.


    MAN(N) MUß NUR RICHTIG LESEN :whistling: :whistling: :whistling:

  • So, mit viel lesen und basteln habe ich nun fast meine Webseite am laufen, einziges Problem sind anscheinend nocht die Rechte, nachdem ich in Froxlor einen Kunden anlegt habe.
    Nach anlegen des Kunden hat das Verzeichnis
    "

    /var/customers/webs/kunde/" 750
    während z.B.

    /var/customers/webs/
    und

    /var/customers/ 755
    haben.
    Wenn ich in Filezilla die Rechte von


    /var/customers/webs/kunde/
    auf 755 anpasse, und in der joomla configuration.php den cache deaktiviere (public $caching = '0'; | public $cache_handler = 'file';), komme ich ins joomla Backend, und die Systeminformationen sagen mir, dass alle Verzeichnisse schreibgeschütz sind.


    Wie kann ich nun dem entsprechenden User die richtigen Berechtigungen geben?
    Und vorallem, was muss ich tun, damit zukünftig froxlor beim Kunden anlegen die Rechte richtig vergibt?

  • So, geschafft, die ersten beiden Seiten laufen und sind umgezogen.
    Die Rechte werden nun nach anlegen eines Kunden richtig gesetzt.
    Wie ich das alles geschaft habe weiss ich nun auch nicht mehr genau, auf jeden fall sollte man die Codeschnipsel aus Froxlor sehr genau abarbeiten, teils musste ich von Hand noch etwas anpassen.


    Danke erstmal für die Anteinahme!