Posts by macca

    So, nach einigen Mails ist das ganze nun geregelt, war wohl ein Bug und der Fix wurde ausgerollt. Was zu beachten ist, erst muß der alte Snapshot vom ftp gelöscht werden bevor eine neuer exportiert werden kann (war eine Antwort vom Support), leider kann man den Snapshot nicht selber löschen (auch das macht der Support).

    Hallo liebes Forum, ich habe gerade im CCP 10 weiter Backups für meinen Vserver gebucht, wenn ich nun einen Snapshot exportieren möchte funktioniert das nicht mehr.

    Gestern konnte ich mein letztes Backup noch nutzen und einen Snapshot exportieren.

    Folgende Mail bekomme ich...


    "Guten Tag xxx,


    der von Ihnen beauftrage Export des Snapshots "Upgrade" auf Server "vxxx" konnte leider nicht erstellt werden.

    Mit freundlichen Grüßen / best regards


    netcup Team"


    Nicht gerade viel.

    In der Log im SCP steht gerade mal "???log.SnapshotExport.do???"


    Eine Mail an den Support ist raus.

    Mit dem "noch nicht" kann ich locker leben, aber am Telefon sagte man "dann wird das wohl NICHT mehr dazu kommen, das ist die Regel".

    Hallo, weil mein altes Webhosting Expert xxx nicht mehr auf MySQL 5.7.x aktualisiert wurde, habe ich mich nach einigen Mails und Telefonaten mit Netcup dazu entschlossen ein neues "Webhosting 2000 SE de a1" für einen Shopware Onlineshop zu buchen. Der Umzug war etwas nervig (wie das halt so ist) hat aber ganz gut funktioniert. Nachdem ich testweise von PHP 7.2.19 auf 7.3 umgestellt habe, meldet Shopware "Zend OPcache fehlt". Nachdem ich abermals mit Netcup telefoniert habe, wurde mir kurz und bündigt gesagt "wenn das Feature fehlt dann ist das halt so und wird wohl auch nicht ergänzt", im Klartext "Pech gehabt". Sicher werden jetzt einige schreiben, ich solle mir doch einen VServer oder Managed-Server etc. zulegen. Ein Webhosting ist für den kleinen Shop ausreichend und ich konnte auch Jahre damit arbeiten. Ich bin schon sehr lange Kunde bei netcup und habe viele Kunden dorthin gebracht, unter anderem nutze ich sogar einen VServer, aber in den letzen Jahren ist der Persönlich und gute Service etwas auf der Strecke geblieben und die Antworten am Telefon oder in den Mails werden immer oberflächlicher und pauschaler.

    Ich würde mich freuen wenn mir geholfen wird ohne das ich wieder den Shop umziehen muss, denn dann überlege ich erstmals mir eine Alternative zu suchen.


    ich hoffe, höfliche Kritik wird auch angenommen!?;)

    So, mit viel lesen und basteln habe ich nun fast meine Webseite am laufen, einziges Problem sind anscheinend nocht die Rechte, nachdem ich in Froxlor einen Kunden anlegt habe.
    Nach anlegen des Kunden hat das Verzeichnis
    "

    /var/customers/webs/kunde/" 750
    während z.B.

    /var/customers/webs/
    und

    /var/customers/ 755
    haben.
    Wenn ich in Filezilla die Rechte von


    /var/customers/webs/kunde/
    auf 755 anpasse, und in der joomla configuration.php den cache deaktiviere (public $caching = '0'; | public $cache_handler = 'file';), komme ich ins joomla Backend, und die Systeminformationen sagen mir, dass alle Verzeichnisse schreibgeschütz sind.


    Wie kann ich nun dem entsprechenden User die richtigen Berechtigungen geben?
    Und vorallem, was muss ich tun, damit zukünftig froxlor beim Kunden anlegen die Rechte richtig vergibt?

    Files

    Prima, mit der anpassung der "Surce-Liste" konnte ich nach Konfigurationsanleitung aus Froxlor tatsächlich alle Pakete installieren und zu meiner freude ist das apache2 Restart-Problem nach aktivieren von "PHP-FPM" endlich behoben.


    MAN(N) MUß NUR RICHTIG LESEN :whistling: :whistling: :whistling:

    apt update ausgeführt? non-free Bereich aktiviert? Dort gibt es das Paket zumindestens…



    MfG Christian

    apt update ausgeführt?
    Ja


    non-free Bereich aktiviert?
    Was meinst Du damit? Wie gesagt, ich lerne gerade!



    "main" habe ich durch "non-free" ersetzt wie es die Konfiguration in froxlor sagt!


    # add "non-free" after all occurrences of "main" in /etc/apt/sources.list
    # this is needed for libapache2-mod-fastcgi to install




    Meine "Surce-Liste"
    #


    # deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official amd64 NETINST Binary-1 20160604-15:31]/ jessie non-free


    #deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official amd64 NETINST Binary-1 20160604-15:31]/ jessie non-free


    deb Index of /debian jessie non-free
    deb-src Index of /debian jessie non-free


    deb http://security.debian.org/ jessie/updates non-free
    deb-src http://security.debian.org/ jessie/updates non-free


    # jessie-updates, previously known as 'volatile'
    deb Index of /debian jessie-updates non-free
    deb-src Index of /debian jessie-updates non-free



    EDIT: Der erste Fehler ist entdeckt, nach dem "main" noch ein "non-free", nicht ersetzen!


    #


    # deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official amd64 NETINST Binary-1 20160604-15:31]/ jessie main non-free


    #deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official amd64 NETINST Binary-1 20160604-15:31]/ jessie main non-free


    deb Index of /debian jessie main non-free
    deb-src Index of /debian jessie main non-free


    deb http://security.debian.org/ jessie/updates main non-free
    deb-src http://security.debian.org/ jessie/updates main non-free


    # jessie-updates, previously known as 'volatile'
    deb Index of /debian jessie-updates main non-free
    deb-src Index of /debian jessie-updates main non-free

    root@v220170550549227:~# apt-get install libapache2-mod-fastcgi php5-fpm
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libapache2-mod-fastcgi is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source


    Muss ich wohl die Source-Listen anpassen!?
    Habe schon einige anleitungen vergebens getestet.


    Das schlimmste ist, in den Apache-Logs steht ab dem Zeitpunk an dem Apache kapituliert nichts mehr drin!

    Hatte ich doch in meinem ersten Beitrag geschrieben.


    Ich überlege die komplette Distribution neu aufzusetzen und Froxlor etc. nachträglich einzurichten.
    Ich hatte mich bewusst für diesen VServer entschieden um ertmal mit etwas Hilfe in die Thematik einsteigen zu können, dass schon jetzt solche Probleme losgehen hätte ich nicht erwartet, immerhin handelt es sich um ein vorbereitetes Image das mehr oder weniger unberührt ist. Ausser Phpmyadmin wurde nichts zusätzliches von mir eingespielt.

    äähm
    auf welches der 8 genannten images beziehst du dich denn nun?


    jay

    Ich möchte nur Froxlor dazu haben, und erstmal ne Webseite zum laufen
    bekommen und genau da beginnen die Probleme (PHP-FPM und FCGID nach
    aktivieren kein Apache mehr Startbar).
    Auch die FTP-Rechte scheinen nicht zu passen.



    Unter dem Punkt "Konfiguration" in Froxlor komme ich nicht weiter, entweder ist da was veraltet oder ich kapiers nicht.


    Bei
    den Konfigurationen gibts jeweils ne Eingabemaske für Text und darunter
    eine für das "SQL-Passwort", wie genau muss ich vorgehen? Unter SSH
    scheinen die Zeilen auch nicht alle zu funktionieren (Beispiel
    Konfiguration PHP-FPM) schon 100 mal versucht, aber anscheinend
    scheitere ich immer.


    Hab mal paar Screenshots angehängt

    Files

    • jessy_froxlor.jpg

      (44.45 kB, downloaded 16 times, last: )
    • conf1.jpg

      (54.07 kB, downloaded 14 times, last: )
    • conf2.jpg

      (190.98 kB, downloaded 24 times, last: )

    Folgendes Image habe ich auf meinem VServer installiert:
    Debian Jessie



    ( cozy cloud, Froxlor, Minimal, Nextcloud, ownCloud, Plesk, PowerDNS Master, PowerDNS Slave, ... )


    Zusätzlich noch phpmyadmin dazu und gut war erstmal.


    Nach einigem basteln und üben (bin noch ein Anfänger unter Linux), habe ich bemerkt das sobald ich in "Froxlor -> Einstellungen -> FCGID oder PHP-FPM" aktivieren und einen Kunden anlege, nach dem cron, apache2 nicht mehr startet.Ein bekannter hat mit mir zusammen gegooglet und einiges versucht, aber er konnte den Fehler auch nicht finden, dazu scheint irgendetwas mit den Rechten des ftp-Users nicht zu passen. Eine installation wie z.B. joomla, hat nicht das Recht am Ende der Installationsroutine, eine configuration.php zu erstellen oder das Installationsverzeichnis zu loschen.Das ganze würde auch erklären, warum ich solche Probleme beim Umzug meiner Seite habe, und egal wie oft ich schon die configuration.php geprüft und angepasst habe, scheitert wohl die Verbindung zur Datenbank.


    Das schlimmste ist, in den Apache-Logs steht ab dem Zeitpunk an dem Apache kapituliert nichts mehr drin!


    Meine Frage ist, wie löse ich diese Probleme, bzw. was stimmt mit dem Image...
    Debian Jessie



    ( cozy cloud, Froxlor, Minimal, Nextcloud, ownCloud, Plesk, PowerDNS Master, PowerDNS Slave, ... )
    ...nicht!?

    Die Kunden sind Bäcker und Konditoren, erkläre denen mal wie sie ein Backup incl. DB machen. In Confixx gab es den schönen "Backup" und "Wiederherstellen-Button" Ich habe den Kunden einfach darauf aufmerksam gemacht, dass er für seine Daten verantwortlich ist, jedoch war es für ihn eben viel leichter, in Confixx den Button zu Clicken und die Daten via Filezilla vom ftp zu laden.


    Ich weiss was Du meinst, wir werden die Daten regelmäßig sichern, dann muss ich den Kunden zukünftig erklären, das wir für Betrag X die Daten im Alter von X Tagen bereitstellen können.


    Würde mich freun wenn Froxlor sowas irgendwann wieder bieten kann!


    Danke Euch

    Hallo, ich suche mir schon die ganze Zeit die Finger wund nach einer Backupfunktion in Froxlor. Ich habe im Internet mehrere Hinweise gefunden, dass froxlor solch eine Funktion unterstützen sollte, doch nirgendwo finde ich weder diese Funktion, noch ein Hinweis wo sie denn zu finden sein soll!


    Hier wird schon über solch eine Funktion geschrieben:
    Funktionsweise Backup - German / Deutsch - Froxlor Forum


    froxlor/actions/admin/settings/215.backup.php
    fehlt gänzlich!


    EDIT: Habe mir mal die Installationsverz. der versionen 0.9.31.2 und 0.9.32-rc2 angesehen, ich habe die rc2 installiert, in der anderen version ist die 215.backup.php enthalten. Was kann ich nun tun?


    Auf der Demoseite von Froxlor in der RC-2 gibt es die Funktion auch nicht mehr. Warum baut man soetwas aus?
    Froxlor Server Management Panel



    Installierte Version:
    0.9.32-rc2

    Da hab ich ja was ausgelöst! :S .
    Das mit der SMS fände ich auch super, klar kann ich auch ne passende Mailadresse hinterlegen. Anscheinend war ich wohl nicht der einzige, der ne Mailadresse hinterlegte die nach Sperrung nicht erreichbar ist.
    Gibts denn Vorschläge von Netcup?