Sieve leitet Mails nicht in den Spam Ordner

  • Hallo zusammen,


    ich versuche derzeit Sieve, Spamassassin und Amavis zu installieren und einzurichten. Spamassassin und Amavis funktionieren soweit. Spammails werden erkannt markiert (X-Spam-Flag und ****SPAM**** in die Betreff) und oder ggf. gelöscht (noch bevor sie ins Postfach geleitet werden).


    Leider macht mir Sieve nun Schwierigkeiten, es leitet die Mails nicht in den Spam Ordner. Sie kommen wie jede normale Mail im Posteingang an. Leider finde ich in keinem Log ein Fehler oder dergleichen. Wird Sieve evtl. nicht geladen?:


    Code
    1. Feb 22 19:38:17 imap: Debug: Loading modules from directory: /usr/lib/dovecot/modules
    2. Feb 22 19:38:17 imap: Debug: Module loaded: /usr/lib/dovecot/modules/lib10_quota_plugin.so
    3. Feb 22 19:38:17 imap: Debug: Module loaded: /usr/lib/dovecot/modules/lib11_imap_quota_plugin.so


    Meine /etc/dovecot/conf.d/90-sieve.conf sieht mittlerweile so aus (Ich habe viel rumprobiert und überall steht was anderes):

    Code
    1. plugin {
    2. sieve_global_path = /var/lib/dovecot/sieve/default.sieve
    3. sieve_global_dir = /var/lib/dovecot/sieve/
    4. }


    Die default.sieve sieht entsprechend so aus. Hier ist mir nicht ganz klar, ob fileinto als Eigenschaft die Orderfunktion oder den Ordnernamen haben möchte (hab beides versucht), denke aber das es der Ordnername ist


    Code
    1. require "fileinto";
    2. if header :contains "X-Spam-Flag" "YES" {
    3. fileinto "Junk";
    4. }


    Sieve ist in der /etc/dovecot/conf.d/15-sieve.conf aktiviert:

    Code
    1. protocol lda {
    2. log_path = /var/log/sieve.log
    3. mail_plugins = $mail_plugins sieve
    4. }


    In der /etc/dovecot/dovecot.conf habe ich noch folgendes hinterlegt:

    Code
    1. mail_debug = yes
    2. protocols = imap pop3 sieve



    Allgemeine Daten:
    Debian Version: 7.9
    Postfix Version: 2.9.6
    Dovecot Version: 2.1.7


    Falls ich wichtige Informationen vergessen habe, lasst es mich wissen.


    Ich weiß nicht mehr was ich tun kann, bzw was ich übersehen habe. Sowohl Google als auch mein schönes Linux Buch können mir leider nicht mehr weiterhelfen.
    Ich würde mich freuen, wenn ihr mir helfen könnt.


    Liebe Grüße
    Christof

  • Wurde Sieve auch wirklich aktiviert?


    Code
    1. # grep -Hi sieve /etc/dovecot/conf.d/*.conf
    2. /etc/dovecot/conf.d/15-lda.conf: mail_plugins = $mail_plugins sieve
    3. /etc/dovecot/conf.d/20-lmtp.conf: mail_plugins = $mail_plugins sieve
    4. […]


    Das sieht in meinem mail.log dann so aus:


    Code
    1. dovecot: master: Dovecot v2.2.13 starting up for imap, lmtp, sieve, pop3, sieve (core dumps disabled)


    Debian 8, aber das war auch bei der Vorgängerversion genau gleich.



    MfG Christian

  • Hallo zusammen,


    erst einmal Danke für eure Hilfe.


    redhell , Mordor: Eure Scripte ändern nichts an der Sache.


    killerbees19 :
    Mein Log sieht nur so aus:

    Code
    1. server dovecot: master: Dovecot v2.1.7 starting up (core dumps disabled)


    Jedoch habe ich in der 15-lda.conf die Zeile drinne:

    Code
    1. mail_plugins = $mail_plugins sieve


    Eine lmtp.conf habe ich nicht.

  • Die 20-lmtp.conf Datei gab es aber auch schon in Debian 7, gerade nachgeschaut. Welche Art der Zustellung verwendest Du denn bei Dir? LDA oder LMTP? Je nachdem könnte das schon die Ursache sein…


    Und Du hast Recht, die Zeile im Log sieht bei der alten Version tatsächlich noch so aus:

    Code
    1. dovecot: master: Dovecot v2.1.7 starting up (core dumps disabled)


    Das Paket dovecot-sieve (und sofern gewünscht auch dovecot-managesieved) hast Du aber schon installiert?



    MfG Christian