Wie php CLI memory limit korrigieren? + fehlender php link in /bin

  • Hallo.


    Als Anfänger (mit Webhosting 2000) habe ich 2 Fragen zu php (CLI):


    - Das memory_limit von php im CLI ist aktuell auf 128MB begrenzt, während Webseiten 512MB nutzen können. Wenn ich php-Sachen über CLI starte, gibt es meist eine entsprechende Warnung.

    Wie kann ich auch im CLI/shell das php memory_limit dauerhaft auf 512MB setzen?


    - In einem anderen Webhosting-Paket hatte ich im Ordner /bin immer einen Link zur php-Datei der Version, die ich in Plesk eingestellt hatte:

    lrwxrwxrwx   1 root      php -> /usr/local/php72/bin/php


    Der fehlt jetzt in /bin. Behelfsweise habe ich in .bash_profile den Pfad gesetzt:

    export PATH="/usr/local/php72/bin:$PATH"


    Den Link kann aufgrund fehlender Berechtigungen nicht selbst setzen. Wie und wann wird der gesetzt? Änderungen an den php-Einstellungen im WCP haben da nichts geändert.


    Vielen Dank für die Hilfe.

  • Hay,


    Du könntest es ja über einen anderen Weg versuchen - einen alias.


    Beispiel:


    Code
    1. alias php="/usr/local/php72/bin/php -d memory_limit=512M"

    Damit hättest Du zum einen die Pfad-Geschichte umgangen und zum anderen den Parameter fürs Memory-Limit beim CLI-Aufruf übergeben.

    Ab damit in die .bash_profile und fertig.


    CU, Peter

  • Ein Alias wäre für direkte CLI Aufrufe sicher sehr gut. Könnte ich ja zusätzlich zum Pfad noch in die .bash_profile packen.


    Was ich leider im Anfangspost ganz vergessen hatte:

    Den Pfad habe ich in die .bash_profile genommen, weil er (falls ich mich nicht irre) auch Skripten und Programmen (z.B. occ bei Nextcloud) hilft, php zu finden (die nutzen den Alias ja nicht). Da kamen vorher einfach immer jede Menge command not founds für php-Aufrufe (weil der erwähnte Link in /bin fehlte).

    Nur kann ich dafür kein memory_limit setzen. Eine php.ini kann ich wohl leider auch nicht erstellen im Webhosting 2000. Das wäre natürlich die einfachste Lösung.

    Vielleicht muss ich doch mal den Support kontaktieren. Die haben ja die Rechte, um sowas zu korrigieren.

    Vielen Dank schon mal.

  • Hay,


    dritter Weg: Was hindert Dich an einem Shell-Script im Pfad, welches nur php heißt und einfach nur alle Paramenter plus den "-d memory_limit" ans Binary weitergibt?


    Sowas:


    Shell-Script
    1. #!/bin/bash
    2. /usr/local/php72/bin/php $* -d memory_limit=512M

    noch ein chmod 700 php und geht (bei mir im Weghosting 1000 SE)... obs mit den anderen Scripten zusammenarbeitet habe ich natürlich nicht ausprobiert.


    CU, Peter