Fehler bei Nextcloud-Installation im Webhosting

  • wenn ich nach Eingabe des Benutzernamens und Passwort die Anmeldung abschicke, stehe ich quasi direkt wieder an der Anmeldemaste. Lösche ich den hinteren Rest von:

    http://hosting133402.a2e2e.net…rl=/index.php/apps/files/

    und ersetze es durch http://hosting133402.a2e2e.netcup.net/index.php/apps/files/,

    lande ich wieder bei http://hosting133402.a2e2e.netcup.net/index.php/login


    gibt es eine Möglichkeit zu sehen, ob er bei der Installation überhaupt einen User angelegt hat?

  • Via OCC kannst dir die User Listen lassen:


    sudo -u www-data php occ user:list

    Ich habe jetzt fleißig nach OCC gegooglet und auch versucht mit Putty auf den Server zu kommen um den Befehl abzusetzen. Leider komme ich mit den mir vorhandenen Informationen, Passwörter und gemieteten Paketen nicht weiter.

  • Wirst wahrscheinlich den Befehl eh nicht absetzen können. Da du kein sudo in deinem chroot haben wirst. Und occ läuft nur mit dem User www-data und dein hostingxxxx User wird keine Rechte dafür haben.


    Bleibt dir also nur ein php Script womit du mit exec() den Befehl aufrufst. Dafür muss aber in den PHP Einstellungen bei disabled functions exec raus. Was vor ein paar Tagen nicht ging weil netcup das aus dem Backend genommen hat. Ob es wieder da ist kann ich aktuell nicht sagen.


    Ich kann nachher mal ein nextcloud schnell auf einem Webspace aufsetzen. Oder du schreibst mir mal ne PM und wir gucken ob wir deine zum laufen bekommen.

  • Moin zusammen,


    ich habe gestern einen Webhosting 8000 Vertrag abgeschlossen, der meinen 2000er beerben sollte.

    Dort lief ebenfalls eine Nextcloud-Instanz, die ich jetzt natürlich auf dem "großen Bruder" einrichten wollte.

    Klappt nicht. Selbes Problem.

    Interessanterweise klappt es jetzt auch auf dem alten Webspace nicht mehr (unter einer Subdomain, die ich wieder angelegt habe... cloud.hostingXYZ...).


    Für mich leider ein absolutes Ko-Kriterium. Die letzten Monate lief alles ohne Probleme. Jetzt wollte ich die Ressourcen aufstocken und kann meine Cloud nicht mehr nutzen. Schade. Überlege, den großen Vertrag wieder zu kündigen, wenn sich keine Lösung findet... Dann lieber VPN aufs heimische NAS.

  • Da du kein sudo in deinem chroot haben wirst. Und occ läuft nur mit dem User www-data und dein hostingxxxx User wird keine Rechte dafür haben.

    Wie kommst du denn darauf? Der www-data im Webhosting ist doch der hostingxxx-User.

    Sudo brauchst du außerdem nicht, da via SSH/chroot direkt als der hostingxxx-User ausgeführt wird. Das sudo -u www-data dient nur, damit occ die Dateien von der Nextcloud auch mit dem entsprechenden Besitzer (also in der Regel www-data) bearbeitet, damit PHP am Ende keine Probleme hat.


    Edit: Quelle:

    You must run it as your HTTP user to ensure that the correct permissions are maintained
    on your Nextcloud files and directories.

    Da steht nichts von www-data.

  • Zum Thema OCC im Webhosting gibt es einen etwas älteren Thread (2 Jahre), Damit hat man OCC wohl ganz normal zum laufen bekommen in der Kommandozeile. Probiert habe ich das aber auch nicht. Zur Zeit ist allerdings doch wohl einiges arg durcheinander im Plesk/WCP. Ich fürchte, da werden heute noch ein paar Tickets von mir zu den sicher schon reichlich vorhandenen dazukommen. Fehler können immer mal passieren, sollten dann aber halt zeitnah behoben werden.

  • Wie kommst du denn darauf? Der www-data im Webhosting ist doch der hostingxxx-User.

    Sudo brauchst du außerdem nicht, da via SSH/chroot direkt als der hostingxxx-User ausgeführt wird. Das sudo -u www-data dient nur, damit occ die Dateien von der Nextcloud auch mit dem entsprechenden Besitzer (also in der Regel www-data) bearbeitet, damit PHP am Ende keine Probleme hat.

    Ist richtig, hab es nur bei mir im Docker rennen und bin natürlich als eingeloggter User nicht der Besitzer der Dateien... und da kommt es bei mir ohne www-data eben immer zu Problemen. Wusste auch nicht aus dem Kopf ob der hostingXXXX dann passt.


    Quote


    versucht mal bitte bei den PHP-Einstellungen der entsprechenden (Sub-)Domain den Parameter session.save-path auf /var/lib/php5/sessions zu setzen. Bei mir läuft es damit wieder.


    War das nicht hier im Thread wo die Thematik schon durchgenommen wurde ? Ja der Session Path muss auf /var/lib/php5/sessions gestellt werden.

  • So habe es eben versucht:


    Code
    1. curl https://download.nextcloud.com/server/releases/nextcloud-17.0.1.zip --output nextcloud.zip
    2. unzip nextcloud.zip


    Aufrufen von x0c.de/nextcloud/


    Installation laut Vorgabe mit MYSQL durchgeführt. Und es geht:


    pasted-from-clipboard.png


    PHP Einstellungen WCP

  • Ist richtig, hab es nur bei mir im Docker rennen und bin natürlich als eingeloggter User nicht der Besitzer der Dateien... und da kommt es bei mir ohne www-data eben immer zu Problemen. Wusste auch nicht aus dem Kopf ob der hostingXXXX dann passt.



    War das nicht hier im Thread wo die Thematik schon durchgenommen wurde ? Ja der Session Path muss auf /var/lib/php5/sessions gestellt werden.

    Ging bei mir gestern abend nicht zu setzen. Wurde dann zwar im Plesk so angezeigt, aber die phpinfo() hat mir dann was anderes erzählt, Das muss ich jetzt gleich nochmal testen. Anyway, das wäre bestenfalls ein Workaround, aber keine Lösung. Kann ja nicht sein, dass man was einstellen kann (und das sogar Default ist) was dann hinterher nicht funktioniert.

  • Ging bei mir gestern abend nicht zu setzen. Wurde dann zwar im Plesk so angezeigt, aber die phpinfo() hat mir dann was anderes erzählt, Das muss ich jetzt gleich nochmal testen. Anyway, das wäre bestenfalls ein Workaround, aber keine Lösung. Kann ja nicht sein, dass man was einstellen kann (und das sogar Default ist) was dann hinterher nicht funktioniert.

    Das ist richtig, aber irgendwas arbeitet Netcup eh im Backend rum. Die Funktion für disabled_functions fehlt ja aktuell immer noch. :cursing::cursing:


    @ alle Nextcloud Webspace User:


    pasted-from-clipboard.png pasted-from-clipboard.png pasted-from-clipboard.png


    Auch die 18 Beta geht auf dem Webspace :D

  • Danke, das hat geholfen. Jetzt geht es wieder nen Schritt weiter.

    Kannst du mir auch erklären, was die Änderung macht?

  • Danke, das hat geholfen. Jetzt geht es wieder nen Schritt weiter.

    Kannst du mir auch erklären, was die Änderung macht?

    Es ändert nur den Ordner wo die Sessions drin gespeichert werden. Das Problem dürfte aktuell bei netcup liegen mit dem php/sessions. Bei einem anderen Thema wurde festgestellt, dass es mit php5/sessions eben funktioniert. Ist also ein Workaround aktuell.


    So, dann wirst du noch feststellen das OCC nicht funktioniert. Dafür die Datei config/config.php ändern bei der Zeile datadirectory:


    Code
    1. 'datadirectory' => ((php_sapi_name() != 'cli') ? '/var/www/vhosts/hostingxxxxx5.axxxxx.netcup.net' : '').'/httpdocs/nextcloud/data',

    Eben anpassen, dass es zu deinem Ordnerpfad passt. Ansonsten versucht der php-cli immer den ganzen Pfad /var/www/vhosts/.... mit auszuführen und kann das Data Directory nicht finden. Erkennbar an folgendem Fehler:



    Mit angepassten Data Directory kannst du dir nun auch die User anzeigen lassen - Und viel mehr machen mit OCC!! <- Wichtiges Tool bei Nextcloud...

    Code
    1. bash-4.3$ php occ user:list
    2. - admin: admin
  • Ahhhh, da kommen die ganzen Webspace Nextcloud Anwender... ich hoffe ihr sitzt nicht auf meinem Node und macht meine Seite langsam. Jetzt kann ich die Beiträge garnicht mehr bearbeiten und Fehler einbauen um den Webspace für "normal Webspace User" schnell zu halten. 


    Ne Spaß... Dann viel Spaß mit eurer Nextcloud.

  • Bingo. Vielen Dank.

    Ich habe über 10 Stunden versucht, das Thema in den Griff zu bekommen. Dann bin ich auf die Idee gekommen, hier im Forum mal zu schauen.

    Vielen Dank Thomas :-)

    Grüße, Carsten

  • Vielen Dank für all die konstruktiven Vorschläge!


    Jetzt habe ich noch einmal die ganz aktuelle Nextcloud Version 17.0.2 via "setup-nextcloud.php" in einer neuen Sub-Domain (mit MySQL-DB) installiert und es hat alles soweit auf Anhieb problemlos funktioniert.


    Habe dann die die hier beschriebenen Einstellungen überprüft:

    • session.save_path =/var/lib/php5/sessions -> war bereits standardmäßig gesetzt...

    Ich gehe mal davon aus, dass netcup hier im Hintergrund tätig war (vielen Dank dafür!) und die notwendigen Voraussetzungen für eine problemlose Installation entsprechend eingerichtet / geändert hat.


    Version 17.0.2. generiert anscheinend noch nicht das letztlich notwendige DB-Format.

    Es muss folgender Befehl für das Ändern des DB-Schemas abgesetzt werden:

    Code
    1. php occ db:convert-filecache-bigint

    Damit "occ" bei mir via SSH-Shell funktioniert, habe ich nach der Anleitung von ArtCore7 die Datei config/config.php entsprechend geändert:

    • 'datadirectory' => ((php_sapi_name() != 'cli') ? '/var/www/vhosts/hostingxxxxx5.axxxxx.netcup.net' : '').'/httpdocs/nextcloud/data',

    Um noch die letzte Nextcloud-Warnung (OP-Cache-Warnung bleibt ja unvermeidlich bestehen) loszuwerden, fehlte nur noch bei [Einstellungen für Apache & nginx] der zusätzliche Header:

    • Strict-Transport-Security: max-age=15552000;includeSubDomains

    Für mich ist das anfängliche Problem damit aus der Welt. Nochmal vielen Dank in die Runde und allen ein gesegnetes Weihnachtsfest!


    Viele Grüße, Carsten

  • Hallo community,

    kaempfe auch mit meiner Nextcloud Installation, die zwar grundsaetzlich laeuft aber ich bekomme OCC nicht zum laufen trotz workaround von ArtCore7.

    ich habe Nextcloud in einer subdomain cloud.xxx.de direkt in deren root mit Dokumentenstamm /cloud.xx.de (kein extra Unterverzeichnis fuer Nextcloud)


    datadirectory in php.config war

    Code
    1. 'datadirectory' => '/var/www/vhosts/hostingxxx.xxxx.netcup.net/cloud.xxx.de/data',

    bekomme damit den Fehler

    "Could not open input file: occ"


    Habe jetzt geaendert in

    Code
    1. 'datadirectory' => ((php_sapi_name() != 'cli') ? '/var/www/vhosts/hostingxxx.xxx.netcup.net' : '').'/cloud.xxx.de/data',

    und bekomme denselben Fehler: "Could not open input file: occ"

    Was mache ich falsch?


    Weiterhin habe ich mein setup auf Basis von nginx, habe damit aber noch folgende Fehler auf der Uebersichtsseite:

    • PHP does not seem to be setup properly to query system environment variables. The test with getenv("PATH") only returns an empty response. Please check the installation documentation ↗ for PHP configuration notes and the PHP configuration of your server, especially when using php-fpm.
    • Accessing site insecurely via HTTP. You are strongly advised to set up your server to require HTTPS instead, as described in the security tips ↗.
    • Your web server is not properly set up to resolve "/.well-known/caldav". Further information can be found in the documentation.
    • Your web server is not properly set up to resolve "/.well-known/carddav". Further information can be found in the documentation.


    Hat jemand eine Idee wie ich die alle noch wegbekomme?

    Merci!