Key-Login Fehlerhaft

  • Hallo,


    ich habe ein Problem, wenn ich mich mit meinem Benuter root einloggen möchte, dann erhalte ich folgende Meldung:
    Server refused public-key signature despite accepting key!




    Mit meine anderen Benutzer komme ich ganz normal rein.


    Woran liegt das?


    Gruß Tobi

  • Scheinbar möchte sich dein System selbst schützen :P


    Aber gut Spass bei Seite wieso musst du dich mit root auch anmelden können. Ich mein du kannst dich als normaler Benutzer anmelden und mittels "su -" dann zu root werden, oder täusche ich mich ? Du solltest root login deaktivieren das wäre etwas besser.


    ThomasPr Wenn er hier fragt weil wir ein Forum sind muss man nicht immer gleich mit "Och gucke ma bei Google!" trotzen.

  • Das hat aber vor meiner neu Installation von meinem Laptop noch funktioniert.


    Glaub das "Server refused our key" ein anderer Fehler ist als "Server refused public-key signature despite accepting key!"


    Weil wenn ich Server refused our key habe, dann passt nur der Pfad zur meiner Datei nicht. Die findet er aber.


    Kann das sein das hier am Putty bzw. WinSCP eine Einstellung nicht passt?


    Habe hier weder WinSCP noch Putty Zugriff.




    Gruß & Danke

  • Da du mit root kommst (das tutst du doch immer noch, oder?) sollten die Ordnerrechte eigentlch kein Problem darstellen,
    da du als root ja überall reinschauen darfst...


    Kannst du vielleicht nochmal kurz dein Vorgehen beschreiben und wann du welchen Fehler bekommst?


    VG Andreas

  • Hi,


    wenn ich mich einlogge, fragt er nach dem Passwort vom Key Passphrase den gebe ich dann auch ein und danach erhalte ich sofort die Meldung Server refused public-key signature desspite accepting key.


    Passphrase for key "XXXXX":
    Server refused public-key signature despite accepting key!




    Gruß

  • Hi,


    der Fehlermeldung nach ist ein erfolgreicher KEY-Auth anzunehmen.
    Ich würde also erstmal nach anderen Quellen suchen, die den Login verbieten könnten:
    Account auf dem Server gesperrt ('!' statt Hash in der /etc/shadow), Root-Login per SSH verboten, ...
    Vobei ersteres bei der Verwendung von root eher unwahrscheinlich ist :)


    Vielleicht hast du auch in der sshd Konfiguration im Abschnitt des SCP-Servers einen Parameter gesetzt, der dir beim SSHd fehlt...
    Da könnte vielleicht die Konfiguration beim Fehlersuchen noch behilflich sein.



    Nach deiner Neuinstallation des Laptops hast du auf der Server-Seite nichts mehr geändert, oder?


    Grüße - Andreas

  • Hallo Tobi,


    du hast in der SSHd-Config den Root-Login geblockt.
    Du müsstest den Operator "PermitRootLogin" von "no" auf "yes" setzten, um dich anmelden zu können.


    Allerdings, wie oben schon erwähnt, sollte lieber ein anderer User für den Login verwendet werden, also bitte später, wenn alles über einen anderen Account geht wieder zurück setzen ;)


    Viele Grüße
    Andreas

  • Wahnsinn, warum hab ich das nicht gesehen :wacko:


    Einwandfrei vielen vielen Dank. Jetzt funktioniert es wieder. Danke


    Eigentlich hab ich mein Root Login immer gesperrt und verwende einen anderen Benutzernamen, aber wollte den Fehler beheben was mein Fehler war :(


    Top vielen Dank.


    Hab noch eine Frage wie kann ich das machen, das der weitere Username bsp. Tobi volle Rechte hat in den Verzeichniss /var/www inkl. Unterordner/Dateien?


    Gruß Tobi

  • Hi Tobi,


    freut mich, dass es jetzt klappt.


    Um tobi alle Rechte zu geben gibt es mehrere Möglichkeiten:
    Entweder du änderst die Dateien so, dass sie Tobi gehören. Das sollte allerdings der Webserver nicht wollen.
    Die andrere Möglichkeit ist, dass du Tobi zu der Gruppe hinzufügst, der die Dateien gehören (wahrscheinlich httpd oder apache, www etc.).


    Wenn dann die Gruppe die gewünschten Berechtigungen hat, solltest du mit tobi lesen, schreiben oder auch ausführen können, je nach dem wie du es brauchst.



    Viele Grüße
    Andreas

  • Eigentlich sollte www-data:www-data für alle Verzeichnisse in /var/www zuständig sein. Wenn du einen weiteren Nutzer ebenfalls die Rechte geben möchtest, solltest du den in die Gruppe www-data mit aufnehmen und die Rechte entsprechend verteilen. ACHTUNG: Nicht anwenden, wenn irgendein Managementtool läuft, wie z.B. plesk oder confixx, da es ggf. Probleme geben könnte.

  • Sieht so aus: