Teamspeak 3 Server SRV funktioniert nicht mehr

  • Hallo,


    Ich habe einen Rootserver und auf diesem meinen Teamspeak 3 Server installiert. Dann habe ich mir auch bei Netcup eine Domain transferiert. Nun wollte ich die Domain auf meinem Teamspeak 3 Server umleiten mit einer Wildcard für die Domain und Website, sowie ein @. (Alle Anwendungen, wie Website, Minecraft Server und Teamspeak laufen auf dem Selben RootServer). Dann habe ich es für Minecraft eingerichtet und alles hat funktioniert, doch dann als ich es für Teamspeak 3 einrichtete bekam ich die Fehlermeldung "Host [Domain.Net] konnte nicht aufgelöst werden". Ich habe gelesen, dass Teamspeak nun keine A Records mehr als target bei SRV untersützt und deswegen die IP als traget gesetzt. Habe jetzt sogar "tssub" und "ts3" als A Record hinzugefügt, da ich nicht mehr weiter weiß.


    Vielen Dank


    UdoC.

  • Also ich habe bei mir meine Domain genommen und da ich den TS unter der Subdomain ts3 (also ts3.meinedomain.tld) haben mag, habe ich das so eingerichtet.

    Der verpixelte Bereich ist der FQDN des des Hostes, auf dem der TS3 Server läuft.


    Bildschirmfoto von 2020-07-09 20-24-25.png


    Durch den FQDN hat man dann auch gleich IPv6 mit abgefackelt, das ist ganz praktisch.

  • Udo Coopmann Der Fehler ist, dass du deinen SRV-Record versuchst an eine IP zu binden, das geht nicht. Trage dort einfach deine gewünschte (Sub)Domain ein, unter die der TS-Server erreichbar ist.


    Warum man hier, wie von Isaac vorgeschlagen, den Dienst eines Drittanbieters (TSDNS) nutzen soll, erschließt sich mir nicht. Alles was nötig ist, bringt Netcup bereits mit. Und korrekt eingerichtet klappt das auch einwandfrei. :)

  • Hallo,


    erstmal vielen Dank für den ganzen Support. Ich habe nun einfach die IP gegen meine normal Domain "ScouterLP.Net" ersetzt oder muss ich noch ein .tdl an das Ende hängen?


    Vielen Dank


    UdoC.

  • Ähm. TLD steht für Top-Level-Domain - das ist Grundwissen wenn man Server betreibt.

    Das muss da natürlich nicht mit dran, sondern sollte einfach nur ein Platzhalter für .net in diesem Falle sein.


    EDIT: Dass du eine Datenschutzerklärung und ein Impressum brauchst und dass deine Encodings kaputt sind, weißt du? Ich wollts halt nur mal am Rande erwähnt haben. ;)


    EDIT2: Irgendjemand hat mir auch mal erzählt, dass es ne gute Idee ist, seine Website vernünftig abzusichern https://observatory.mozilla.org/analyze/scouterlp.net - just my 2 cents. Mit deinem TLS am Webserver könntest du dich auch nochmal auseinandersetzen https://tls.imirhil.fr/https/scouterlp.net

  • So ist es korrekt. Ergebnis:


    .net ist eine tld, hast also korrekterweise den vollständigen Domainnamen bereits eingesetzt. Funzt! :thumbup: