Ping geht nicht mehr (Temporary failure in name resolution)

  • Nach einem Neustart des Servers komm ich nicht mehr per SSH auf den Server.
    Auch "Ping google.de" oder sowas geht nicht mehr.


    apt update oder upgrade usw. geben alle einen Fehler. Vermutlich weil keiner mehr eine Verbindung herstellen kann.


    Habe bereits versucht in /etc/resolv.conf einen weiteren nameserver 8.8.8.8 hinzuzufügen, aber jedes mal wenn ich danach den Server neustarte, ist das wieder rausgelöscht

  • Es wäre hilfreich wenn du die Fehlermeldung posten würdest;)


    EDIT: Geht denn „Internet“ nach dem Ändern der Nameserver?

    Es geht echt gar nix...

    ping google.de
    -> ping: google.de: Temporary failure in name resolution

    apt update

    -> Failed to fetch http://...... usw.

    Ich komm also auch vom Server aus scheinbar nicht nach außen.

    ufw status ist inaktiv... also keine Firewall an


    /etc/resolv.conf sieht so aus

    nameserver 46.38.255.230

    nameserver 46.38.252.230

    nameserver irgendeine IPV6

    # Too Many DNS servers, the following entries my be ignored.

    nameserver wieder eine IPV6


    Hab wie gesagt bereits probiert dort 8.8.8.8 reinzubekommen, aber nach jedem Restart ist die resolv.conf wieder zurückgeändert

  • Welches OS nutzt du denn und wie sieht deine /etc/resolv.conf aus?


    EDIT: was ist die ausgabe von „ping 8.8.8.8“?

    resolv.conf hab ich einen Beitrag oben hinzugefügt gehabt bereits....

    Hatte auch grad mal die /etc/resolv.conf gelöscht und händisch nur nameserver 8.8.8.8 eingetragen, ist auch nach dem restart gespeichert geblieben weil der symlink ja weg ist durchs löschen. Hilft aber trotzdem nicht.


    ping 8.8.8.8 gibt Network is unreachable


    Hab irgendwie das Gefühl das bei netcup was schief läuft... hab echt auch keine Idee mehr was ich mahcen soll


    Achso und nutze Ubuntu 20.04 ausm Controlpanel

  • Hast du deine Netzwerkkonfiguration überprüft ob die korrekt ist? Des weiteren kannst du auch mal schauen ob du in das Rettungssystem booten kannt.

  • Hast du deine Netzwerkkonfiguration überprüft ob die korrekt ist? Des weiteren kannst du auch mal schauen ob du in das Rettungssystem booten kannt.

    Was genau meinst du mit Netzwerkkonfiguration überprüfen? Also was gneau soll ich machen?

    Hab jetzt auch hinbekommen das in der /etc/resolv.conf 8.8.8.8 und 8.8.4.4 drin sind, hilft aber leider auch nix.


    ping 8.8.8.8

    -> Network is unreachable


    Im Rescue Mode funktioniert ping 8.8.8.8

  • Was genau meinst du mit Netzwerkkonfiguration überprüfen? Also was gneau soll ich machen?

    Hab jetzt auch hinbekommen das in der /etc/resolv.conf 8.8.8.8 und 8.8.4.4 drin sind, hilft aber leider auch nix.


    ping 8.8.8.8

    -> Network is unreachable

    Bei ubuntu ist unter /etc/netplan/ die Konfigurationsdateien für die Netzwerkeinstellungen hinterlegt. Bei einem Image install von Netcup müsste glaub ich der Name cloudinit mit dabei stehen. Genau weiß ich das jetzt nicht, da ich eher auf Debian setze.


    Du kannst aber auch erstmal versuchen ob du den Server in das Rettungssystem Booten kannst. Die Option findest du im SCP unter Medien -> Rettungssystem ( rechts oben in der ecke)

  • resolv.conf hab ich einen Beitrag oben hinzugefügt gehabt bereits....

    sorry bin nur am Handy online und habs übersehen.


    Wenns im Rettungssystem funktioniert ist dein System falsch konfiguriert. Hast du Ubuntu per Image oder iso/netinstall etc. installiert? Was ist die Ausgabe von „ip a“?

  • Bei ubuntu ist unter /etc/netplan/ die Konfigurationsdateien für die Netzwerkeinstellungen hinterlegt. Bei einem Image install von Netcup müsste glaub ich der Name cloudinit mit dabei stehen. Genau weiß ich das jetzt nicht, da ich eher auf Debian setze.


    Du kannst aber auch erstmal versuchen ob du den Server in das Rettungssystem Booten kannst. Die Option findest du im SCP unter Medien -> Rettungssystem ( rechts oben in der ecke)

    Was genau soll ich dann dort prüfen? Hab die Datei offen, steht z.B. sowas (anhang)


    Rescue Mode geht, dort geht auch ping 8.8.8.8 zum Beispiel

    Nur keine Ahnung was ich da machen soll dann?

  • sorry bin nur am Handy online und habs übersehen.


    Wenns im Rettungssystem funktioniert ist dein System falsch konfiguriert. Hast du Ubuntu per Image oder iso/netinstall etc. installiert? Was ist die Ausgabe von „ip a“?

    Hab ich über das Panel von Netcup. Direkt dort ausgewählt und eigentlich auch nichts daran geändert.
    Nur apt updates/upgrades und autoremove. Ansonsten nur nginx, mysql etc. installiert, aber das sollte ja daran nix ändern am Netzwerk etc?



    ip a mach ich sofort, moment

  • Stimmt, apt-get ändert nichts an deiner Netzwerk-Config. Eventuell ist der schnellste Weg Ubuntu einfach mal per ISO neu zu installieren. Normalerweise sollte das Image aber out of the box funktionieren.


    Da im Rettungssystem alles funktioniert liegts auf jeden Fall an deinem System und nicht an netcup an sich. Vielleicht hat sich ein Fehler in das vorgefertigte Image eingeschlichen.

  • da fällt mir gerade ein: wie konntest du denn updaten und mysql etc installieren ohne Internetverbindung?


    edit: sorry für den tripple-post, editieren am handy ist nervig

  • dein eth0 hat ja gar keine IP. Bitte probier eine erneute Image-Installation oder - besser - Neuinstallation per iso. Geht bestimmt schneller als den bestehendwn Fehler zu analysieren

    Hm kann ich dann denn irgendwie nen Backup vorher machen und reinladen oder so? ... hatte grad am server an der datenbank einiges geändert, wäre dann ja alles weg wenn ich das iso neu installiere


    Wie gesagt, es lief ja alles... ich hab nix geändert am Netzwerk oder so... hab vorhin mal den Server neugestartet nach paar Wochen laufzeit und jetzt geht das halt nicht mehr... Vorher gings noch vor dem Restart alles

  • dein eth0 hat ja gar keine IP. Bitte probier eine erneute Image-Installation oder - besser - Neuinstallation per iso. Geht bestimmt schneller als den bestehendwn Fehler zu analysieren

    Kann man das nicht fixen? Das wird ja am Netzwerk irgendwie liegen...