Docker auf vServer?

  • Ich würde mir an Deiner Stelle schon Gedanken machen, warum da willkürlich Dateien verschwinden oder beschädigt sind. Die DPKG-Verify Ausgabe ist beängstigend. Meiner Meinung nach gibt es dafür drei mögliche Ursachen:

    • HDD oder Dateisystem kaputt.
    • Irgendein Script das so handelt. (z.B. als Hook oder Cronjob)
    • Ein simpler Benutzerfehler. (= selber gelöscht)

    Ich würde Dir dringend raten, einmal alle installierten Pakete zu überprüfen:

    Shell-Script
    1. sudo dpkg -V

    Tauchen dabei Einträge auf, bei denen es sich nicht um Konfigurationsdateien handelt, hast Du eventuell ein viel größeres Problem. Konfigurationsdateien werden in der zweiten Spalte mit "c" gekennzeichnet. Außer einer handvoll Konfigurationsdateien darf da nichts auftauchen. Andernfalls sind Dateien beschädigt. Das könnte bedeuten, dass irgendetwas am Paketmanager vorbei arbeitet und Systemdateien in einer Art manipuliert, wie es nicht sein sollte.

  • hm ja da ist tatsächlich irgendwas ziemlich merkwürdig.

    nach einem Reboot ist alles wieder weg.

    also alle module die vorher fehlten sind wieder weg.

    docker geht entsprechend dann wieder nicht mehr.


    nach dem ausführen von

    sudo apt-get install linux-modules-4.15.0-47-generic --reinstall

    wird bei eingabe von

    sudo dpkg -V linux-modules-4.15.0-47-generic

    nichts mehr ausgegeben

    sudo dpkg -V | grep "net"

    gibt aber weiterhin:

  • Machst Du das auf dem Docker Host (KVM) oder im Container? Der Stand des Docker-Container müsste gesichert werden (docker commit).

    Wenn das Problem tatsächlich auf dem Host auftritt, dann ist wohl das Filesystem im Argen. Es könnte sich aber auch um ein Overlay-FS handeln. Hast Du das für Docker in Verwendung und ist da eventuell etwas Unbeabsichtigtes passiert?

    Was sagt mount auf dem Host dazu?

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • hallo,


    oh ich hatte irgendwie übersehen das mir noch jmd geantwortet hatte.

    Der Docker Container lief ja noch garnicht.

    Ich habe alle Befehle immer in der KVM durchgeführt.

    mount ergibt:


    lg grischan