Apache Reverse Proxy ändert POST-Body? Mailcow UI Problem

  • Hallo liebe Netcup-Community,


    ich war gerade dabei ein Issue bei Mailcow-Dockerized zu erstellen, da die UI hängen blieb, wenn man beim Ändern des Passwortes eines nimmt, welches ein = enthält.

    Nun musste ich leider feststellen, dass es bei direktem Zugriff auf den Mailcow-nginx problemlos funktioniert. Versuche ich es aber über den Apache Reverse Proxy, liefert der Mailcow-nginx auf den API-POST-Request einen 404-Fehler.


    Habt ihr vielleicht eine Idee, woran das liegen könnte?

    Ich verwende eine Apache VHost Config wie in https://mailcow.github.io/mail…/firststeps-rp/#apache-24 empfohlen.

    Die UI sendet einen POST-Request mit einem typischen GET-Query-String als Body, wobei der relevante attr-Parameter ein (URL-encoded) JSON enthält.
    Und dieser Request wird vom Mailcow nginx mit 404 beantwortet, wenn die Anfrage durch den Apache (v2.4.38-3, Debian Buster) geht - sie kommt nicht in der verantwortlichen PHP-Datei an.


    Was läuft hier falsch? =O

  • Moin,


    wenn das von Mailcow so empfohlen wird, dann könntest du doch auch (zusätzlich?) dort das Ticket aufmachen? Ich vermute, die kennen sich mit dem Kontext ein bisschen besser aus.


    Viele Grüße
    Matthias


    P.S.: Vielleicht liegts ja an den anderen Zeichen im Passwort? Welche Zeichen verwendest du denn noch? ;)

  • Danke für eure Bemühungen - besonders an False fürs testen.

    Seltsamerweise funktioniert es heute problemlos. Ohne reboot, ohne sonst etwas geändert zu haben...


    Obwohl es mich brennend interessieren würde, was das war - schade um die Zeit. Ich freu mich, dass es jetzt geht. :)