Posts by sdellenb

    Statt einem Storage Server könntest du auch minimalistisch im Rettungssystem einen Storage Space Share (ab 250GB für 5€) mit NFS einbinden und /dev/sda per dd sichern.

    Oder mit Menüführung z.B. Clonezilla, mit ISO hochladen und booten (zum sichern und restoren).


    Ich hab im Moment nur Filesicherung mit Borgbackup, da mein vServer 160GB SSD hat und ich nicht genug Platz (und Downtime) habe, um ein Image so zu sichern...

    Kann das sein, dass http://www.netcup-sonderangebote.de/ und http://www.netcup-status.de/ immernoch nicht per SSL erreichbar sind?


    https://www.netcup-sonderangebote.de bindet einige Elemente über http ein. Je nach Browser sieht's seltsam aus (z.B. Firefox 52.6.0 ESR) oder geht gar nicht (Google Chrome?).

    Code
    1. Blocked loading mixed active content "http://www.netcup-sonderangebote.de/wp-content/themes/netcup2/style.css"[Learn More] www.netcup-sonderangebote.de
    2. Blocked loading mixed active content "http://www.netcup-sonderangebote.de/wp-content/themes/netcup2/extra2.css"[Learn More] www.netcup-sonderangebote.de
    3. Loading mixed (insecure) display content "http://www.netcup-sonderangebote.de/wp-content/themes/netcup2/images/logo_head.png" on a secure page[Learn More] www.netcup-sonderangebote.de
    4. Loading mixed (insecure) display content "http://www.netcup-sonderangebote.de/wp-content/uploads/2012/11/dedom.png" on a secure page[Learn More] www.netcup-sonderangebote.de
    5. Loading mixed (insecure) display content "http://www.netcup-sonderangebote.de/wp-content/uploads/2016/12/vserver_ny.png" on a secure page[Learn More] www.netcup-sonderangebote.de
    6. GET http://www.netcup-sonderangebote.de/wp-content/themes/netcup2/images/logo_head.png [Mixed Content] [HTTP/1.1 200 OK 54ms]
    7. GET http://www.netcup-sonderangebote.de/wp-content/uploads/2012/11/dedom.png [Mixed Content] [HTTP/1.1 200 OK 74ms]
    8. GET http://www.netcup-sonderangebote.de/wp-content/uploads/2016/12/vserver_ny.png [Mixed Content] [HTTP/1.1 200 OK 74ms]

    Im Moment habe ich einen kleinen VPS und 250 GB Storage Space, der Borg Backups speichert.


    Weil CrashPlan mich rauswirft, werde ich bald auf einen S1000 umsteigen und alle meine Maschinen dahin sichern (das 1TB Storage Space reicht wahrscheinlich grad nicht aus).

    Die Sicherung der Sicherung geht dann in ein simples Cloud Storage bei einem anderen Anbieter (d.h. Off-site).


    Mir persönlich fehlt da nichts im Angebot.

    Ich habe für Mails das folgende Setup (von Hand konfiguriert):

    * Postfix für SMTP

    * Dovecot für IMAP (POP3 abgeschaltet)

    * ViMbAdmin** zur Verwaltung der Email-Domains, -Adressen & Aliases, die dahinterliegende MySQL-Datenbank wird von Postfix und Dovecot gemeinsam verwendet

    * SQLGrey für Greylisting, mit sgwi** als Verwaltungstool

    * SpamAssassin

    * openDKIM

    * Roundcube Mail als Webmail (selten genutzt)


    Das alles braucht kaum Ressourcen auf meinem RootServer.

    Ich denke ausschliesslich für Email reicht auch ein VPS 500 (wenn 40GB Disk reichen).



    ** Die Webdienste habe ich auf einen VPS 100 ausgelagert. Die zwei MySQL Datenbanken werden mit selektiver Replikation in beide Richtungen synchron gehalten.

    Das gleiche Problem trat bei mir heute mittag ca 12.00h nach dem angekündigten Neustart auf.

    Kernel 3.10.0-693.11.6.el7.x86_64 bootet nicht mehr. Statt dessen Kernel Panic s. Screenshot. Die Zwischenlösung bestand bei mir darin, den Vorgängerkernel 3.10.0-693.11.*1*.el7.x86_64 zu booten.


    Vorhin (ca. 19.00h) wurde ich dann im SCP aufgefordert, den Server wegen eines (erneuten) KVM-Updates neu zu starten. Danach lief bei mir auch wieder der Kernel 3.10.0-693.11.6.el7.x86_64.

    Ich hatte heute nach dem Node Update das gleiche Problem mit 3.10.0-693.11.6.el7. Kernel Panic nach Grub und nix ging mehr. Ich habs dann erst eine Stunde später bemerkt, als der Root Server schon lange wieder gestartet war. Nur ein älterer Kernel half.


    Mit dem neuen KVM-Update bootet er wieder mit dem neuesten Kernel. :thumbup:

    Interessanterweise war der VPS nicht betroffen, nur der Root Server G6..

    Hallo,

    mein Server war gerade für ca 1 bis 2 Minuten weg. (Nicht offline sondern nur Verbindung abgebrochen aber nicht die ssh Verbindung)

    War das schon der angekündigte Restart oder hat das etwas damit zu tun? Oder kommt der Restart noch?

    Um 13:39 hatte ich laut externem Monitoring auch einen kurzen Unterbruch (2 Minuten), die Server wurden aber nicht neu gestartet (uptime immer noch 25 Tage).

    Antivirussoftware ist fast immer einer der ersten Verdächtigen wenn im Netzwerk was nicht richtig läuft oder irgendwas seltsames passiert...

    Früher waren es Viren, heute ist es die Antivirussoftware.. 8o

    1. Beide Server in den Rettungsmodus. Auf dem Quellserver musst du den root-Zugriff per SSH zulassen. Ist zwar nicht best-practice, mit einem starken Root-Passwort oder gar pubkey-Auth im Rettungssystem sollte das aber für die kurze Dauer des Transfers kein Problem sein.

    Das kann man ja dahingehend absichern, indem man sshd_config mit

    Code
    1. AllowUsers root@remote-ip

    einschränkt.

    Ich habe im Frühling einen vServer mit Clonezilla direkt übers Netzwerk gespiegelt (Partitionen kopiert, da die Zieldisk kleiner ist als die Quelldisk, welche aber wiederum nicht voll belegt war).


    Nachher noch Sachen wie hostname, statische IP / Gateway, Keys etc anpassen.


    War recht schnell erledigt und ohne zusätzlichen Export.

    Eine Variante zur forensischen Analyse wäre, einen Snapshot des vServers zu exportieren und mit qemu-img in eine VM-Disk zu konvertieren.

    Damit dann eine VM ohne Netzwerk aufsetzten oder mit einer Linux-Live-CD analysieren, ohne das installierte Betriebssystem zu starten.


    P.S. Das ist alles theoretisch, selbst gemacht habe ich das noch nicht.. :)

    Welche fail2ban Version verwendest du?


    Ich habe das Gefühl, seit dem letzten Update (weiss grad nicht welche Version ich habe) bannt es auch nicht mehr richtig. Da kommen teilweise noch hunderte fehlgeschlagene Logins, nachdem der "Ban IP..." im logfile ist..

    Also ich bin mit meinem Root-Server M SSD v6 ganz zufrieden.