Posts by Rubi

    Lieber Server-Freunde,


    ich bin gerade dabei, meinen Server von "normalem" SSL (über Thawte) auf Let's Encrypt umzustellen.
    Leider funktioniert das nicht so wie gewünsch - ich habe das alte Zertifikat in Froxlor gelöscht und die Keys vom Server gelöscht und Let's Encrypt aktiviert. Beim Neustart des Servers erhalte ich die Meldung:

    Code
    1. SSLCertificateKeyFile: file '/etc/apache2/apache2.key' does not exist or is empty


    Benötige ich denn überhaupt noch apache-Keyfiles? Wenn ich meinen Key wieder einfüge, sagt mir die Console beim Server-Neustart:

    Code
    1. Syntax error on line 1 of /etc/apache2/sites-enabled/apache2.key:
    2. Invalid command '-----BEGIN', perhaps misspelled or defined by a module not included in the server configuration


    Habe ich irgendetwas falsch verstanden? Hatte mich eigentlich an diese Anleitung gehalten, komme jetzt nicht mehr weiter: https://nichteinschalten.de/fr…it-letsencrypt-verbinden/ - Kommt es zu Problemen, da ich vorher "normal" SSL installiert hatte?


    Freue mich über Tipps!

    Hi Server-Freunde,


    ich habe ein merkwürdiges Problem beim Versenden von Mails über ein CMS (Drupal, will einen Test-Newsletter verschicken). Folgendes Szenario:

    • Auf meinem Server liegen zwei Domains x1.de und x2.de
    • auf x2.de ist Drupal installiert, ich will eine Testmail an name@x1.de schicken und bekomme eine Fehlermail zurück an name@x2.de mit dem Inhalt (u.a.):
      Diagnostic-Code: X-Postfix; unknown user: "name@x1.de"
    • Ein Versenden von Testmails an z.B. name@gmx.de etc. funktioniert aber problemlos
    • Ansonsten funktioniert die Mail-Adresse name@x1.de auch absolut fehlerfrei. Nur die Testmails vom Server können anscheinend nicht zugestellt werden. Noch ein Hinweis: die Mails name@x1.de laufen über Google Apps, die DNS wurde also geändert (was aber bisher noch nie zu Problemen geführt hat).
    • Das Problem besteht, seit der Server von einem alten Volksserver auf eine aktuelle Maschine umgezogen ist.

    Habt ihr eine Idee? Echt ein komisches Ding!
    Ein Nachtrag noch nach weiteren Tests: Mails an Domains, deren Mail-System über eine andere IP läuft, kommen als unknown zurück. Wenn das Mail-System aber auf dem Server läuft, klappt alles. Kann man Postfix irgendwie mitteilen, dass er woanders nach dem User schauen soll, nicht auf dem eigenen Server, auch wenn www der Domain auf dem Server selbst liegt?

    Die Pings sind schnell, keine Probleme zu erkennen.
    Es scheint wirklich über den gesamten Server an der schlechten SQL-Performance zu liegen... Gibt es eine Möglichkeit, hier was zu verbessern bzw. zu überprüfen? In der Prozess-Übersicht sind auch keine belasteten Prozesse zu erkenne, die was mit SQL zu tun haben könnten.


    Das Problem mit der Performance besteht auch, wenn ich eine komplett neue Drupal-Site in einem neuen Kunden-Account installiere, was bisher immer blitzschnell ging. Konkrete Skript-Probleme würde ich also ausschließen.


    Thx!

    Hi Server-Freunde,


    ich habe derzeit massive Probleme mit meinem Server. Alle Adressen (also alle "Kunden") reagieren sehr sehr langsam.
    Mit

    Code
    1. top

    kann ich keinerlei Probleme erkennen. Weder mem noch CPU sind in irgendeiner Weise belastet. Der Aufruf jeder Kundenseite dauert jedoch ca. 2-3 Minuten...


    Auch die Navigation in Froxlor ist schleppend langsam. Das Problem scheint zu bestehen, seitdem ich den Server gestern neu gestartet habe...


    Habt ihr eine Idee, wo das Problem liegen könnte? Vielleicht irgendwelche VHOST-Settings oder sowas? Mem und CPU sind ja komplett auf idle... ;(


    Thx!

    Danke für die Antworten.


    Hab es jetzt mit WinSCP probiert, da bekomme ich allerdings immer ein Timeout. Was muss ich denn einstellen? Kann man irgendwo SSH-Login oder so auswählen?
    Per Putty habe ich keine Probleme. Nur würde ich gerne die grafische Oberfläche von WinSCP nutzen.


    Danke euch!

    Hi,


    ich habe mal eine kurze - hoffentlich nicht doofe - Frage.


    Wie kann ich denn per FTP auf die Root-Ebene zugreifen? Meine Benutzer können jeweils auf ihr Verzeichnis zugreifen, ich würde jedoch gerne per FTP auf die Root-Ebene (um Log-Dateien downzuloaden).


    Danke!

    Hi Server-Freunde,


    ich habe eine Domain bei register.com registriert (nur die Domain, kein Hosting), die Inhalte würde ich gerne bei Netcup auf einem vServer hosten.
    Weiß jemand, was genau ich wo einstellen muss?


    Bei register.com kann ich die IP des vServers eintragen, was muss dann noch in Apache beim Server geändert werden, damit alles klappt?


    Danke!

    Robert;21732 wrote:

    Für eine zeitbasierte Löschung:

    Code
    1. find -ctime +14 -delete

    Das löscht alle Dateien, deren letzte Änderung mindestens 14 Tage zurückliegt. Du kannst zum Testen einfach das "-delete" weglassen, dann siehst du, welche Dateien betroffen sind. Über "man find" findest du auch noch weitere Filtermöglichkeiten.


    Thx, funktioniert super!

    Moin Server-Freunde,


    ich führe von einigen Ordner per Shell-Skript automatisierte Backups durch, merke nun aber, dass die Datenmenge schnell explodiert, da jeden Tag eine Sicherung durchgeführt wird.


    Kann mir jemand auf die Sprünge helfen, wie ich im Backup Ordner nur die aktuellsten X Dateien beibehalten kann, also ältere Dateien automatisch löschen kann?


    Thx!

    Artimis;21033 wrote:

    Rubi, dein Tut sieht nett aus, aber da ist ein fetter Fehler und ein sehr grober Umweg drin:


    a) "* 5 * * * /home/scripts/logwatch.sh" sendet dir täglich 59 Emails. Ich glaube nicht, dass dies beabsichtigt ist. Nimm lieber "0 5 * * * /home/scripts/logwatch.sh".


    b) Wozu ein Sende-Script anlegen es irgendwo speichern, es chmodden und dann in den Cronjob eintragen, wenn es doch nur eine Zeile hat. Warum nicht einfach "* 5 * * * /usr/sbin/logwatch --mailto [user]{@[host]}"?


    Da sieht man, dass ich noch eine Menge lernen muss, dachte es geht nur per Script. Und das * hatte ich noch zu Testzwecken drin (und falsch hier eingetragen), danke für den Tipp!


    Hatte bei mir keinen Eintrag in der daily, komisch. Kann es sein, dass die Daily gelöscht wird (o.ä.), sobald ich manuell einen Eintrag angelegt habe?

    Da ich bisher nur mit Fragen hier aktiv war, will ich nun auch mal ein kleines Tutorial posten. Finde Logwatch auch klasse, sehr gut, um den Server im Auge zu behalten.


    ---


    Logwatch ist ein Logfile-Programm, mit welchem man sich Log-Dateien täglich per Mail senden lassen kann.
    Logwatch installieren


    Code
    1. apt-get install logwatch

    Konfigurieren


    Code
    1. nano /usr/share/logwatch/default.conf/logwatch.conf

    Hier die E-Mail-Adresse eintragen, als Format habe ich noch HTML eingetragen. Aufruf von Logwatch mit:


    Code
    1. logwatch --mailto [EMAIL='MAIL@ADRESSE.COM']MAIL@ADRESSE.COM[/EMAIL]

    Cron-Job


    Code
    1. nano /home/scripts/logwatch.sh

    Inhalt der Datei:


    Code
    1. !/bin/sh
    2. /usr/sbin/logwatch --mailto [EMAIL='MAIL@ADRESSE.COM']MAIL@ADRESSE.COM[/EMAIL]

    Ganz wichtig, CHMOD für das Script setzen:


    Code
    1. chmod 750 logwatch.sh


    Cronjob einrichten


    Code
    1. crontab -e

    Inhalt der Datei:


    Code
    1. 0 5 * * * /home/scripts/logwatch.sh

    Von nun an wird jeden Tag um 5 Uhr eine E-Mail mit einer Zusammenfassung der Log-Daten versendet.

    Hi, habe nun noch ein wenig geforscht und diesen Fehler in den Log-Files gefunden:


    Code
    1. fatal: main.cf configuration error: virtual_mailbox_limit is smaller than message_size_limit


    Nach dem Einfügen von

    Code
    1. virtual_mailbox_limit = 0


    in die /etc/postfix/main.cf.
    Vorher hatte ich noch Courier deinstalliert und die Konfig-Vorschläge vom SysCP für Dovecot und Postfix neu eingespielt.


    Nun klappt alles (Weiterleitung, Senden und Empfangen), JUHU!


    Eine Frage hab ich aber noch: Leider läuft die SMTP-Kommunikation unverschlüsselt ab, gibt es eine Möglichkeit, ein freies SSL-Zertifikat zu verwenden? Hat evtl. jemand ein HowTo zur Hand?