Posts by Rubi

    Hi vServer-Freunde,


    nach der Installation von ClamScan (apt-get install clamscan) ist es leider nicht möglich Verzeichnisse zu untersuchen.


    Beim ersten Startversuch (clamscan /tmp) war der Fehler:


    [HTML]unable to lock database directory[/HTML]


    Inzwischen kommt immer der Fehler


    [HTML]Malformed database[/HTML]


    Leider konnte mir google da nicht wirklich weiterhelfen, habt ihr eine Idee?

    Hi,


    eine kurze Frage zu DenyHosts, in den FAQ finde ich keine Antwort.


    Muss ich das Programm einfach mit apt-get install denyhosts installieren und fertig? Die Config stimmt ja dann für Debian.


    Läuft das Programm dann automatisch oder muss ich noch was einrichten?

    Habe nun zum Schutz des Verzeichnisses per htaccess bisher folgendes (erfolglos) probiert:



    • Erstmal in der /etc/apache2/apache2.conf den Verzeichnisschutz für das PMA-Verzeichnis erlauben AllowOverride AuthConfig:


      <Directory "/usr/share/phpmyadmin">
      Options Indexes FollowSymLinks
      AllowOverride AuthConfig
      Order allow,deny
      Allow from all
      </Directory>


      jetzt in der config.inc.php im PMA-Verzeichnis den auth-type auf http ändern: $cfg['Servers'][$i]['auth_type'] ='http'

    • Apache neu gestartet -> keine htaccess Abfrage beim Aufruf von /phpmyadmin per Browser
    • Diese Anleitung hat auch nicht dazu geführt, dass ich per htaccess abgefragt werde:
      http://blog.bidinger.de/2009/1…t-mit-htaccess-schuetzen/


    Hat noch jemand eine Idee, was ich machen könnte?

    Quote from sim4000;20037

    vHost ändern, Ordner verschieben und Authentifizierung auf http ändern.
    http://wiki.phpmyadmin.net/pma/Auth_types#http


    Wo ist nun das Problem?


    Danke für die Antwort schonmal, leider hilft mir das aber nicht wirklich weiter.
    Kannst du die Schritte noch genauer erklären?


    • vHost ändern: wie geht das?
    • Ordner verschieben einfach per mv?
    • Quote

      In config.inc.php do not fill in values for $cfg['Servers'][$i]['user'] and $cfg['Servers'][$i]['password']


      Wenn ich da die Werte rausnehmen, ist auth_type http aktiviert?


    Bin Neuling auf dem Gebiet Server (irgendwann muss man ja mal anfangen) :)

    Hi vServer-Freunde,


    ich würde gerne den Pfad zu PhpMyAdmin ändern (als erste kleine Hürde).
    Muss ich dafür einfach den Ordner umbenennen und dann den Link zu dem Ordner entsprechend ändern?


    Wenn ich phpMyAdmin dann auch noch per htaccess schützen will, lege ich einfach die htaccess und passwd direkt in den phpMyAdmin-Ordner (oder muss man in dem Link-Ordner auch irgendwas machen)?

    Quote from Robert;20015

    Das kann ich dir nicht zu 100% sagen... diese Meldung kommt nur, wenn der Paketverwalter etwas an den Konfigurationsdateien verändert hat. Diese Änderungen können einfach nur organisatorisch sein, z.B. um den Aufbau logischer zu machen, aber es können auch wichtige Einstellungen geändert worden sein, die man möglicherweise auch übernehmen will. Ich habe es beim Upgrade so gemacht, dass ich mir die Unterschiede zwischen den Dateien angesehen habe und meiner Meinung nach sinnvolle Änderungen in meine Dateien eingefügt habe. Ohne Anpassungen sollten die alten Dateien meist weiterhin funktionieren, aber es besteht die Gefahr, dass man dadurch sinnvolle Änderungen verpasst.


    Alles klar, danke, dann werde ich das auch so machen. Sicher ist sicher!

    Hi,


    ich wollte heute mein Confixx gemäß der Anleitung von parallels updaten, leider hat das aber nicht geklappt:



    In Schritt 6 kommt bei mir nur die Fehlermeldung Command not found
    Auch wenn ich mich ins Verzeichnis begebe und dann dort das Update ausführen will, selber fehler.


    Muss ich irgendwas installieren, um pl ausführen zu können?

    Quote from Robert;20013

    Beim Upgrade müsstest du gefragt worden sein, ob du von bestimmten Konfigurationsdateien die momentane Version behalten oder die des Paketverwalters übernehmen möchtest. Hast du beim Apache vielleicht letzteres ausgewählt? Diese Seite wird nämlich in der Standardkonfiguration angezeigt. Möglicherweise fehlen jetzt einige vHost-Einstellung. Falls du die alten Konfigurationsdateien gesichert hast, solltest du mal vergleichen, was sich geändert hat.


    Oh ja, das wird es sein!
    Kann ich einfach die alten Config-Dateien beibehalten, oder muss ich alle Dateien händisch anpassen?

    Quote from slukas;20008

    wie hast du das update durchgeführt?


    Hab mitgeschrieben, daher kann ich das gut beantworten:


    erstmal die Sources.list anpassen (Lenny statt Etch), dann:


    • Die beiden alten Logger entfernen:
      aptitude purge klogd sysklogd
    • den neuen installieren:
      aptitude install rsyslog
    • Lenny installieren
      aptitude full-upgrade


    Hab danach noch versucht Confixx zu updaten, was auch nicht geklappt hat (er konnte die update.pl-Datei nicht finden), aber eins nach dem anderen ;)

    Quote from cisum;20005

    Wenn die Checksummen usw. nicht mehr stimmen würd ich erst nochmal überlegen, ob ich vor kurzem etwas installiert habe, was dies verursacht haben kann.


    Wenn ich mir wirklich sicher bin, dass sich jemand an meinem Server zu schaffen gemacht hat, dann würde ich den Server neu aufsetzen, sicher ist sicher.


    Also du sicherst die Kunden-Daten und Datenbanken und installierst komplett neu?


    Gibt es da eine Möglichkeit, das Sichern irgendwie zu automatisieren?

    Hi,


    ich habe meinen Etch mit Confixx auf Lenny aktualisiert.
    Leider bekomme ich beim Aufruf meiner Admin-Adresse nun nur die Apache-Meldung "It Works!", statt des Confixx-Logins.


    Hat schonmal jemand das Image mit integriertem Confixx erfolgreich auf Lenny upgedatet und kann mir Tipps geben?

    Wollte jetzt dafür keinen neuen Thread eröffnen:


    wie soll man sich denn verhalten, wenn man weiß oder vermutet, dass ein Hacker sich auf dem Server eingenistet haben könnte (z.B. über Checksummen, chkrootkit findet etwas etc.)?


    Will lieber vorher Bescheid wissen, anstatt dann in Panik zu verfallen, sollte es mal der Fall sein ;)

    Quote from sim4000;19979

    Nein. Wenn sich in einer .htaccess etwas findet was nicht erlaubt ist, löst Apache unter Umständen einen 500er Fehler aus.
    So beispielsweise wenn man mod_rewrite benutzen möchte.


    Das AllowOverride gibt es für jeden Ordner. Bist Du dir sicher, dass Du das All in dem richtigen <Directory>-Tag gesetzt hast?
    Und ein reload reicht. Ein restart musst Du nicht machen.


    Yeah! Das war es!
    Hab als Directory jetzt das Verzeichnis des Kunden angegeben.


    Vielen Dank, so macht ein Forum Spaß!
    Werde mich jetzt noch weiter in den Server einarbeiten, um dann hoffentlich auch bald Newbies weiterhelfen zu können.

    Danke schonmal für die Antworten.
    Erstmal noch kurz zur Info, habe einen vServer mit Debian.


    Nach dem Eintrag von


    Code
    ServerName localhost

    in die apache2.conf klappt der Neustart des Servers schonmal problemlos.


    Allerdings habe ich das htaccess Problem noch nicht lösen können.
    Laut Apache-Website müsste es mit None eigentlich ja egal sein, was ich in der htaccess zu stehen habe.


    Quote

    Wenn diese Anweisung auf None gesetzt wird, dann werden .htaccess-Dateien komplett ignoriert. In diesem Fall wird der Server nicht einmal versuchen, die .htaccess-Dateien im Dateisystem zu lesen.

    AllowOverride auf All zu ändern, hilft leider auch nicht.


    Sobald irgendwas in der htaccess steht, und sei es nur "Options +FollowSymLinks" gibt es einen Internal Server Error. Eine leere htaccess macht allerdings keine Probleme.


    edit: reicht nach dem Ändern ein "apache2 restart", oder muss man die Config-Datei irgendwie anders neu laden?

    Hallo Netcup-Freunde,


    bin Neuling auf dem Gebiet vServer und habe mir den Server jetzt mal zugelegt, um mich ein bisschen in das Thema einzuarbeiten, werde euch also in Zukunft noch sicherlich mit reichlich Fragen nerven ;)


    Hier die erste:


    • Beim Versuch Apache neuzustarten, erhalte ich folgende Fehlermeldung "Could not determine the server's fully qualified domain name"


    Habe in der /etc/hostname statt vXXX mal vXXX.yourserver.net eingetragen, selbes Resultat. Habt ihr eine Idee?
    Hintergrund: ich habe in der php.ini ein höheres Memory_limit eingetragen, in der info.php steht aber immer noch der alte Wert.


    Meine nächste Frage:


    • Wo kann ich die Einstellungen für die htaccess vornehmen?
      Bekomme derzeit einen Internal Server Error mit der Drupal-Standard-htaccess.