Wordpress + Cloudflare kein Login möglich

  • Hallo,


    ich habe ein großes Problem, und zwar habe ich hier bei NetCup neuen Webspace bestellt. Die Domain habe ich bei Cloudflare eingetragen ( wie sonst auch ) und DNSSEC Aktiviert ( funktioniert auch ) und HSTS Aktiviert.


    So und nun habe ich Wordpress Installiert und da kommt schon das Problem.


    wenn ich es unter http Installiere, erscheint Wordpress ganz normal ein Login Fenster erreiche ich auch aber er logt sich nicht ein.


    wenn ich es unter httpS Installiere, kommt auch Wordpress ganz normal aber wenn ich ein Login möchte kommt die Fehlermeldung "zu viele Umleitungen"


    Was habe ich den falsch gemacht ? Jemand eine Idee wie ich das Lösungen könnte ?

  • Wenn Du eine https only Seite willst, musst Du in Wordpress die siteurl mit https Prefix einstellen. Wenn dort http drin steht, schickt Dich Wordpress auf http und Cloudfare auf https usw.


    Alternativ gibt es auch Plugins mit denen Du steuern kannst welche Teile der Webseite https sein sollen und welche nicht. Das muss aber mit den Cloudflare Einstellungen zusammen passen.

  • Ja https steht schon drin, habe auch eine andere Seite mit genau den gleichen Einstellungen.


    Aber bei der neuen geht es nicht…


    Egal was ich in Cloudflare einstelle nix funktioniert. Entferne ich Cloudflare läuft alles super mit https…


    Ist echt der Wurm drin komme da echt nicht weiter…

  • Naja, irgendwas muss anders sein. In meinem jugendlichen Leichtsinn würde ich behaupten, das du eine oder mehrere Weiterleitung (vermutlich Default Einstellungen, so wie mein Vorredner das schon vermutet) übersiehst. Guck doch nochmal nach :)


    Hast du den Artikel des Supports gelesen? Ich denke das löst dein Problem :


    If you use Cloudflare's Flexible SSL service and see mixed content issues or redirect loop errors, first ensure that there is no SSL certificate installed at your origin. If there is, then you shouldn't be using Flexible SSL and should instead set it to Full or Full(Strict).

    Additionally, please ensure that there is no redirect set up at your origin from http to https, as this specifically would cause the redirect loop.

    If none of the above applies, consider the following:

    1. If you are on an Apache web server, ensure that you have Mod_Cloudflare installed.
    2. If you're on Nginx, or Mod_Cloudflare does not automatically resolve the issue, ensure you have our official WordPress plugin installed.
    3. Should you continue to find issues, you may have URLs incorrectly formatted in your HTML or database, in order to resolve this please install a Mixed-Content Fixer plugin. We have had success with SSL Insecure Content Fixer.

    Other Users

    If you are using Cloudflare's SSL in Full or Full (Strict) mode and you find you have mixed-content issues, it is likely the case that you have absolute URLs hard coded into either your HTML or in your database. Please install a Mixed-Content Fixer plugin which should automatically replace the http with https in these sections. We have had success with the SSL Insecure Content Fixer plugin.



    Beste Grüße

  • Bin jetzt alles nochmal durch gegangen. Aber ich seh ich Wald vor lauter bäumen nicht.


    Und das Wordpress Plugin gut und schön, aber ich kann es ja nicht Aktivieren wenn ich nicht mehr ins Backend komme.