ionCube Loader Update?

  • Moin.


    Habe im WCP die PHP Version auf 5.6.37 gestellt da dort auch GMP aktiviert ist.


    Jedoch brauche ich den ionCube Loader 10.1 und der ist nur bei Netcup auf 6.0.

    Kann man den über Putty selber updaten oder muss ich abwarten?


    MfG


    Edit: PHP 7.1.21 hat mein Problem gelöst.

  • Hallo also ich brauch jetzt auch mal Hilfe ich brauch unbedingt ein Update von ionCube Loader auf mindesten 7.2 wie kann ich dies durchführen. Muss dazu sagen ich bin Laie. Ich bräuchte das Update für meinen Shop.


    Ich hoffe es kann mir jemand helfen.


    Danke schon mal

  • Das hab ich ja gemacht und da bekomme ich diese Fehlermeldung:

    Fatal error: The file /var/www/vhosts/hosting121538.af995.netcup.net/httpdocs/shop/Xycons/xycons_protected.inc.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0


    Laut System Info habe ich noch eine ältere Version des ionCube drauf Bild im Anhang.

  • Das hab ich ja gemacht und da bekomme ich diese Fehlermeldung:

    Fatal error: The file /var/www/vhosts/hosting121538.af995.netcup.net/httpdocs/shop/Xycons/xycons_protected.inc.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0


    Laut System Info habe ich noch eine ältere Version des ionCube drauf Bild im Anhang.

    ionCube Encoder ist das Programm, dass der Entwickler (Xycons ?) nutzt, um seinen Quellcode zu "verschlüsseln".

    ionCube Loader ist das Programm, dass der Hoster (netcup) zur Verfügung stellt, um den Quellcode zu "entschlüsseln".


    Die Meldung sagt dir, dass die Software, die du einsetzt für PHP 5.6 encodet wurde (ionCube Encoder). Sie muss auch mit dem Loader für 5.6 betrieben werden.

    Folglich kannst du die Software nicht mit PHP über 5.6 betreiben. Die Lösung wird auch genannt:

    Quote

    Please ask the provider of the script encoded with the ionCube Encoder

    Den Entwickler der Software um Update bitten

  • Hallo,


    der ionCube Encoder für PHP 5.6 ist lauffähig bis PHP 7.1.

    Ab PHP 7.2 muss der Encoder für PHP 7.2 genommen werden, welcher aber ebenso für PHP mit Version 7.3 funktioniert.


    Also entweder auf PHP 7.1 umstellen oder das Script mit der neueren Version encoden lassen.



    Beste Grüße