Funktionsproblem der Website nach Umzug

  • Wie gesagt, ob ich die Zeilen lösche oder etwas anderes reinschreibe. Hat leider keinerlei Auswirkungen auf Irgendwas.

    Nur beim Fremdhoster zeigen Änderungen an diesen Zeilen Wirkung.

    Du hast beim alten Hoster den kompletten Pfad zum Hosting eingetragen, bei netcup steht aber nur httpdocs und das ist nicht der komplette Pfad deshalb wie bereits von den anderen schon vorgeschlagen den vollständigen Pfad eintragen und solange der nicht richtig ist wird sich vermutlich auch nichts ändern

  • Ich denke das Problem ist die korrekte Pfadangabe.


    Im Basisverzeichnis befindet sich das Verzeichnis ''httpdocs''.

    Die Verzeichnisstruktur ist dort exakt so angelegt wie beim Fremdhoster.

    Pfad bei define und session sind beim Fremdhoster identisch.


    Fremdhoster

    DEFINE('LINK', '/bla/bla/11/11/11/htdocs/test/');

    DEFINE('WEBSEITE', 'http://www.blabla.de/');

    $_SESSION['verzeichnis'] = '/bla/bla/11/11/11/htdocs/test/');


    netcup

    DEFINE('LINK', '/var/www/vhosts/hosting134058.a2f90.netcup.net/httpdocs/');

    DEFINE('WEBSEITE', 'http://hosting134058.a2f90.netcup.net/');

    $_SESSION[verzeichnis] = '/var/lib/php5/hosting134058.a2f90.netcup.net/httpdocs/');


    Könnte bitte jemand die Pfade in den Zeilen 1 + 3 korrigieren?

  • ich hab kein Webhost, aber ich meine mal gelesen zu haben es gibt nur ab dem punkt httpdocs, thematik chroot oder bezog sich das nur auf ssh....

    jeder der einen Schreibfehler in meinem Post findet, darf ihn Kommentarlos behalten

    P.S. gilt auch für Schignaturen ;)

  • Hi,


    wie lautet denn die Document Root der Domain?

    In deinem alten Webhosting hast Du scheinbar einen Test Ordner unter htdocs, hast du den bei Netcup auch? Du schreibst das die Ordnerstruktur die gleiche ist bei Netcup gibst du aber keinen Test Ordner nach httpdocs an.

    Die dritte Zeile sollte wohl so aussehen

    Code
    1. $_SESSION[verzeichnis] = '/var/lib/php5/sessions/');
  • Was mir gerade zufällig auffällt: Wieso steht der Array-Schlüssel verzeichnis bei $_SESSION einmal in Anführungszeichen und einmal nicht? Ohne handelt es sich um eine Konstante und somit wahrscheinlich nicht mehr den gewünschten String. (Ja, ich weiß, dass PHP den bei Nichtexistenz trotz Fehlermeldung einfach umwandelt.)


    Was Dein Script bei der dritten Zeile wirklich erwartet, weiß ich nicht. Spontan würde ich sagen, dass es der gleiche Wert wie bei LINK ist.