[GELÖST] Fehler nach Update auf php 5.3

  • Hallo,


    ich habe ein Problem nach dem Update der php und mysql Version.
    Das Problem ist bei mir aber nur bei einem Server aufgetreten, bei einem anderen war alles okay.


    Folgenden Fehler bekomme ich wenn ich auf den IspCP Admin Zugreifen möchte:

    Quote

    Warning: require_once(/var/www/ispcp/gui/include/ispcp-db-keys.php): failed to open stream: Permission denied in /var/www/ispcp/gui/include/ispcp-lib.php on line 90 Fatal error: require_once(): Failed opening required '/var/www/ispcp/gui/include/ispcp-db-keys.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/ispcp/gui/include/ispcp-lib.php on line 90



    Folgender Fehler kommt bei phpmyadmin:

    Quote

    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.


    Folgender Fehler bei "php -v"



    Hier einfach mal die Seiten dazu:


    http://admin.dj-cosmo.net || IspCP Admin
    http://admin.dj-cosmo.net/pma/ || phpmyadmin
    http://ultimate-esport.de || Ebenfalls voll von Fehlern
    http://dzcp.dj-cosmo.net || gleiche System wie ultimate-esport.de allerdings ohne Fehler!



    Server Infos:


    Debian Lenny 64bit
    Apache2
    wenn noch infos fehlen liefer ich die gerne!


    Vielen Dank schonmal!

  • Ich habe apache schon gefühlte 100 mal restartet,reloaded etc.


    Das was ich nicht verstehe ist ich habe das ganze gestern mit dem gleichen Verfahren schon mal auf nem anderen Server gemacht und da habe ich überhaupt keine Fehler...


    Mir scheint, als würden iwelche Rechte nicht mehr stimmen aber wo...

  • bei mir war auch einiges im argen, allerdings mit Froxlor.


    habe einfach ein apt-get remove php5 gestartet.. hat Froxlor mit deinstalliert.. und ein install froxlor hat alles wieder ins reine gebracht..


    Grundlage war ein Update auf Squeeze vorweg und Php5 über Dotdeb.


    Gruß,
    Schuppe

  • Fehler beseitigt, mit ispCP Kundensupport.


    Mit Lenny geht es nicht php zu updaten^^ Also klar gibt es die dotdeb Pakete, aber ispCP kann seine Dateien nicht neu updaten, da Dotdeb ja mehr oder weniger testsource ist.


    Habe jetzt aber trotzdem neuinstalliert auf Sequeeze. Aber Dotdeb ist bei Sequeeze nicht notwendig gibt es auch in den Debian Sources. ;)


    Danke noch mal


    Gruß
    Cosmo