vmware ESXi on root server

  • hello,

    i have installed ESXi on the root server (RS 4000 G8) after enabling VMX.

    i have created 2 VMs (windows and CentOS). there is reachability between this two VMs also they are able to reach he ESXi management interface but i am not able to reach the internet.

    any ideas


    thanks

  • Two possibilities:

    1st: you have public IPv4 or IPv6 addresses for the VMs.

    They need to be connected as point2point via the ESXi machine or you need to setup a route to the ESXi machine and set the default route via ESXi


    2nd: you have private IP (RFC1918) addresses for the VMs.

    You need to assign the ESXi as gateway. On the ESXi you need to set up a (S)NAT towards your public IP / public interface.

  • i have 1 ipv4 and /64 ipv6 . i tried using this ipv4 on a VM machine but it didnt work , also IPV6 not working.

    i cannot do NAT on ESxi .


    it is not a routing issue , the issue is the machines connected to the vswitch are not able to communicate with anything outside the vmnic0.

    i might be missing a parameter on ESXi to make it works on a KVM

  • H6G : How to nat or use esxi as a gateway? I have never seen a setup with an single IP for host and vm's. Have you a link for your setup?

    LinkeIn und XING - Schreibt mir einfach eine PN.


    "Security is like an onion - the more you dig in the more you want to cry"

  • You cannot assign your only IPv4 to a VM.

    You have to use NAT. You can do NAT with the Linux-tools (iptables).


    i cannot do NAT on ESxi .

    Why?


    If you cannot use NAT you'll have to buy a second IPv4 address and use a router-VM which handles NAT then.


    In order to use IPv6 you have to install a neighbor discovery proxy on the ESXi machine to tell netcup's routers that this address is used on a machine.

  • why not , i can use it as long as ipv4 is disabled on my ESXi host.

    That IP is bounded to the physical network card of your host and is terminated there. Your IP cannot be a hop for yourself. There is no way of forwarding that IP to a VM while being used on your primary. If you disable IPv4 on the host, how are the packets supposed to get to the VMs? That would only be possible by bridging the outside NIC to the vswitch and I don't think that is going to work on netcup's network.



    problem is not routing or IP , it is related to vswitch and vnic and how the VMs are communicating with external network

    Your problem is Layer3 (Routing / IP). vswitch and vnic are Layer2. Forget about Layer2 here. Your solution lays in L3.

  • That would only be possible by bridging the outside NIC to the vswitch and I don't think that is going to work on netcup's network.

    if this is not possible , how we can install an hypervisor on netcup network .

    i opened a ticket with the support and they confirmed that lot of there clients are using ESXi. and logically it should work. and in case there is any ipv4 limitation, ipv6 is not working

  • if this is not possible , how we can install an hypervisor on netcup network .

    KVM, (Xen) and Proxmox are working fine, because the hypervisor host is a Linux machine where NAT can be used.

    I don't doubt that many customers are using ESXi on the network here. But I'm sure there are using a second IP with a routing VM then.


    For IPv6 you'll need a neighbor discovery proxy, because not the entire subnet is statically routed to your server.