Ständige Netzwerkprobleme

  • Hallo!


    Mein Server (Root-Server XL SSD v6) kämpft seit einigen Wochen häufig mit Netzwerkproblemen. Er ist von außen für mehrere Sekunden, manchmal sogar Minuten, nicht erreichbar, weder per HTTP noch per IMAP, noch per SSH. Die Serverauslastung ist sehr gering mit 0.04 0.01 0.01, RAM ist reichlich vorhanden, geswappt wird nicht, auf Disk-I/O wird nicht gewartet, in den Logs steht nichts Auffälliges, von meiner Seite sieht also alles gut aus. An der lokalen Netzwerkanbindung liegt es auch nicht, da der Server weder über das Mobilfunk von T-Mobile erreichbar ist, noch über unitymedia, noch über eine Standleitung zu TelemaxX in Karlsruhe. Häufig habe ich Probleme selbst die Homepage von netcup aufzurufen, während mein Server unerreichbar ist. Hat jemand Tipps für mich wie ich den Fehler auf Serverseite noch eingrenzen kann?


    Grüße

  • Häufig habe ich Probleme selbst die Homepage von netcup aufzurufen, während mein Server unerreichbar ist. Hat jemand Tipps für mich wie ich den Fehler auf Serverseite noch eingrenzen kann?

    Das klingt aber doch eher nach einem Problem mit deiner Verbindung, wenn du manchmal auch Probleme hat die Website von netcup aufzurufen?!

  • Japp, auch heute hatte ich wieder zwei Meldungen:


    13:31:09 The monitor mail.... (mail....) is currently DOWN (Port Is Not Listening).

    13:31:32 The monitor mail.... (mail....) is back UP (Port Is Listening) (It was down for 0 minutes and 24 seconds).


    15:14:25 The monitor mail.... (mail....) is currently DOWN (Port Is Not Listening).

    15:15:57 The monitor mail.... (mail....) is back UP (Port Is Listening) (It was down for 1 minutes and 6 seconds).


    Ich habe nach der DOWN-Meldung mtr gestartet und der Loss passiert tatsächlich direkt bei mir am Server, finde dort aber keinerlei Infos, dass etwas nicht stimmt. Da der Fehler so sporadisch auftritt, ist es schwer genau während der Downtime etwas zu unternehmen, zumal ich ja in dem Moment gar nicht auf den Server komme um ein mtr von dort nach außen zu starten.

  • Guten Tag,



    in so einem Fall ins Rettungssystem booten, MTR anfertigen und diesen bitte zum Support schicken, wenn hier im Bereich von netcup eine Störung vorliegt.


    Vielen Dank!


    Tritt der Paketverlust nicht im Rettungssystem auf, liegt die Fehlerursache vermutlich an der individuellen Systemkonfiguration. Je nach Betriebssystem lohnt es sich hier ggf. im SCP einen anderen Netzwerkkarten-Treiber auszuwählen.



    Mit freundlichen Grüßen


    Felix Preuß

  • Hallo!


    Also Auslastung kann es nicht sein, ich habe eben beobachtet wie selbst mit 0.01 Load der Server sich für eine Minute "aufgehängt" hat und nach dem Reconnect war die Load für die vergangenen Minuten bei 0.01 und die aktuelle bei 0.00. Ist auch irgendwie zu erwarten, dass der Server die meiste Zeit idle ist, da laufen nur eine Handvoll Apaches und PHP-FPM, Postfix und Dovecot.


    Ich habe den Netzwerktreibe von e1000 auf virtio umgestellt, aber die Probleme bleiben.


    Wie soll ich das mit dem Rettungssystem verstehen? Die Probleme treten ja sporadisch auf. Ich kann ja schlecht den Server herunterfahren und das Rettungssystem für ein paar Stunden booten in der Hoffnung, ich kann den Fehler irgendwann reproduzieren, und ein Failover habe ich aktuell nicht eingerichtet. :(

  • So aus Neugierde mal eine Frage .... hats du nur eine (1) IP auf dem Server, oder zufällig 2 IPs?

    Ich habe 5 IPs wobei 2 sind aus der gleichen Range. Mir ist eingefallen, ich könnte mal alle IPs überwachen und schauen, ob es Überschneidungen gibt. Ich habe festgestellt, dass die Ausfälle relativ zufällig sind, will heißen, manchmal sind alle Dienste hinter einer IP dicht aber andere Dienste von einer anderen IP sind noch erreichbar, mal sind wirklich alle Dienste dicht, mal sind die Dienste von den zwei IPs mit gleichen 3 Octets betroffen, aber die anderen IPs nicht. Echt komisch.

  • Hmm, warum kann man Beiträge nicht editieren? :(


    Ich werde mal ein Mini-Server auf alle IPs lauschen lassen und gucke dann, ob ich ihn irgendwie erreichen kann. Aber wie gesagt, bei der extrem niedrigen Last, die mein Server hat, vermute ich entweder Netzwerkprobleme oder ein anderer Kunde auf der Kiste treibt Unfug.