Windows Setup: Virtio Treiber Problem

  • Hallo,


    Ich habe seit Freitag den Server "VPS 2000 G7" und versuche momentan Windows Server 2012 R2 zu installieren.
    Hierzu hab ich mich auch an die Anleitung aus dem Netcup Wiki gehalten.
    Ich habe die von Netcup bereitgestellte Windows ISO wie auch die Treiber CD verwendet.
    Nur leider bleibt das Setup jedesmal hängen wenn die Virtio SCSI Treiber geladen werden.


    Um ein Fehler des Windows Image und der Treiber CD auszuschließen hab ich auch "Windows Server 2012" und auch die aktuellste Treiber CD von fedoraproject.org ausprobiert.
    Und in egal welcher Kombination, das Windows Setup bleibt beim laden der Virtio SCSI Treiber hängen.


    Mittlerweile befürchte ich es liegt an der Konfiguration des vServer selbst, da ich ja das Windows Image wie auch die Treiber als Fehlerquelle ausschließen kann.


    Kennt jemand von euch diese Problematik?


    Anbei ist noch ein Screenshot vom Zeitpunkt an dem das Setup hängen bleibt.
    Ersichtlich ist da auch um welchen Treiber es sich handelt.

  • Unter Debian, was momentan auf dem Server installiert ist, wird das hier ausgegeben:


    /dev/sda /dev/sda1 /dev/sda2 /dev/sda3


    Edit:
    Wie ich in dem von dir verlinktem Thread gelesen hab, wurden die Laufwerke bisher als vdX und nicht sdX erkannt. Kann dies mit meinem Problem zusammenhängen?


    Und wenn der von mir verwendete Treiber nicht der richtige ist, stellt sich die Frage welcher richtig wäre.
    Aber selbst wenn er nicht richtig ist, müsste das Windows Setup eigentlich den Treiber trotzdem problemlos laden, nur halt dann einfach keine Laufwerke anzeigen.

  • Hallo zusammen,


    ich habe exakt das gleiche Problem wie der Thread Ersteller. Ich habe schon mit dem Netcup Support gesprochen aber da wollte man mir nicht weiterhelfen. Nur bin ich, wie ich es auch am Telefon sagte, der festen Überzeugung das Netcup mir ja zumindest sagen könnte welche Hardware genutzt werden damit ich den entsprechenden Treiber installieren kann.


    Weiß noch jemand Rat?


    Ich denke ansonsten muss ich meinen Server innerhalb der zwei Wochen Widerrufsfrist kündigen.


    Danke!

  • Wie ich in dem von dir verlinktem Thread gelesen hab, wurden die Laufwerke bisher als vdX und nicht sdX erkannt. Kann dies mit meinem Problem zusammenhängen?


    Das ist durchaus möglich, da die virtuelle Hardware verändert werden kann. Auf einem "alten" Server mit vdX funktioniert die Treiber-CD einwandfrei. Ggf. muss man manuell in das WIN8-Verzeichnis wechseln.


    chris-jerusalem:
    Du kannst von Windows Virtio Drivers - FedoraProject neuere Treiber laden. Sowohl virtio-win-stable als auch virtio-win-latest sind aktueller als die Treiber-CD, so dass Du bei beiden Erfolg haben kannst. Sonst hilft nur ein Support-Ticket.

  • chris-jerusalem:
    Du kannst von Windows Virtio Drivers - FedoraProject neuere Treiber laden. Sowohl virtio-win-stable als auch virtio-win-latest sind aktueller als die Treiber-CD, so dass Du bei beiden Erfolg haben kannst. Sonst hilft nur ein Support-Ticket.

    Genau diese habe ich versucht. Die Iso habe ich mir auf den FTP geladen und habe nun alle auf der ISO befindlichen Treiber versucht. Entweder es werden keine Datenträger erkannt oder die Installationsroutine geht einfach nicht weiter, also nach Auswahl des Treibers steht diese.


    Sonst jemand eine Idee?


    Danke!

  • Hallo, ich habe das gleiche Problem.
    Die Installation von Windows Server 2012 R2 bleibt immer bei der Treiberauswahl hängen.


    Ich lege die Treiber CD ein, dann versuche ich den Teiber auszuwählen. Welches ist denn der richtige? Automatisch wird keiner erkannt.


    Treiber CD: virtio-win-0.1.126.iso


  • An derselben Stelle dann auch gleich noch die Treiber für NetKVM (Ethernet, damit gleich die IP Adresse per DHCP vergeben wird) und Balloon (Speichermanagement) mit auswählen/installieren. (Sonst muss man das im Nachgang manuell machen und beim Installieren würde er sonst keine Updates finden.


    Zur ursprungsfrage: Es kann eigentlich nur virtioscsi oder virtiostor sein. Darunter liegen Verzeichnisse für das jeweilige Windows.
    Damit sollte es eigentlich funktionieren. Ich habe es selbst jedoch nur auf root-Server und nicht auf VPS ausprobiert.

  • D:\vioscsi\2k12R2\amd64

    Also mit dem klappte die Installation sofort :)
    Man muss halt nur darauf achten, gleich nach der Treiberinstallation wieder die Windows CD einzulegen.


    Ansonsten wird der WEITER Button ausgegraut...


    Die Installation war innerhalb von wenigen Minuten fertig. Die 200 Windows Updates dauern aber noch an... :D