Gnome auf Ubuntu 10.04

  • Ich krieg Gnome nicht zum laufen auf Ubuntu 10.04, ich habe "apt-get install ubuntu-desktop" benutzt. Wenn ich mit jetzt mit VNC einlogge kriege ich erstmal nur eine Shell. Wenn ich hier "startx" eingebe kommt folgende Ausgabe:


    Code
    1. exec: 3: /usr/bin/X: not found
    2. giving up.
    3. xinit: No such file or directory (errno 2): unable to connect to X server
    4. xinit: No such process (errno 3): Server error.
  • Mit VNC einloggen und eine Shell bekommen?
    Meinst du eine Shell in einem xterm?


    startx startet einen XServer. Dein VNC-Server muss dir aber bereits einen zur verfügung stellen (sonst würdest du deinen Terminalemulator nicht sehen können).


    Versuch es mal mit

    Code
    1. gnome-session

    .


    Darf ich fragen, was du mit Gnome auf einem vServer vor hast? Bist du dir der Risiken bewusst?

  • Und wo wir schon bei Risiken sind: Wie loggst du dich per VNC ein?
    Doch hoffentlich nicht über einen auf einem frei erreichbaren Port laufenden von root gestartenen VNC-Server über eine unverschlüsselte Verbindung mit eine bis zu 8-stelligen Passwort (denn mehr werden afaik nicht unterstützt), oder?

    Mein Server:
    v(olks)Server 1. Serie: 2,5GHz, 1024MB RAM, 1024MB Swap, 2x60GB-Raid1-HDD, Traffic-Flat
    Node:
    78.46.117.9x | hos-tr2.ex3k4.rz7.hetzner.de

  • Bah, ersetze einfach überall VPN durch VNC :D:o
    Ich habe mich gerade mit meinen VPNs und die Unsetzung von IPv4 und IPv6 in denselben befasst.
    Sorry

    Mein Server:
    v(olks)Server 1. Serie: 2,5GHz, 1024MB RAM, 1024MB Swap, 2x60GB-Raid1-HDD, Traffic-Flat
    Node:
    78.46.117.9x | hos-tr2.ex3k4.rz7.hetzner.de

  • theDude;23770 wrote:

    Darf ich fragen, was du mit Gnome auf einem vServer vor hast? Bist du dir der Risiken bewusst?


    Was Gnome auf einem vServer für Risiken hat ist mir nicht bewusst.


    Artimis;23778 wrote:

    Und wo wir schon bei Risiken sind: Wie loggst du dich per VNC ein?


    Über einen SSH-Tunnel(SSH ist auf meinem Server der einzige von außen erreichbare Dienst)


    Wenn ich gnome-session eingebe wird das folgende ausgegeben:


    Code
    1. sh: gnome-session: command not found
  • Artimis;23799 wrote:

    gnome-session ist ein Paket ;)
    Hast du es installiert?


    Gerade versucht, geht allerdings leider nicht:


  • Oh... Hm, mit fuse kannst du sowiesi nichts bei Netcup anfangen wegen der Virtualisierung

    Mein Server:
    v(olks)Server 1. Serie: 2,5GHz, 1024MB RAM, 1024MB Swap, 2x60GB-Raid1-HDD, Traffic-Flat
    Node:
    78.46.117.9x | hos-tr2.ex3k4.rz7.hetzner.de

  • gnome-session ist ein programm (und ja, auch ein Paket). max gnome-session sagt:


    blablabla.


    Ohne gnome-session gibt's keine Gnome Sitzung.


    Ich habe gerade mal auf meinem eigenen vServer (Debian Lenny) aptitude install gnome-session ausprobiert. Ich bekomme eine lange liste von Paketen (322), die installiert werden müssten. Allerdings sehe ich dort nichts in Richtung fuse.
    Bist du sicher, dass deine vorherige Installation von ubuntu-desktop (das AFAIK fuse enthält) erfolgreich war? Ich vermute, dass die letzte Installation fehl schlug und apt nun bei jeder weiteren Installation fuse nachinstallieren will.


    Ich würde alles noch mal runter schmeißen und nur gnome-session installieren.



    Zum Thema Sicherheit: Wie du siehst werden dort viele Pakete installiert, die wahrscheinlich nicht für den Einsatz auf Servern entwickelt wurden. Sie können ggf. Sicherheitslücken enthalten, die dir das Genick brechen können (sprich: Schaden anrichten können). Aber das nur am Rande - es ist deine Verantwortung damit richtig umzugehen.

  • Mal etwas anderes: Muss es denn unbedingt das Schwergewicht Gnome sein?
    Was ist sonst mit Fluxbox (das läuft bei mir *schäm*. Natürlich als unprivilegierter User und nur per SSH-Tunnel erreichbar).


    Und du weißt auch, dass du mit einem lokalen X-Server die GUIs per SSH auf den Desktop holen kannst?

    Mein Server:
    v(olks)Server 1. Serie: 2,5GHz, 1024MB RAM, 1024MB Swap, 2x60GB-Raid1-HDD, Traffic-Flat
    Node:
    78.46.117.9x | hos-tr2.ex3k4.rz7.hetzner.de

  • Habe "apt-get fluxbox gemacht, da kamen auch keine Fehler. Wenn ich jetzt "startfluxbox" eingebe kommt folgender Fehler:


    Code
    1. xmodmap: unable to open display ''
    2. Error: Couldn't connect to XServer
  • Ne, fluxbox wird mit dem vnc4server mitgestartet.
    Dazu einfach in ~/.vnc/xstartup folgenden Inhalt einfügen:

    Anschließend vnc4server mit der Portnummer als den VNC-User starten. Ich verwende z.B. folgendes Startscript (ja, es ist unschön. Ich habe es damals in der Anfangszeot geschrieben):

    Der vnc4server hört dann auf TCP/5901 und TCP/6001

    Mein Server:
    v(olks)Server 1. Serie: 2,5GHz, 1024MB RAM, 1024MB Swap, 2x60GB-Raid1-HDD, Traffic-Flat
    Node:
    78.46.117.9x | hos-tr2.ex3k4.rz7.hetzner.de

  • Naja, wenn man einfach fluxbox und vnc4server installiert, macht der auch alles von alleine (bis auf das Starten).
    Ich weiß aber nicht, was er jetzt anstellt, wo da ein halbes Gnome drauf ist.

    Mein Server:
    v(olks)Server 1. Serie: 2,5GHz, 1024MB RAM, 1024MB Swap, 2x60GB-Raid1-HDD, Traffic-Flat
    Node:
    78.46.117.9x | hos-tr2.ex3k4.rz7.hetzner.de