RS 8000 G9 mit nested-Virtualization: Windows-Installation hängt nach ~ 20 Sekunden

  • Hallo zusammen!


    Ich habe einen RS 8000 G9, bei dem nested-Virtualization (svm Flag) aktiviert wurde. Ich verwende Proxmox 7 und versuche derzeit, Windows 10 zu installieren.

    Sobald die Installation läuft, geht die CPU-Last auf 100% hoch und nach 20 Sekunden friert das ganze System ein (kurz nach der Wahl der Festplatte in der Windows-Installation).


    Kann ich davon ausgehen, dass das niemals stabil funktionieren wird, da der RS 8000 G9 ja selbst schon virtualisiert ist und - Nesting hin und her - das Ganze nie wirklich mich Bare-Metal vergleichbar ist. Ich habe natürlich die CPU auf "host" gesetzt und alles andere durchprobiert - immer mit gleichem Ausgang.


    Das Geld war vermutlich in den Sand gesetzt, oder?


    Grüße

    Lars-Daniel

  • Funktioniert nie 100%ig, gerade wenn man etwas anderes als einen Linux Gast virtualisieren will.

    Das habe ich mir schon gedacht. Offenbar gibt's dafür keine Testsuite, die man mal durchlaufen lassen kann... KVM sagt "alles tutti".


    Ist die Frist für die Nutzung der 30-Tage-Zufriedenheitsgarantie schon abgelaufen?

    Ja, lange. Ich muss gestehen, dass ich aus Zeitgründen mehrere Monate keine Zeit für das Projekt hatte. Seit Corona hat sich die Arbeit verdreifacht.


    Ich weiß gar nicht, wie teuer das ist und ob man das überhaupt separat kündigen kann. Aber immerhin klappt's es offenbar mit Linux-Gästen... hoffe ich jedenfalls.

  • Ich habe lange einen Proxmox mit LXC hier laufen gehabt. Das klappt wunderbar, wenn man nichts mit dem Kernel macht. Da brauchts dann auch keine nested virtualization.

    Klar, ich gebe Proxmox ja nicht die Schuld. LXC, Docker, Podman & Co. laufen hervorragend. Nur ich dachte, ich kann auch einige Windows-Sachen auslagern... Schade, muss ich wohl doch einen "echten" Real-Server dafür anschaffen oder mir einen Windows-Server basierten VPS suchen.

  • Okay, ich habe mich heute mal hingesetzt und habe ein paar Kombinationen probiert. Jeweils mit qemu 5.1 und qemu 6, was KEIN Unterschied gemacht hat.


    Debian Kernel v5.4 Kernel v5.10 Kernel v5.13
    Buster funktioniert funktioniert nicht funktioniert nicht
    Bullseye funktioniert funktioniert nicht funktioniert nicht


    • "Funktioniert" bedeutet, dass die CPU durchgereicht wird und das System sich wie "bare metal" verhält.
    • "Funktioniert nicht" bedeutet, dass die CPU(s) auf dem VPS auf 100% springen und das System nach wenigen Sekunden einfriert.

    Verwendete Kommandozeile:

    Code
    1. qemu-system-x86_64 -enable-kvm -cpu host,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time -smp cores=10 -drive file=./windows.img -m 8192 -usbdevice tablet

    Auch das weglassen der HyperV-Optimierungen ändert nichts.


    ich vermute stark, dass der neuer Buster-Kernel nicht mit dem (vermutlich älteren) Kernel des Netcup-Servers zusammenarbeiten kann? Leider gibt es auf meinem VPS dazu keine Kernel-Fehlermeldungen.


    Ein Nachtrag: Nicht nur Windows, auch Linux Guests sind betroffen! Ich kann nicht mal Debian in einem Guest installieren. Da muss also echt ein Kommunikationsproblem vorliegen. Ich schreibe mal den Support an.