Posts by klobi

    Noch nie das spiel/server benutzt aber vlt musst du das mal über steamcmd updaen?


    Lief es denn schonmal also konntest du rauf connecten?


    Wenn nicht vlt reicht dein CPU nicht aus dafür? Oder du hast irgendetwas falsch eingestellt. Am besten im arma3 forum fragen mehr weiß icha uch nicht

    Halloo


    Das mod_rewrite hat mich sehr interessiert, da man dadurch die URL's verschönern kann, jedoch habe ich Probleme damit es zum Laufen zu bringen und daher bitte ich euch um Hilfe!
    Alsoo ich habe eine .htaccess erstellt mit diesem Inhalt:


    #####################
    RewriteEngine on
    #RewriteBase /ordner/ <-- bringt auch nix
    RewriteRule .* index.php
    #####################


    Nun müsste ja wenn ich zb domain.com/ordner/abc.php eingebe, der mir domain.com/ordner/index.php anzeigen, denke ich.


    Ich sehe leider nur den Fehler " 404 /ordner/abc.php nicht gefunden" .
    Die index.php lädt selber schon..


    -Habe mehrmals apachectl graceful und apachectl restart gemacht bringt auch nichts.


    Kennt sich jemand damit aus?
    Ist Neuland für mich habe mir schon einiges zu durchgelesen jedoch klappt es ja nicht mal bei so einfach Sachen.. :(



    Systeminfo : Freebsd 11 , Apache24 , PHP7



    EDIT:


    <Directory /usr/local/www/apache24/data/mod_rewritetest>
    Options +FollowSymLinks
    AllowOverride All
    </Directory>


    Hatte das anders, jetzt klappt es ABERRR ne Frage warum hatte es vorher mit Options All nicht geklappt ?

    Ah danke wusste nicht dass der keys unterstützt. Jedoch habe ich keine Ahnung wie ich mich da su - root machen kann?
    ( hab ssh login für root aus ) . Als Alternative fällt mir ein crontab stündlich der alles kopiert (Logs) und mit Rechten versieht im Ordner vom normalo User.

    Hallo gibt es schon eine Anwendung/Möglichkeit Daten vom Server, zb Logs oder so, auf Android zu laden , also ne App halt?
    Vielleicht per PHP und cron?


    Oder müsste ich da selbst was zusammenbasteln?

    Also bei meiner Recherche kam raus, dass Linux , Debian standardmäßig zwar UFS im Kernel eingebaut ist,
    jedoch die "Dangerous" write Funktion für UFS nicht.
    Das liegt wahrscheinlich daran vermute ich.
    Wie man neuen Kernel kompiliert auf dem Rescuesystem usw weiß ich aber nicht also ging das nicht bei mir.


    Und ich habe doch rw (readwrite) statt nur r bzw ro (readonly) als -o Argument benutzt.


    Edit: Achso sehe es jetzt erst was du meinst,
    aber ich glaube dass ohne dieses -r der selbe Fehler kommt,
    also irgendwas mit wrong filesystem oder bad superblock in der Art.
    Kann es gerade aber nicht nochmal testen bin mir aber sicher dass es dann fehlgeschlagen hatte.
    Das weist ja darauf hin dass im Kernel das Schreiben auf eine UFS Partition nicht aktiviert ist.


    Aber schon merkwürdig. Man muss doch irgendwie drauf zu greifen falls man was falsch macht.
    Und die VNC Konsole hängt bei mir, weiß nicht warum.

    EDIT: Hatte ganz oben die Regel stehen:
    pass out quick all
    Jetzt geht das blocken der teamspeak 4players seite, jedoch ist nun direkt eine neue ip aufgetaucht mit dem Port 53 auch udp.
    Gehört wohl zu netcup, war vor dem Regeln zum Sperren der Ip von teamspeaks und dem entfernen der obigen Regel nicht da.


    Was ist das? Was wichtiges?


    Läuft btw über den Teamspeakuser diese connection.


    Und merkwürdigerweise ist netstat langsam.. Sockstat zeigt alles direkt an. Netstat braucht so um die 20 Sekunden.

    Achso ich dachte dass der browser dann beim Upload streikt, sodass nicht erst die Datei hochgeladen wird um die Größe zu checken. Das ist ja doof dann lieber javascript.



    Obwohl unterstützen Browser diesen Check nicht vielleicht? Die Antworten aus Stackoverflow sind ja schon 5-7 Jahre alt :D



    Dachte halt vielleicht braucht der Safaribrowser das in dem Form. Kann man ja kurz testen.

    Hab leider keine Iphones zum Testen.
    Kannst du es mal in der Form probieren, also das Feld MAX_FILE_SIZE vor deinem file Feld packen? Hab das so gelernt.


    Beispiel :
    <form method="post" action="upload.php" enctype="multipart/form-data">
    Datei:
    <input type="hidden" name="MAX_FILE_SIZE" value="100000">
    <input type="file" name="datei" size="40" maxlength="100000">
    <input type="submit" name="Submit" value="Senden">
    </form>



    Oder eventuell stimmt was in deiner Datei was nicht was die Daten empfängt
    Falls du PHP hast mach mal testweise print_r($_POST) und print_r($_FILES) in ne neue Datei zb uploaddebug.php und benutze die als Formular action. Dann siehst du ob das ankommt, ich weiß nicht was aspx genau ist aber sollte ja so ähnlich sein wie PHP.?


    Kannst du mit dem Iphone denn auf anderen Seiten hochladen?

    Ja stimmt genau das hatte ich eingegeben ^^




    Hmm habe das irgendwie durch parted rausgefunden glaube ich,


    ich habe die anderen schon probiert gehabt aber keines hat geklappt leider..


    ausserdem ist nachdem ich sda3 mounte das richtige filesystem gemountet, da meine dateien da sind, aber halt nur read kein write

    Achso ja stimmt dieses kenne ich noch nicht.. Ja ist neu und außerdem war das schon ganz Anfang so wo ich den Server bekam. Nur zwischendurch ging das mal schön schnell, aber vielleicht war das nur Glück ^^


    Und ja der Server ist jetzt per SSH Key gesichert, und kein root login möglich per SSH . Und Firewall läuft auch und Port ist net 22 :)

    Hallo ich habe einige Probleme mit der Firewall bei Freebsd. Ich verstehe das nicht wirklich und die Anleitung von freebsd.net hilft da auch nicht wirklich.


    Ich habe versucht alles zu blocken außer ssh und die Sachen wie Website , Email jedoch weiß ich nicht ob es geklappt hat, wie kann ich das denn auch richtig prüfen dass der Port nicht benutzt wird/werden kann?



    Ich habe PF benutzt aber schon zweimal mich ausgesperrt.. habe ssh in die services eingetragen


    pass out quick all


    pf.conf war das hier :



    pass out quick all
    tcp_services = "{ ssh, http, https }"
    block in all
    pass in quick inet proto icmp all
    pass in quick inet6 proto icmp6 all
    pass in proto tcp from any to any port $tcp_services


    und sobald ich pfctl -e gemacht hab war ssh weg , und musste über vnc ausmachen.


    Ich verstehe nicht was ich da falsch mache er sollte doch alles blocken was ja scheinbar funktioniert aber die Regel dass er die 3 durchlassen soll beachtet er nicht?



    Edit : Ups etwas sehr wichtiges vergessen ! pfctl -f /etc/pf.conf ... Er hat die falsche Konfiguration von davor gestartet ^^ so ,


    Aber jetzt würde gerne erfahren wie ich testen kann ob das funktioniert , also dass alles geblockt ist? Wie teste ich das? Vielleicht per cmd ping oder so?

    Hallo, ich versuche mich mit der VNC Konsole einzuloggen auf der VCP Seite, jedoch kann ich nur ein paar Buchstaben schreiben geht sehr schön gut gemacht , jedoch dann wird es unerträglich lahm ein Buchstabe braucht 10 Sekunden, so kann ich mich nicht einloggen, geschweige denn das Passwort eingeben, da passieren scheinbar Fehler wie dass paar Buchstaben nciht ankommen. Und dann noch das Sahnehäubchen dass ganze Teil verliert die Verbindung, drücke auf Reconnect passiert nix mehr... Ich hatte dieses Problem schon mal , ich weiß aber nicht was ich gemacht hatte um es wegzubekommen.
    Vielleicht einfach nur gewartet ^^


    Ist das normal??

    Also ich habe es jetzt hinbekommen aber habe nur Leserechte, benötige aber dringend Schreibrechte da ich einige Zeilen ändern muss in einer Konfigurationsdatei, ohne den Server selbst zu starten.


    Der Befehl bringt rein gar nichts :
    sudo mount -r -t ufs -o rw,ufstype=ufs2 /dev/sda3 /mnt/
    bzw ist wieder readonly..


    Wie mache ich das nun?

    Wie schaffe ich es auf meinem server auf dem freebsd einen key zu erstellen? Benutze putty btw muss dann den key in puttygen unwandeln oder?
    Aber ich hab halt null Plan wie es serverside funzt das einrichten. Ssh hab ich gemacht dass nur ich rinkann aver key wäre mir lieber .


    MfG

    Hallo irgendwie klappt das mounten Garnicht. Ich habees gemountet mit was hier steht Rettungssystem – netcup Wiki


    Habe freebsd am laufen.


    Im Rettungsmodus sehe ich per fdisk -l



    Disk /dev/sda: 257.7 GB, 257698037760 bytes
    255 heads, 63 sectors/track, 31330 cylinders, total 503316480 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00000000


    Device Boot Start End Blocks Id System
    /dev/sda1 1 20971519 10485759+ ee GPT



    wenn ich jedoch mount /dev/sda1 /mnt/ eingebe steht da :


    rescue:/# mount /dev/sda1 /mnt/
    mount: you must specify the filesystem type



    und es passiert nix.


    #mount /dev/vda2 /mnt/ klappt btw auch nicht, da in /dev/ noch nichtmal dieses vda ist sondern nur sda.


    Wie kann ich denn nun darauf zugreifen?


    Und ganz nebenbei mal gesagt wie wäre es wenn man den Wiki mal erweitern würde sodass wenigstens die Buchstaben stimmen