Posts by asteinberg

    Danke Leute, es läuft jetzt einwandfrei und ich bin auf dem neusten Stand :)

    Habe anstatt <Directory /var/www/> <Directory /var/> genommen, zusätzlich noch unter /etc/apache2/sites-enabled dasselbe eingetragen (war noch nach Apache 2.2 Art). Dann hatte ich den Fehler 500 bekommen, nach kurzem googeln unter folgendem Link den richtigen Text für .htaccess kopiert und es läuft jetzt!


    https://github.com/Laverna/laverna/issues/110


    Kämpfe jetzt mit dem upgrade von PHP. php -v zeigt:

    Code
    PHP 7.3.6-1+0~20190531112735.39+stretch~1.gbp6131b7 (cli) (built: May 31 2019 11:27:35) ( NTS )

    Froxlor zeigt jedoch immer noch 5.6.40-0+deb8u4. Wo könnte der Hacken sein?

    Schmeiß erstmal den ioncube Loader aus deiner PHP Config raus.

    Der 403 von heute morgen taucht da aber nicht auf. Haben vHosts bei dir extra error Logs?


    [Tue Jul 02 09:51:56.488847 2019] [mpm_prefork:notice] [pid 25192] AH00163: Apache/2.4.10 (Debian) PHP/5.6.40-0+deb8u4 configured -- resuming normal operations

    09:51 und Debian 8 (ggf. UTC Zeit) - passt das zusammen? Wenn nicht, bist du noch nicht vollständig auf Stretch.

    habe in der Dati 20-ioncube.ini im Ordner etc/php5 vor dem Text

    Code
    zend_extension = /usr/lib/php5/20100525/ioncube_loader_lin_5.4.so

    ein # gesetzt. Habe nichts anderes zu dem Ioncube gefunden.


    Von Apache-Logs habe ich access.log (sauber), error.log wie oben und other_vhost_access.log

    sorry, hatte im falschen Log geschaut. Das sind die Meldungen von heute seit dem Upgrade.

    In der apache2.conf steht bei mir:


    Code
    <Directory /var/www/>
            Require all granted
    </Directory>

    In diesem Ordner (var/www) sind Froxlor, PHPmyadmin etc. drin.


    Error log zeigt einige Zeile mit:

    Code
    "OPTIONS * HTTP/1.0" 200 126 "-" "Apache/2.4.10 (Debian) (internal dummy connection)"

    Froxlor sieht die aktuelle Apache-Version

    Tag. Habe genau den Anleitungen befolgt. Die Seiten auf dem Server sind zurzeit nicht erreichbar "You don't have permission to access / on this server.", Apache ist 2.4.25. Hier ist eine meiner Webseiten: richstaker.com. Debian ist jetzt 9.9, Froxlor zeigt jetzt die PHP 5.6.40 Version. Hättest Du ein Tipp für mich?

    Verwaltung ist mir ganz ehrlich zu teuer. Habe schon diverse Sachen selbst gemacht, nur ich weiß einfach nicht wie man mit den Systemen rumspielt. Eine einfache Anleitung/Tipps würden reichen. Das mit dem Betriebssystem ist mir bewusst. Es bleibt die Frage "wie"?


    Danke!

    Tag zusammen,

    leider haben mich die Suchfunktion und Google nicht weitergebracht. Habe zurzeit PHP 5.4.4-14+deb7u8 drauf, benötige jedoch eine neuere Version. Habe vServer mit Froxlor. Wie kann ich das kurz und schmerzlos machen? Außer paar älteren CMS läuft auf dem Server nichts.


    Danke!

    Ja, das war der Port! War irgendwie falsch eingegeben obwohl ich da nichts dran gemacht habe.
    Nur das Arbeiten mit der kyrillischen Domain funktioniert nicht. Bei Outlook wird das Konto noch nicht mal eingerichtet, bei Thunderbird funktioniert alles andere nicht.


    Danke vielmals!


    Für die die wie ich die Beiträge von hinten lesen um direkt die Lösung zu finden:


    1x Froxlor->Server->Konfiguration->die installierte Distribution auswählen->SMTP


    Alles machen wie beschrieben, keine Änderungen notwendig, außer, dass man das SQL-Passort (SQL-Froxlor-Passwort aus einer der ersten Mails von netcup).



    2x Froxlor->Server->Konfiguration->die installierte Distribution auswählen->IMAP



    Alles machen wie beschrieben, keine Änderungen notwendig, außer, dass man das SQL-Passort (SQL-Froxlor-Passwort aus einer der ersten Mails von netcup).


    Wenn es eine Meldung kommt:


    Code
    postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=



    Dann master-Datei ändern wie folgt:

    Code
    # Postfix 2.10 requires this option. Postfix < 2.10 ignores this.# The option is intentionally left empty. # smtpd_relay_restrictions =

    OK,
    IMAP scheint zu funktionieren. Ich kann mich einloggen, aber der MX-Eintrag wurde noch nicht übernommen und ich kann nicht testen ob ich mails empfangen kann.
    Aber SMTP:

    Code
    Senden der Nachricht fehlgeschlagen.Die Nachricht konnte nicht gesendet werden, weil der Verbindungsaufbau mit dem SMTP-Server 5.45.109.226 fehlgeschlagen ist. Der Server ist entweder nicht verfügbar oder lehnt SMTP-Verbindungen ab. Bitte kontrollieren Sie die SMTP-Server-Einstellungen und versuchen Sie es nochmals oder kontaktieren Sie Ihren Netzwerkadministrator.

    Genau das habe ich auch gemacht und seit dem habe ich diese Fehlermeldung.

    Code
    postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=



    Die Konfigurationen habe ich alle 1 zu 1 übertragen und nur die Passwörter eingesetzt.

    Habe jetzt einfach mal die Konfigurationen aus dem Froxlor angewendet (davor ehrlich gesagt nicht gemacht).


    Beim Restart von Postfix bekomme ich mehrfach diese Meldung:

    Code
    postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=




    Was heißt das?

    Also die Domain ist in Kyrillisch geschrieben, was als

    Code
    xn--80akhj1aedi7b.com

    entziffert wird. Da das Login dann auch kyrillische Zeichen enthält. hatte ich das mal mit kyrillischen Zeichen probiert, mal mit dem Umschreiben.


    Da das Problem daran liegen konnte, versuche ich einfach mal mit einer "normalen" Domain. Das klappt soweit aber auch nicht.