Posts by Lego

    In einem vHost gibt es grob geschätzt hunderte Fehlermöglichkeiten. Z.B. das die Subdomain nicht ordentlich in einem eigenen Kader liegt sondern durch einen Wildcardeintrag der Standarddomain abgedeckt wird. Stichwort Reihenfolge der inkludierten vHosts, etc.


    Wenn beim Aufruf der Standarddomain der Verzeichnisschutz abgefragt wird liegt die Wahrscheinlichkeit jedoch sehr hoch das nun mal Daten aus dem Ordner für welchen der Verzeichnisschutz eingerichtet wurde Daten enthält die geladen werden.


    Nochmal als Hinweis: Ein Verzeichnisschutz ist +immer+ Pfad bedingt, nicht Domain bedingt.


    Ich tendiere dazu, dass die Daten aus dem Ordner mit dem Verzeichnisschutz gezogen werden und dadurch der Schutz unwirksam wird.
    Danke für die Hilfe.

    Dann liegt entweder ein Fehler im vHost vor, oder unter der regulären Domain werden eben doch Inhalte aus dem Ordner der betroffenen Subdomain geladen. Das können nur Sie prüfen.


    Ja, die besuche werden abgefragt und die herkunft der Besucher.
    Wie genau kann den ein Fehler im vHost vorliegen ?

    Es kommt nicht auf die Domain an, sondern den Ordner. Offenbar wird über die reguläre "Homepage" etwas aus dem Pfad geladen für welchen der Verzeichnisschutz angelegt wurde, dann ist klar das die Abfrage kommt ;)

    Ich habe ja den schutz auf das Verzeichniss test aufgegeben.
    Es existiert eine Subdomain test.domain.de diese Subdomain ist für das Verzeichniss test angelegt.
    Wenn ich aber auf die haupt Domain gehe, kommt schon die Abfrage nach den Daten !!!
    Das sollte ja nicht der Fall sein.
    Ich habe noch ein Verzeichniss z.B das nennt sich test2 und dafür habe ich keine Subdomain und der Verzeichnissschutz funktioniert perfekt !
    Nur auf dem Verzeichniss nicht, wo eine Subdomain existiert.


    Ich habe in dem Verzeichniss test ein Script was die Besucheranzahlen aus meiner Hauptdomain ausliest.
    Und auf der Hauptdomain liegt ein Forum.

    Hallo,
    undzwar habe ich ein verzeichniss Namens test.
    Für dieses Verzeichniss habe ich eine Subdomain angelegt: test.domain.de
    Ich möchte, dass das Verzeichniss aber geschützt wird.
    Schön und gut, ich schütze das Verzeichniss dann wird die Abfrage schon auf der Startseite bzw. der Hauptdomain: domain.de angezeigt.
    Es lässt sich zwar weggklicken, aber es kommt jedes mal.


    Wie löse ich das Problem ?


    Gruß.

    Poste die my.cf mal hier.

    Also, wenn ich die Zeile mit SKIP entferne, sollte es Theoretisch gehen ?
    Ich finde folgende Zeile mit SKIP:

    PHP
    # Instead of skip-networking the default is now to listen only on

    Da hätte dir Google aber auch geholfen: MySQL für externen Zugriff konfigurieren @ huschi.net ;)



    MfG Christian

    Das Tutorial habe ich auch gesehen, leider hatte ich beim 2. Punkt folgenden Fehler:
    ERROR 1044 (42000): Access denied for user 'forumsql1'@'localhost' to database 'mysql'


    Aber wenn ich mysql -uforumsql1 -p forumsql1 eingebe dannach das Passwort, geht es.
    Nach diesem Punkt:
    update user set host='%' where user='huschi';


    Bekomme ich folgenden Fehler:
    ERROR 1146 (42S02): Table 'forumsql1.user' doesn't exist

    Hallo,
    undzwar würde ich gerne meinen MySQL Server nach außen erreichbar machen.
    Ich würde nähmlich gerne Navicat nutzen um meinem MySQL Server zu verwalten.
    Leider ist mir nicht bekannt wie ich das einstelle.


    Gruß,
    Lego

    Ahso meinst du das... Ich habe phpmyadmin runtergeladen und dann hochgeladen auf meinen FTP.
    Wie installiere ich denn die PHP Erweiterung ?


    @ Dragon, dafür habe ich jemanden, der mir das macht. Sonst komme ich ja eigentlich klar ;) Ich weiß nur leider nicht wie ich Mcrypt installiere und in die php.ini einfüge, da ich es noch nie gemacht habe.

    Ich vermute du suchst das Paket php5-mcrypt. phpMyAdmin könntest du übrigens auch direkt über die Paketverwaltung installieren :)



    MfG Christian


    Wirklich, wo finde ich denn die Paketverwaltung ?
    Ich habe einfach apt-get install mcrypt in die konsole geschrieben, das hat ja anscheinend gereicht, oder nicht ?


    Gruß.

    Hallo,
    undzwar habe ich soeben apt-get install mcrypt eingegeben, somit mycrypt installiert.
    Da man Phpmyadmin selbst hochladen und bei Froxlor eintragen muss, habe ich das getan.
    Phpmyadmin sagt mir aber, dass die Erweiterung mcrypt fehlt und ich sie in die php.ini eintragen muss.
    Wo genau finde ich die php.ini und was muss ich dort eintragen ?


    Gruß.

    Hallo liebes Netcup Team,
    Als ich einen Verzeichnisschutz angelegen wollte, bekam ich den Fehler bei der Benutzer Erstellung, dass der Benutzer schon existiert.
    Leider wird der Benutzer aber nicht auf der Benutzerliste aufgelistet.
    Woran liegt das ? Wie kann ich den User löschen ? Ja, ich hatte den User vorher angelegt, aber leider ist er nicht auf der Benutzer Liste.


    Gruß,
    Taros