Posts by Encore

    Bei 587 wirst du evtl. Parameter in der main.cf anpassen müssen.

    z.B. den smtp_tls_wrappermode abschalten.

    hat geklappt!!! :D

    ich danke euch beiden herzlichst x)

    weiß zwar immer noch nicht, was für vorteile ich von 587 vs 465 habe, aber wird schon seine gründe haben - müsste ich mal nach googeln was die unterschiede genau sind haha

    Ich würde eher 587 nutzen (StartTLS) - aber wie heißt es so schön: never change a running system.

    Da es jetzt funktioniert, würde ich den Port so lassen.

    hat es im home Bereich (nichts produktives) irgendwelche sicherheitsnachteile direkt 465 statt startTLS zu nutzen? habe den unterschied zwischen den beiden varianten noch nicht so ganz kapiert :) ind en meisten Anleitungen nutze ich direkt 465 statt 587 - bisher ohne für mich erkennbare nachteile


    edit:

    hab mal testweise auf 587 gestellt und via postmap bearbeiten lassen (die passwd) sowie neustart


    Code
    1. Aug 10 13:28:19 proxmox postfix/smtp[87653]: warning: TLS library problem: error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../ssl/record/ssl3_record.c:331:
    2. Aug 10 13:28:19 proxmox postfix/smtp[87653]: D28913E1173: to=<meine@email.tld>, relay=mx2ea2.netcup.net[91.204.46.162]:587, delay=0.05, delays=0.01/0.01/0.03/0, dsn=4.7.5, status=deferred (Cannot start TLS: handshake failure)

    kriege aber jetzt nen handshake error (rein zum "testen" gerade mal probiert)

    hab nach einer passwortänderung vergessen neu zu hashen also dein punkt "durch postmap behandelt" - nun funktioniert es :D


    wegen dem port, würdest du eher 587 oder 465 nutzen?


    aber um deine frage noch zu beantworten:


    Code
    1. nano /etc/postfix/sasl_passwd
    2. [mx2ea2.netcup.net]:465 meine@email.tld:meinpw

    hab jetzt via header_checks noch den "send from" abgeändert da sonst alles unter "Root <meine@email.tld" reinkam :D


    Code
    1. root# nano /etc/postfix/header_checks
    2. /^From:[[:space:]]+(.*)/ REPLACE From: "Proxmox-Home" <[email='meine@email.tld'][/email]>
    3. root# cd /etc/postfix
    4. root# postconf -e 'smtp_header_checks = regexp:/etc/postfix/header_checks'

    danach noch postfix neugestartet

    nun scheint alles zu klappen, emails kommen an :)

    Hey zusammen,


    würde gerne für meinen Proxmox Homeserver Postfix via Relay nutzen, als Email dient ein Webspace hier bei Netcup.


    Meine main.cf:


    Postfix service neugestartet usw.

    via echo "Test mail from postfix" | mail -s "Test Postfix" meine@email.tld ein test geschickt


    im mail log sehe ich allerdings dann, dass die ip meines anschluss bei spamhaus geblockt ist - ist ja auch verständlich, da "dialup ip" :D

    frage ist allerdings, krieg ichs irgendwie hin, dass ich den email dienst von proxmox aus dem home bereich trotzdem nutzen kann ?:/

    Mein Ziel ist, dass Status Emails von Proxmox mir per email zugestellt werden, wenn ich zb unterwegs bin :)

    falls relevant: telekom (dial up IP)


    alternativ besteht noch ein gmail account - falls google nicht so "pingelig" sein sollte:D

    mit Datacenter ist das oberste " Rechenzentrum" gemeint, nicht den Node / VM - ja ?


    Sehe dort allerdings nur die Möglichkeit als Aktion Accept / Drop / Reject zu wählen, wüsste nicht was ich z.B: bei Interface / quelle / Ziel reinschreiben müsste um zum ergebniss zu kommen, dass die netze untereinander nicht kommunizieren dürften.


    hätte jetzt IN - drop - quelle 192.168.178.0/24 gemacht als auch OUT und das ganze dann umgekehrt für das 10.0.0.0/24 - wäre das the way to go?


    Falls alle stricke reißen mit dem aussperren, bestünde ein Monitor und via shell kann ich die firewall deaktivieren im fall der fälle :) - aber den "stress" will ich mir sparen haha (Monitor rauskramen, an stöpseln samt Tastatur usw)


    Entschuldige mich schonmal für etwaige Dumme Fragen, ist für mich auch gerade ein wenig lernen für die Zukunft :) durch "Google" bin ich nicht sonderlich schlau geworden, da finde ich deine Hilfestellung gerade echt am angenehmsten umzusetzen

    Wenn ich z.B. in einer Spielwiese irgendwelche Daten liegen hätte , auf die man dann zugreifen könnte oder ähnlich, vl ist das bisschen mit Kanonen auf Spatzen geschossen, bin da vielleicht auch ein wenig paranoid :D


    wenn ich zb eine windows VM nutze (hab einen m1 mac) dort dann auch paar sensiblere daten (jetzt nicht lebensnotwendig, aber datenschutzgemäß sensibel) liegen hätte, nicht dass jmd zb in den TS LXC einbricht und sich dann zugriff zu der windows VM beschafft und dort alle daten klaut oder so ( wiegesagt, bisschen paranoid, aber ich denke mal so "sicherheitsbewusst" zu denken oder sich zumindest Gedanken zu machen, ist nicht schlimm


    hab Variante 1 am laufen, der LXC hat jetzt die ip 10.0.0.2 und kann auch nach draußen pingen vom 192 XX netz klappt der ping ins 10.XXX netz und umgekehrt.


    lediglich das mit den IPtables hab ich noch nicht raus, geht das mit der GUI oder muss ich das über die proxmox shell regeln? (Die netze jeweils gegeneinander nicht erreichbar zu machen (privat + vms)

    dann müsste ich für jede bridge ein neues netz erstellen und das dann auch in der fritte immer hinzufügen als route, richtig?

    das klingt gut, ich baus gleich mal nach :D


    also quasi nur eine neue bridge erstellen - im ip4 feld 10.0.0.1/24 eintragen (gateway leer lassen)


    dann den VMs manuell 10.0.0.2 -3 -4 -5 usw zuweisen, eine route in der fb erstellen und am proxmox knoten via firewall / ip tables dann die regeln festlegen ? (muss mich mal mehr mit iptables auseinandersetzen *würg*


    sysctl -w net.ipv4.ip_forward=1 natürlich vorher setzen am proxmox.




    edit: wäre es vl auch einfacher möglich, den proxmox host an LAN4 zu hängen der Fritzbox, welcher in den Fritzbox settings als "Gastnetz" genutzt wird? - der dürfte ja dann auch im eigenen netz unterwegs sein ? (sofern ich dann noch eine portweiterschaltung setzen kann) --- das dürfte doch zum selben ergebniss führen, außer , dass die VMs untereinander kommunizieren können ? *rein informativ*


    Quote

    Gastzugang

    Hier ermöglichen Sie Ihren Gästen schnell und sicher einen Zugang zum Internet. Aktivieren Sie die Option "Gastzugang für LAN 4 aktiv" und schließen Sie das Gastgerät an die Buchse "LAN 4" an Ihrer FRITZ!Box an. Die mit dem "LAN 4"-Anschluss verbundenen Geräte nutzen lediglich den Internetzugang, haben aber keinen Zugriff auf Ihr Heimnetz.

    Gastzugang für LAN 4 aktiv

    Hey zusammen,


    kurze Frage - vielleicht steh ich auch einfach auf dem Schlauch :)


    Habe einen A300 (3400g, 16gb ram, 500gb nvme, 1x 1gbit nic) zuhause, auf dem ein MC Server, TS³ Server und diverse "spielwiesen" laufen.


    der MC und TS sind via Port Weiterleitung an der Fritzbox 7590 via meine subdomain (myfritz dynds + cname record meiner domain) von außerhalb erreichbar.


    nun möchte ich allerdings verhindern das SOLLTE sich mal jemand in einen LXC / KVM "hacken" - zugriff bekommen, er nicht auf mein restliches heimnetz kommt, aktuell kann ich von dem minecraft container (192.168.178.201 (200 ist der Proxmox) ) meinen mac / windows pc (192.168.178.2 (192.168.178.1 ist die fritzbox) ) anpingen.


    mein ziel wäre , dass die KVMs / Container nach draußen funken können, auch von draußen erreichbar sind via meine subdomain ABER ich nicht vom container / kvm mein "heimnetz" selbst erreiche / anpingen kann usw. >EDIT(außer ich würde z.B. eine Wireguard KVM oder so erstellen)<


    Wie ist da die vorgehensweise? (ambesten detailiert erklärt zum nachbauen / verstehen :) )


    Aktuell war die idee, dass ich eine neue bridge (vmbr1) erstelle, die dann z.B. die ip 10.0.0.1 /24 gebe den anderen vms dann 10.0.0.2 usw und in der fritzbox eine route einstelle?

    Aber dann hätte ich ja wieder das problem, dass ich die zwei netze irgendwo verbinde miteinander?


    hab den dreh mit vlan tags usw noch nicht ganz raus :) der proxmox selbst soll von außerhalb nicht erreichbar sein (Port in der Fritzbox ist nicht freigegeben).


    edit2: wäre durfte, wenn ich das alles über die mittel von Proxmox lösen könnte :) ohne eine pfsense aufsetzen zu müssen (doppelts nat? )


    Telekom ; 250 Mbit/s down 47 UP // SVDSL // Fritzbox7590

    Hey Leute,


    musste in meinem Postfach heute mittag diese Nachricht feststellen:

    nun stelle ich aber fest, das unter dem genannten port 19311 ich aber nichts am laufen hab oO

    der server wird mit nem centoswebpanel betrieben (nur dns, mail und website + ts3) - mehr läuft da nicht drauf.


    erste mal dass mir sowas passiert ist, gibt es jetzt etwas bestimmtes zu beachten?

    das ganze ist eige sehr unbekannt - die website / ts wird nur von mir und paar kumpels verwendet - wovon aber niemand das wissen hätte, nen ddos zu starten :)


    wie würdet ihr jetzt vorgehen?

    lg


    edit:

    habe mal geguggt woher zb ip : 200.34.142.185 kommt (mexico) ...

    gibts echt leute auf der welt - die random leute ddosen?^^


    meine betroffene ip ist auch nicht die "haupt" ip sondern eine zusätzlich gebuchte von netcup.

    Sobald ich die zeit hab, mach ichs nochmal bisjen detailierter :)


    https://administrator.de/wisse…fsense-tunnel-567618.html


    hat mir sehr viel geholfen, dabei wurde aber auf richtige nics ausgegangen.


    ich habe es mit reinen virtuellen nics gemacht, da gabs paar fallstricke die man beachten muss X)


    nen ganz kleinen vps + ne zusätzliche ip, so hat man für kleines geld ne funktionierende feste ip im heimnetz :D


    angenehmer als 70euro + bei telekom für nen dlan voice/data..


    auch reversedns alles klappt wunderbar!

    mit lfd/csf noch den vps "abgesichert", alle dienste bis auf den linux tunnel deaktiviert, ssh deaktiviert (komme auch über die netcup shell rein), so kann das ganze auch relativ problemlos dauerhaft laufen, firewall wird in der VM in proxmox dann gemacht x)


    mitlerweilee erreiche ich auch im speedtest von meinen 250mbits down und 42 up den kompletten anschlag :D

    keine verringerung der bandbreite bei mir feststellbar.

    lediglich pingzeiten is durch die paar hops mehr im route bisjen höher. aber 31ms halte ich für akzeptabel gegenüber dem preisersparnis hehe


    wichtig ist halt, die IP des WANs zuhause im GRE host zu ändern, falls man zuhause ne neue ip zugeteilt bekommt, das lässt sich mittels Script wie im link beschrieben bewerkstelligen, habs nur noch nicht hinbekommen, vl hat da jmd ne anleitung für mich zum umsetzen haha


    tu es aktuell manuell anpassen bei nem reset. über nen gre update

    ps:

    bin ich froh, wenn sich ipv6 wirklich durchgesetzt hat und auch rpivatleute nen ipv6 netz bekommen..

    dann wäre nat usw. endlich geschichte.. und solche bastellösungen gehören der vergangenheit an

    auch dieses problem wurde gelöst...


    da ich pihole als dns resolver nutzte, hab ich dort noch nen custom dns eintrag veranlasst, der zb. srv1.meinedomain.tld auf die interne ip des servers (192.168.1.2) weiterleiten lässt.


    ein zugriff aus dem WAN heraus, klappt wunderbar (kein nat loopback).

    somit klappt jetzt alles zu 100% wie ichs mir vorgestellt habe =)


    möchte mich bei allen nochmal bedanken für den tipp mit der MTU und dem GRE port freigeben in der fritte! *happy*

    Ich stehe jetzt nur vor dem problem, dass ich aus dem Lokalen LAN der Fritte etc. nicht auf die externe ip komme zb 123.456.789.0:2031


    Vom Smartphone oder Tablet über LTE geht es allerdings ohne Probleme, lieg ich mit Hairpin richtig?

    Wenn ja wie kann ich das ambesten lösen so dass ich auch aus dem lokalen netz drauf zugreifen kann