SMTP-Fehler 452 - Angeblich zu wenig Speicher? - Mailcow/Roundcube

  • Guten Abend zusammen,


    ich habe folgendes Problem: mein SMTP spuckt mir seit heute folgende Fehlermeldung aus (siehe Screenshot SMTP-Error-452).


    Dieser Fehler wird beim versuchten versenden einer Mail angezeigt. An sich ist die Meldung aussagekräftig. Irgendwo ist zu wenig Speicher vorhanden.


    Allerdings stellt sich mir die Frage, wo finde ich den Ort, welcher zu wenig Speicher hat?


    Ich weiß, dass Mailcow mitunter in dem Verzeichnis /var/www/mail Dateien ablegt. Laut der Ausgabe von "du -hs /var/www/mail/" belegt das Verzeichnis gerade mal 24 MB. Wo liegen die anderen Dateien und um welche handelt es sich? Welche kann ich löschen um Speicherplatz zu erhalten?


    Laut dem Management-Webinterface hat der Server zudem nur 5,28 GiB zugewiesen bekommen (siehe Screenshot Webinterafce)? Ich habe versucht, dass Verzeichnis via dem Befehl "resize2fs -p /var/www/mail 15G auf 15 GB aufzubohren. Vergeblich. Hat jemand eine Idee, wie ich der Anwendung mehr Platz zuordne? Muss ja nicht sein, dass diese mit so wenig auskommen muss, wenn ich ca. 40 GiB für die Anwendung kalkuliert habe...


    Vielleicht hat jemand eine Idee oder so ein ähnliches Problem schon mal gehabt. Über eure Hilfe wäre ich echt dankbar. Sollte was unklar sein, einfach fragen.


    Beste Grüße und einen guten Start in die Woche

    Simon

  • Nicht nur die Byte zählen, auch die Inodes können volllaufen. Wie viele sind davon noch frei? (df -i)


    Falls die Partition nicht die volle Größe Deiner virtuellen HDD nutzt, findest Du nachfolgend Tipps zur Vergrößerung.

    Vorher unbedingt ein Backup erstellen! Viel Erfolg.

  • Du hast einen Managed Server, Webhosting, etc?


    Unter /var/www befinden sich Dateien vom Webserver.


    Wenn du einen Shell-Zugang hast, dann siehst du doch wo der Speicerplatz knapp wird? Im Zweifelsfall sprich den Support bzw. deinen Admin an, der sollte das Problem mit Basis-Wissen von Linux erkennen können und dir entsprechende Vorschläge machen.

  • Hey, danke Dir für deine schnelle Antwort!

    Ich hab den Befehl gerade mal abgesetzt. Die Ausgabe sagt folgendes:


    Dateisystem Inodes IBenutzt IFrei IUse% Eingehängt auf

    /dev/sda3 360448 125660 234788 35% /

    udev 505473 331 505142 1% /dev

    tmpfs 507572 463 507109 1% /run

    tmpfs 507572 1 507571 1% /dev/shm

    tmpfs 507572 9 507563 1% /run/lock

    tmpfs 507572 13 507559 1% /sys/fs/cgroup


    Ich würde mal sagen genug. Demnach kann es an den INodes nicht liegen würde ich vorerst behaupten?


    Tatsächlich nutzt mein vServer nicht die volle vHDD. Sehr interessant. Das werde ich gleich direkt mal vergrößern. Danke für den Tipp.

  • Update: ich habe es hinbekommen. Auf die richtige Idee hast du mich gebracht killerbees19. Danke Dir dafür. :-)


    Tatsächlich lag es daran, dass mein sda3-Verzeichnis, auf dem sich meine Anwendungen befinden, wie in dem Screenshot zu sehen, nur 5 GiB groß ist. Die sda4 hatte um die 70 GiB. Diese lagen nicht zugewiesen einfach rum. Diese Partition habe ich gelöscht und in meine sda3 reingebügelt. Siehe da, es läuft.


    Danke für eure Hilfe. Immer wieder schön zu sehen, dass auch wenn man gerade aus der Ausbildung als Informatiker draußen ist, man nie auslernt. :-)