Posts by Lundu

    Moin!


    danke vorerst für den Link. Das heißt, ich ziehe die Kiste mal ASAP nach oben.


    Die Frage war ja nach dem apt-Log um zu prüfen, was mit den Paketquellen passiert. Da habe ich nichts gefunden was irgendwie stören könnte. Klar, an sich loggt der Server die Mail.logs unter /var/log. Wo er aber die error-Meldungen hinschiebt muss ich mal prüfen.

    Quote

    Du hast einen vServer von 2017, nutzt Debian 7 - für welches es seit dem 31.05.2018 keinen Support mehr gibt?

    Ich empfehle dir hier ein Update auf Debian 9.

    Lol, danke, für den Hinweis! Ich dachte, 7 wird erst 2019 abgekündigt? oO


    Ein klassisches Linux-Update ist für mich das Updaten der Pakete --> apt-get update && apt-get dist-upgrade. Das Log gibt keinerlei Fehler aus und es sind alle Prozesse gestartet die gestartet sein müssten.


    Quote


    Sollte man dann einen Mailserver betreiben?

    Gute und leicht provokante Frage! Die Antwort ist ganz klar ja. Grund: auch wenn ich Sysadmin von Beruf und Student der angewandten Informatik bin, weiß ich nicht alles. Wissen erlangt man durch zuhören, lesen oder eben ausprobieren. Jeder der mir erzählt er könnte alles, den stopfe ich pauschal in eine Schublade und setze einen Stempel drauf. Da ich nun mal nicht alles weiß und mich eher in dem Bereich Virtualisierung und Storage auskenne muss ich eben fragen. ;-)

    Hallo zusammen,


    zu meiner Situation: ich habe einen vServer (Debian Version 7) auf dem ein SMTP mit der Oberfläche Roundcube läuft. Auf dem Server greifen insgesamt drei Personen zu, welche ihre Postkörbe dort liegen haben.


    Zu meinem Problem: ich habe heute ein klassisches Linuxupdate gefahren und musste den Server aufgrund einer Aufforderung im SCP (neue KVM-Version) neu booten. Vorerst kam die Meldung, dass angeblich kein Zugriff mehr auf meine Datenbanken besteht. Dies konnte ich zurecht biegen. Nun habe ich ein weiteres Problem. Nach dem schreiben einer Mail, also wenn ich diese versenden will, kommt folgendes: "SMTP Fehler: [451] 4.3.0 Error: queue file write error" (siehe auch nochmal Screenshot)

    Hat jemand eine Idee, was es damit auf sich hat?


    Bis dato habe ich folgendes getan:

    Klar, erstmal googlen. Rausgefunden habe ich, dass angeblich das Limit meiner Nachrichten erreicht sei?! Wtf sowas haben ich nicht konfiguriert. Bei Hotmail oder so mag das Sinn machen, damit kein Spam versandt wird, aber bei meinem Server? Also habe ich weiter geschaut. In einem Forum wurde ich dazu aufgefordert meine Speichernutzung zu checken via df -h, df- i und df. Das kam dabei rum:
    Hätte mich auch gewundert wenn die voll wäre.



    Wie man sieht, platz ist genug da, wo liegt das Problem? Also weiter gegoogelt. Möglicherweise liegt es an SpamAssassin. Ich weiß, dass ich SpamAssassin als Filter einsetze, aber hab es nie konfiguriert. Wenn ich mich recht entsinne kommt das mit Roundcube mit? Ebenso las ich, dass ein MX-Record hilft. Hab ich auch.


    Fazit:

    Hat irgendjemand eine Idee, woran das liegen könnte? Da ich mich generell nicht wirklich in der Welt der Mailserver auskenne wäre ich um Rat dankbar. Bei Fragen einfach fragen.

    Ich bin für jede Hilfe dankbar.


    Beste Grüße

    Simon :)

    Update: ich habe es hinbekommen. Auf die richtige Idee hast du mich gebracht killerbees19. Danke Dir dafür. :-)


    Tatsächlich lag es daran, dass mein sda3-Verzeichnis, auf dem sich meine Anwendungen befinden, wie in dem Screenshot zu sehen, nur 5 GiB groß ist. Die sda4 hatte um die 70 GiB. Diese lagen nicht zugewiesen einfach rum. Diese Partition habe ich gelöscht und in meine sda3 reingebügelt. Siehe da, es läuft.


    Danke für eure Hilfe. Immer wieder schön zu sehen, dass auch wenn man gerade aus der Ausbildung als Informatiker draußen ist, man nie auslernt. :-)

    Files

    • Fertig.png

      (8.43 kB, downloaded 15 times, last: )

    Hey, danke Dir für deine schnelle Antwort!

    Ich hab den Befehl gerade mal abgesetzt. Die Ausgabe sagt folgendes:


    Dateisystem Inodes IBenutzt IFrei IUse% Eingehängt auf

    /dev/sda3 360448 125660 234788 35% /

    udev 505473 331 505142 1% /dev

    tmpfs 507572 463 507109 1% /run

    tmpfs 507572 1 507571 1% /dev/shm

    tmpfs 507572 9 507563 1% /run/lock

    tmpfs 507572 13 507559 1% /sys/fs/cgroup


    Ich würde mal sagen genug. Demnach kann es an den INodes nicht liegen würde ich vorerst behaupten?


    Tatsächlich nutzt mein vServer nicht die volle vHDD. Sehr interessant. Das werde ich gleich direkt mal vergrößern. Danke für den Tipp.

    Guten Abend zusammen,


    ich habe folgendes Problem: mein SMTP spuckt mir seit heute folgende Fehlermeldung aus (siehe Screenshot SMTP-Error-452).


    Dieser Fehler wird beim versuchten versenden einer Mail angezeigt. An sich ist die Meldung aussagekräftig. Irgendwo ist zu wenig Speicher vorhanden.


    Allerdings stellt sich mir die Frage, wo finde ich den Ort, welcher zu wenig Speicher hat?


    Ich weiß, dass Mailcow mitunter in dem Verzeichnis /var/www/mail Dateien ablegt. Laut der Ausgabe von "du -hs /var/www/mail/" belegt das Verzeichnis gerade mal 24 MB. Wo liegen die anderen Dateien und um welche handelt es sich? Welche kann ich löschen um Speicherplatz zu erhalten?


    Laut dem Management-Webinterface hat der Server zudem nur 5,28 GiB zugewiesen bekommen (siehe Screenshot Webinterafce)? Ich habe versucht, dass Verzeichnis via dem Befehl "resize2fs -p /var/www/mail 15G auf 15 GB aufzubohren. Vergeblich. Hat jemand eine Idee, wie ich der Anwendung mehr Platz zuordne? Muss ja nicht sein, dass diese mit so wenig auskommen muss, wenn ich ca. 40 GiB für die Anwendung kalkuliert habe...


    Vielleicht hat jemand eine Idee oder so ein ähnliches Problem schon mal gehabt. Über eure Hilfe wäre ich echt dankbar. Sollte was unklar sein, einfach fragen.


    Beste Grüße und einen guten Start in die Woche

    Simon

    Hallo zusammen,


    ich besitze momentan einem vServer mit Debian Jessie auf welchem ein SMTP-Server mit Mailcow und eine Nextcloud läuft. Das Problem welches ich beschreibe betrifft den Mailserver.
    Ich kann an jeden Anbieter Mails senden. Diese werden auch zugestellt bis auf an Hotmail/Outlook. Kurz an Microsoft. Sobald ich die Mail versende, kommt eine Mail zurück mit dem Betreff "Undelivered Mail Returned to Sender" und folgendem Inhalt:



    Reporting-MTA: dns; mail.xy.eu

    X-Postfix-Queue-ID: 4F50720B30

    X-Postfix-Sender: rfc822; simon@xy.eu

    Arrival-Date: Wed, 21 Jun 2017 14:39:24 +0200 (CEST)Final-Recipient: rfc822; ali_k....@hotmail.com

    Original-Recipient: rfc822;ali_k....@hotmail.com

    Action: failed

    Status: 5.0.0

    Remote-MTA: dns; mx4.hotmail.com

    Diagnostic-Code: smtp; 550 SC-001 (COL004-MC4F50) Unfortunately, messages from

    46.XY.XY.179 weren't sent. Please contact your Internet service provider

    since part of their network is on our block list. You can also refer your

    provider to http://mail.live.com/mail/troubleshooting.aspx#errors.



    Der Link verrät mir nur, dass ich mich an meinen Serverprovider melden soll. Netcup kann sich aber nicht wirklich einen Reim darauf machen und mir wohl auch nicht helfen.


    Weiß jemand was ich ändern muss damit die Mails zugestellt werden? Empfangen kann ich diese ohne Probleme. SPF und DKIM-Records im DNS sind gesetzt und werden laut diversen Testwebsites auch anerkannt. Hat irgendwer eine Idee?



    Anbei ich bin Informatiker in Ausbildung und hätte - sofern Möglich auch den technischen Hintergrund erklärt. :)


    Liebe Grüße

    Simon