500er Error - PHP-FPM

  • Servus, ich habe aktuell folgendes Problem
    Ich wollte PHP-FPM für meine Froxlor Installation freischalten und einrichten, nun habe ich folgendes Problem dass ich immer wieder einen 500 Internal Server Error erhalte.
    Fehlermeldung im Log:


    Code
    1. [Wed Jun 25 20:03:33 2014] [error] [client 178.115.131.175] (2)No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/froxlor.panel/xy/4163.fpm.external": connect() failed, referer: http://xy/froxlor$
    2. [Wed Jun 25 20:03:33 2014] [error] [client 178.115.131.175] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/froxlor.panelxy/4163.fpm.external", referer: http://xy/froxlor/admin_index.php?s=54ced79$



    Code
    1. [25-Jun-2014 19:38:52] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful
    2. [25-Jun-2014 19:38:52] NOTICE: fpm is running, pid 24869
    3. [25-Jun-2014 19:38:52] NOTICE: ready to handle connections
    4. [25-Jun-2014 20:02:30] NOTICE: Finishing ...
    5. [25-Jun-2014 20:02:30] NOTICE: exiting, bye-bye!
    6. [25-Jun-2014 20:02:30] ERROR: No pool defined. at least one pool section must be specified in config file
    7. [25-Jun-2014 20:02:30] ERROR: failed to post process the configuration
    8. [25-Jun-2014 20:02:30] ERROR: FPM initialization failed


    lg.
    Alex

    [size=10]

    "This is Linux land. In silent nights you can hear the Windows machines rebooting."


  • Leider habe ich den Include bereits gesetzt und dennoch funktioniert auch ein Neustart von PHP-FPM nicht.


    lg.
    Alex

    [size=10]

    "This is Linux land. In silent nights you can hear the Windows machines rebooting."


  • In dem Ordner befinden sich keine Dateien.


    libnss-mysql-bg ist installiert und konfiguriert.


    lg.
    Alex

    [size=10]

    "This is Linux land. In silent nights you can hear the Windows machines rebooting."


  • wenn in dem ordner keine Dateien sind, ist entweder der falsche Ordner eingebunden, oder froxlor hat die Dateien noch nicht bzw nicht richtig erstellt.


    im pool Ordner muss für jede Domain eine .conf datei sein.


    Ist der cronjob richtig durchgelaufen?

  • Der Cronjob läuft ohne Probleme durch.


    Ich habe bis jetzt keine Domain hinzugefügt, das einzige das momentan nicht funktioniert ist das Backend von Froxlor.


    lg.
    Alex

    [size=10]

    "This is Linux land. In silent nights you can hear the Windows machines rebooting."


  • aso.


    hast du denn einen froxlorlocal User erstellt und in den Froxlor Einstellungen denn die Option angehakt, dass Froxlor einen eigenen vhost bekommen soll bzw ebenfalls unter eigenem User von fpm aufgeführt werden soll?

  • Ich denke das mit dem eigenen vHost könnte ich vergessen haben.
    Kann ich dies irgendwie überprüfen ohne dass ich auf Froxlor selbst zugreifen muss bzw. auf das Webinterface (da dieses ja nicht funktioniert)


    lg.
    Alex

    [size=10]

    "This is Linux land. In silent nights you can hear the Windows machines rebooting."


  • in der Mysql Datenbank kannst du dies nachprüfen in der Tabelle panel_settings


    Um dies zu beheben müsste folgendes ausreichen


    User erstellen mit

    Froxlor Wiki wrote:

    addgroup --gid 9999 froxlorlocal
    adduser --no-create-home --uid 9999 --ingroup froxlorlocal --shell /bin/false --disabled-password --gecos '' froxlorlocal

    Dann per mysql ausführen


    SQL
    1. UPDATE `froxlor`.`panel_settings` SET `value` = '1' WHERE `panel_settings`.`settingid` = 73;
    2. UPDATE `froxlor`.`panel_settings` SET `value` = 'froxlorlocal' WHERE `panel_settings`.`settingid` = 74;
    3. UPDATE `froxlor`.`panel_settings` SET `value` = 'froxlorlocal' WHERE `panel_settings`.`settingid` = 75;



    dann cronjob ausführen


    Code
    1. /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force
  • Ich habe den Server nochmals neu installiert und verwende nun nginx. Ist aus Performance und Sicherheitsgründen nach genauerem überlegen doch die bessere Wahl.
    Nun funktioniert alles bis auf den CronJob den man für Froxlor anlegen muss nicht. Wenn das Skript das alle 5 Minuten aufgerufen wird manuell starte, funktioniert alles ohne Fehler, jedoch wird das Skript nicht wir gewollt und eingetragen alle 5 Minuten automatisch angewendet.


    lg.
    Alex

    [size=10]

    "This is Linux land. In silent nights you can hear the Windows machines rebooting."


  • der cronjob wird nur ausgeführt, wenn EInstellungen in Froxlor geändert wurden.


    Wenn du Daten in die Froxlor DB extern über ein PHP Skript einfügst( wie in deinem anderen Thread geschrieben) musst du noch folgendes einfügen

    SQL
    1. INSERT INTO `froxlor`.`panel_tasks` (`type`) VALUES ('1');
  • Fast richtig. Der Crojob wird theoretisch immer ausgeführt nur ob das Skript von Froxlor eine Aufgabe für den Cronjob hat ist die Frage.


    Der Cronjob an sich wird ausgeführt, dies habe ich getestet indem ich von diesem in eine Textdatei schreiben ließ, dies funktioniert. Jedoch die Konfiguration von neuen vHosts funktioniert nur wenn ich den Cronjob bzw. das Skript von Froxlor manuell anstoße.



    lg.
    Alex

    [size=10]

    "This is Linux land. In silent nights you can hear the Windows machines rebooting."